Resolved Apple Mail suddenly broken

Discussion in 'Mac Apps and Mac App Store' started by v1nsai, Jan 27, 2014.

  1. v1nsai, Jan 27, 2014
    Last edited: Jan 29, 2014

    v1nsai macrumors newbie

    Joined:
    Jul 21, 2012
    #1
    I've happily used Apple Mail since the day I got my first Mac, but this morning when I tried to send an email, it told me that "The server smtp.gmail.com cannot be contacted on the default ports".

    I have it set to use gmail's imap server to retrieve email, and that doesn't seem to be working either. I've disabled SSL, tried using the Apple TLS certificate and I can ping gmail's smtp and imap servers no problem. I even tethered my laptop to my phone and tried to connect from there just in case it was a router problem, but no dice. The console just logs:
    Code:
    1/27/14 8:36:40.850 PM Mail[744]: Metadata.framework [Error]: couldn't get the client port
    1/27/14 8:28:51.240 PM Mail[744]: [LogSocketErrors] Connecting failed for socket: 0x6000004cfab0, error: Error Domain=NSPOSIXErrorDomain Code=65 "The operation couldn’t be completed. No route to host"
    1/27/14 8:28:38.117 PM icbaccountsd[824]: -[ICBLocalDictionary discoverLocalIAAccounts]: Unknown high level account: com.apple.account.mail - F39B13FD-F33F-4EB9-A780-B6495A4C8E94
    1/27/14 8:26:36.426 PM com.apple.preferences.internetaccounts.remoteservice[763]: An instance 0x7fcc4c45cfb0 of class IMAPMailbox was deallocated while key value observers were still registered with it. Observation info was leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:
    <NSKeyValueObservationInfo 0x7fcc4c45d0d0> (
    <NSKeyValueObservance 0x7fcc4c45d060: Observer: 0x7fcc4c45c8c0, Key path: uidNext, Options: <New: NO, Old: NO, Prior: NO> Context: 0x7fff89c8f44b, Property: 0x7fcc49f947f0>
    )
    1/27/14 8:13:50.225 PM sandboxd[429]: ([744]) Mail(744) deny file-issue-extension /Applications/System Preferences.app
    1/27/14 8:13:11.434 PM WindowServer[195]: common_reenable_update: UI updates were finally reenabled by application "Mail" after 4.08 seconds (server forcibly re-enabled them after 1.00 seconds)
    1/27/14 8:13:11.248 PM Mail[744]: Metadata.framework [Error]: _MDAccessCopyClientPort failed retrying
    1/27/14 8:13:07.846 PM Mail[744]: Metadata.framework [Error]: MDPlistContainerRef _MDCopyCompleteFlatSchema(int): couldn't fetch complete schema from server ((ipc/send) invalid destination port)
    1/27/14 8:13:07.287 PM Mail[744]: No more available unread queries. Unread query not created for <MFMailbox:0x7fec2252bce0 (relative path=Gray, attributes=0, displayName=Gray uuid=flag-6)>. Setting unread count to 0.
    1/27/14 8:13:07.286 PM Mail[744]: Metadata.framework [Error]: Failed to get task count with error (null)
    1/27/14 8:13:02.143 PM sandboxd[429]: ([744]) Mail(744) deny file-write-create /Library/Mail/Bundles (Disabled)
    
    I know it just looks like my laptop isn't online, but I swear it is! I have LittleSnitch but disabling the network filter and OS X firewall does no good.

    I downloaded Inky and it seems like a good email client, but I'm a little worried by this. It was working fine yesterday, and I haven't installed or modified anything since then, so why would it just break all of a sudden? I've downloaded Avast! and I'm going to scan my system, this is really fishy. This sort of thing happens constantly in Windows, but on Unix-based systems things have never just broken on me for no reason like this. Makes me think malware.

    Just wanted to ask if anyone else has had this happen to them recently and if there is anything else I can try. Help appreciated. Will post if I find a virus or anything
     
  2. shinji macrumors 65816

    shinji

    Joined:
    Mar 18, 2007
    #2
    Did your ISP start blocking port 25? Plenty of ISPs do. Try changing to 587 in prefs.

    I really don't think it's malware.
     
  3. v1nsai thread starter macrumors newbie

    Joined:
    Jul 21, 2012
    #3
    After hours of nmapping ports, PRAM resets, starting new accounts and every other kind of test, I simply restarted (without making any changes like resetting PRAM) and it started working again. I'm a little nervous about this, but hell it's working :D
     

Share This Page