apple mail won't send

Discussion in 'OS X Mavericks (10.9)' started by vexorg, Nov 21, 2014.

  1. vexorg, Nov 21, 2014
    Last edited: Nov 21, 2014

    vexorg macrumors 6502a

    Joined:
    Aug 4, 2009
    #1
    Bit of a strange one. We had to change mail server hosts due to an upgrade. This was an ISP host change and the email address has not changed.

    The email was off line for a day and then we were told it all is now working. The email is IMAP and SMTP over SSL. Previously this worked fine on my macbook pro, outlook 2010 on the PC and iPhone.

    After being told today that it is all up and running, I set it up on all three. It works perfectly on outlook and the iPhone. It works for reading email on the apple mail, but the apple mail refuses to send any emails.

    I've checked the settings about a dozen times, clear the keychain for the email. deleted the SMTP server and added a new one. It refuses to send. According to connection doctor ir failed to get a response from port 465.

    The PC and iPhone are both on the same local network have the same IMAP/SMTP set up (on port 465) and work perfectly.

    What is wrong with the apple mail?

    Apple mail version 7.3, OSX 10.9.5.
     
  2. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #2
    Also deleted the whole account on the mac and it made no difference when set up again
     
  3. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #3
    And to top it off, outlook on the mac can send and receive perfectly. Looks like apple mail will be getting ditched.
     
  4. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #4
    The "clue" here is that you say you cannot *send.*

    So, here is my guess:

    You are using an internet service like Comcast, and over the years, in my experience, when all of a sudden I cannot SEND mail over Comcast, what that usually means is that I am not using COMCAST'S own SMTP server.

    So, let's say you have your own domain ("myOwnDomain.Com"), and your webhost says "use smtp.myOwnDomain.Com" for your email server. That works fine until Comcast says, "nope, you have to use OUR servers to send mail." So then you have to go in, use the port that Comcast recommends (I think it's 597 or something), and have it use secure password authentication, where you have it use your Comcast username and Comcast password, etc., to send mail.

    That's what's happened to me a zillion times. So, I simply switch it to the Comcast server details, and everything's fine.

    That's my guess.

    Now, the REAL way to figure out the problem is to do this:
    1.) Completely quit Mail (and all other apps).
    2.) fire up Console (located in Applications/ Utilities) and have "Show ALL system messages" checked. Put that on the left side of your screen.
    3.) fire up Mail, put it on the right side of the screen.
    4.) Now, create and SEND a message, and then watch all the stuff that Console complains about.

    That's where you can find out exactly what's going wrong.

    But, my guess, it's just a simple "outgoing server" settings issue.

    The neat thing is that if you have MULTIPLE email accounts, once you've saved a good and correct outgoing server setting, you can keep selecting that exact same setting for all your email accounts (because as far as email, your computer, the recipient, etc., it doesn't matter / they don't care /they don't even notice whether you are using Comcast, or your own domain, or whatever outgoing server.
     
  5. bobdamnit macrumors regular

    Joined:
    Mar 26, 2014
    #5
    If the ISP was only blocking Mac (or more specifically, Mail.app on Mac, because Outlook on the SAME Mac can send email) computers from sending mail, then they'd have a lawsuit on their hands. As this is only happening on a Mac computer and not the iPhone or Windows based computer, this is kind of what you are implying is indeed happening though.

    Since the other devices CAN send emails as well as the Mac in question using Outlook, it clearly cannot be Comcast's fault, unless they somehow took over the OP's Mac and modified it to reflect this, and again that's a massive lawsuit.

    In other words, we can probably rule out Comcast. Most likely its a setting in Mail that got forgotten, like you said.

    You seem to be confused how email accounts work. The SMTP server you use will always be different for each provider. Gmail is different than Hotmail, etc... You can't use "Comcasts" SMTP server for all of them, because it will only work for Comcast accounts. Your Gmail account would be like "Huh, WTF? I quit." and send or receive no mail at all if you used Comcast's SMTP server.
     
  6. vexorg, Nov 22, 2014
    Last edited: Nov 22, 2014

    vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #6
    I do have that ISP problem when sending from home. My ISP is Orange in the UK, they block port 25. The workaround before was to use SSL on port 465, this has always worked and does still work.

    If I change any of them to port 25 for sending then it fails.

    I can use port 25 through my ISP (orange) smtp mail server, but this is a pain as every email pops up and asks what outgoing server would I like to use AFTER it times out. Port 465 took away that grief.

    As bobdammit says, that can't be the problem here as other devices and even a different mail program on the same macbook can still send emails with the new mail server config.

    It is as if the new mail server is refusing apple mail connections for sending. There aren't that many options to overlook, it's quite limited. It was working before, and all that's been done for all devices was to change the host name.

    On the mail.app, it's not even getting as far as asking for the password for the account. The connection doctor gets no response from port 465, the log file only has 2 lines, open port and connection made, then nothing else. The IMAP connection in the log as the same two lines then a whole list of comms back and forth.
     
  7. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #7
    Console give this error message when I try to send:

    22/11/2014 11:42:53.161 Mail[1350]: CFNetwork SSLHandshake failed (-9807)

    No error listed when outlook sends.
     
  8. bobdamnit macrumors regular

    Joined:
    Mar 26, 2014
    #9
    I've never heard of an ISP forcing their users to use their own SMTP server for mail, however I'm not familiar with how UK service providers operate. Perhaps that is the norm there, and I was not aware.

    I have to assume that you have added the account information in here (Mail > Preferences > Accounts): [​IMG]

    Which also added the information here (System Preferences > Internet Accounts): [​IMG]

    But did you edit the SMTP server list in Mail.app? In the first screenshot, you will see a menu at the bottom for "Outgoing Mail server (SMTP)". From that, you can edit the SMTP server for the account you have setup and add how you need to have it setup.
    [​IMG]

    If you have Mail.app setup properly, then I can only assume that the mail server is at fault and not Mail.app.

    Good find! Those might help setting up Mail.app properly.
     
  9. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #10
    That's all setup right. Only the imap and smtp server names were changed in the account details, that's all I done for the PC and iPhone too.

    I've been using apple mail for around 5 years now, and using email for 20 years, I wouldn't say I was a newb at setting it up. I can't see anything set wrong, especially as it's saying the server refused to handshake.

    Regarding the UK ISPs, some block the SMTP servers to prevent bulk spamming, they are locked to their customers and they can track who is responsible.

    For now it looks like it'll be outlook on the mac.
     
  10. Lodesman, Nov 23, 2014
    Last edited: Nov 23, 2014
  11. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #12
    May have part solved this problem. The MX record for the new server is an alias to the real smtp server. If I use the real server name then it works. What i don't understand is why the mac can't use the alias and all others on the same local network can use the alias with no problem.

    The mac must be resolving the name differently somehow.
     
  12. GHM macrumors newbie

    Joined:
    Apr 22, 2004
    #13
    Won't even connect? Certificate issue!!

    Thanks for this thread - the final note that the MX record is for a different domain to the actual server triggered the solution for me. I had been going crazy seeing all other mail clients able to connect to the SMTP server but not Apple Mail - on two different Macs running two different versions (10.9/7.3 and 10.10/8.0).

    The crux is that Apple Mail does not always throw up the screen that warns you about the server certificate not being valid for the server name you're connecting to. (ie. in the background the connection attempt just sits waiting for you to respond but you were never given the screen) But if you quit Mail and then reopen it (maybe a few times) you should get the non-matching certificate warning. In this screen don't just click Continue - instead show the details then tick the box that says to always allow for this server/domain. Then you can click Continue.

    Hope that helps somebody else :)

    KiwiGraham
     
  13. markusonmbp macrumors newbie

    Joined:
    Jan 5, 2015
    #14



    Hi vexorg,

    Please can you give a hint about, what the alias was and then the corresponding real server name?

    Many thanks in advance.

    Kind regards,

    Markus
     

Share This Page