Apple Mail's equivalent to Gmail's "send mail as"

Discussion in 'Mac Apps and Mac App Store' started by Perceptes, Oct 2, 2008.

  1. Perceptes macrumors member

    Perceptes

    Joined:
    Mar 24, 2003
    Location:
    San Diego, CA
    #1
    Hi all,

    I use Apple Mail as a client for my Gmail account instead of Gmail's web interface. There is one thing the web interface provides that I'm not sure how to set up within Apple Mail.

    In the web interface under Settings --> Accounts, the first section is called "Send mail as:" and allows you to send mail from the interface that uses another email address in the From header. I have it set so that when I receive a message that was sent to one of these other addresses (they all forward to my Gmail address), replies will automatically be sent with that address as the From header.

    How do I set up this functionality within Apple Mail without creating a separate account/inbox for the other accounts? I am not checking mail directly from the others, just want to be able to send as them.

    Thanks in advance!
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    That functionality is not, as far as I know, available in Mail. You can add them and just not check the mail in them, but you can't add just their outgoing information.

    I suppose it might be possible with a bit of a workaround, though I haven't tried this. Setup the SMTP server for each service (some SMTP servers allow you to send mail from any address, but if they require a username and password you'll need this step), then add the email address to the account information screen, separating it from the main address for the account with a comma. When you send a message, you'll need to choose the email address from a drop-down box, and the appropriate SMTP server from the next box. The mail should be sent from that address just fine. I don't think there will be a way for it to automatically choose the appropriate email address and server.

    jW
     
  3. prostuff1 macrumors 65816

    prostuff1

    Joined:
    Jul 29, 2005
    Location:
    Don't step into the kawoosh...
    #3
    do some searching in gmails help docs. I know this can be done as i have it set up to do this.

    I have a gmail account that all my school mail is forwarded to. I get this in mail by checking the gmail account. If i see that mail has come from my school address i can reply like i am sending from that address.

    i will try to explain it without looking at the exact directions:
    1. In the web interface add all the account you would like to send as.
    2. Go into mail and add the mail account that all those come to. and in the e-mail address line put: xxxx@gmail.com (<-- this is the main account), xxxx@osu.edu (<-- one of the send as accounts), etc.
    3. And the way i understand it as ong as you select the xxx@osu.edu account and send it via the smtp.gmail.com outgoing mail server gmail will see the e-mail address and adjust itself accordingly.

    Hope that helps
     
  4. Perceptes thread starter macrumors member

    Perceptes

    Joined:
    Mar 24, 2003
    Location:
    San Diego, CA
    #4
    Thanks! This worked for sending mail out from another address. As for having replies automatically set to send from the address the original message was sent to, that is still unknown, and apparently may not be possible at all.
     
  5. Pomeroy macrumors 6502

    Pomeroy

    Joined:
    Sep 27, 2008
    Location:
    Arkansas
  6. Perceptes thread starter macrumors member

    Perceptes

    Joined:
    Mar 24, 2003
    Location:
    San Diego, CA
    #6
    I noticed that option, but in my case there is only one mailbox so it won't quite work. Thanks for looking. :)
     
  7. Pomeroy macrumors 6502

    Pomeroy

    Joined:
    Sep 27, 2008
    Location:
    Arkansas
    #7
    No Problem.. I have several mailboxes, but replay to most from one address.
    If I want to change it I just select it as I compose it , just under the Subject line, just before I send it..
     
  8. Perceptes thread starter macrumors member

    Perceptes

    Joined:
    Mar 24, 2003
    Location:
    San Diego, CA
    #8
    Perhaps Automator could be used to do it... None of the built in actions do it so I'll have to look into how to write one myself.
     
  9. zeromarc macrumors newbie

    Joined:
    Oct 28, 2008
    #9
    prostuff1 is right on the money

    Hey Perceptes,

    I am using Mail 3.3 on Leopard 10.5.4 and the solution described by prostuff1 is essentially equivalent to the gmail webmail functionality. Just string the addresses together in the Mail account settings next to "E-Mail address" with commas. Then when an email is received at x@example.com through gmail, the Mail app defaults to reply with x@example.com. Also, if you receive a message at lets say z@example.com and it is not listed in "E-Mail address" then the reply address in Mail.app defaults to the first listed address in the "E-Mail address" field. Even then you can change the address using the drop-down menu.

    I found this thread looking for the same advice you were looking for. So, try again its working great on my Mail.app.
     
  10. leisgean macrumors newbie

    Joined:
    Feb 23, 2009
    #10
    new, extended issue on this

    I had a similar problem and y'alls 'comma' suggestion worked. Problem is my messages now take a very consistent 12 minutes to send using Apple Mail. Here's my setup: I have a gmail account were I get my mail forwarded to from an exchange account (because the exchange account has a crappy storage limit). I use Apple mail to read and write e-mails and followed the above direction as best I could to get Apple mail to send messages that said they came from my exchange account and not my gmail account. The way it works right now is I receive mail in apple mail from gmail which originally came from the exchange account and send mail using Apple mail, by way of the gmail account, through the exchange server (using the comma trick) and the sent messages get stored on gmail. but yea, this takes 12 minute for the mail to actually get sent. anyone know why this is?
     
  11. risingtiger macrumors newbie

    Joined:
    Oct 1, 2009
    #11
    worked great

    Thank you so much for this post.

    I simply added the email I wanted to send mail as in the email address of the account settings in Preferences of Snow Leopard Mail and so far I am able to send like a charm. I don't notice any delay and things are syncing up well in gmail (granted that I am sending via gmail's SMTP server).
     
  12. akonikui macrumors regular

    Joined:
    Jun 30, 2007
    #12
    I have a primary gmail address and a school email address that automatically forwards everything to my gmail.
    Adding the school email as a regular account in Mail worked perfectly. When composing emails, I can choose which outgoing mail server sends it.

    Snow Leopard, Mail 4.1
     
  13. DJLanglois macrumors member

    Joined:
    Aug 21, 2008
    #13
    I just wanted to say "Thanks a billion!" for the comma trick. Works like a charm.

    Now I can send e-mails in Mail.app from any of my accounts, even though I only have my main Google/IMAP account set up as an actual account. And, better than that, the default respond-from address is whatever address the e-mail I'm responding to was sent to. And, even better than that, e-mails I send form my non-Gmail account still show up in my Sent folder on the IMAP server. Pretty hot stuff.

    So, really, thanks a million. I really appreciate it!
     
  14. treaders macrumors newbie

    Joined:
    Jul 30, 2010
    #14
    Really appreciate the "comma" advice. Thank you.
     
  15. Boris A macrumors member

    Joined:
    Jun 9, 2008
    #15
    I have a similar problem (with Mail 4.4) but don't seem to understand your solutions. The situation step-for-step:

    1. Have an external hosted server with mail at one.com
    2. Have the one-mail forwarded to personal gmail.com
    3. Have "sending as" the one.com e-mail set up within GMail, so I want to be able to send as the hosted mail address from Mail also without going through web clients
    4. I still can't use the "send-as" address with my personal address in Mail, there's no such option in sight

    Know this to be possible somehow and seem to have tried everything but to no avail so far. :(
     
  16. Rob9874 macrumors 6502

    Joined:
    Jul 19, 2010
    #16
    I just figured it out myself. Go to Mail> Preferences> Accounts. It will show the gmail account you have set up. Next to your gmail.com email address, type a comma and then the other email you want to send from. Save, and now when you compose an email, there is a drop-down you can select which account to send from.
     
  17. Boris A macrumors member

    Joined:
    Jun 9, 2008
    #17
    I made the change you described, saved, and re-started Mail. While both addresses still display in the e-mail field in preferences > accounts > account information, the drop-down menu in the send new mail window yields no new options.
     
  18. jonathan999 macrumors newbie

    Joined:
    May 12, 2010
    #18
  19. Xystence macrumors regular

    Joined:
    Apr 17, 2010
    #19
    Ok I got all this working, the problem I have is all the email now comes from the same persons name that is in the description field. So for my website I have help@domain.com, billing@domain.com

    So because I have "Domain Help" as the name of the account, when I send from the billing address, it shows as "Domain Help" as well.

    Has anyone found a solutions for this?
     
  20. jonathan999 macrumors newbie

    Joined:
    May 12, 2010
    #20
    Not quite...

    Well, I thought I had this one figured out. But someone kindly posted a comment to my blog post about this procedure saying that whilst it all looked good, the actual mail is still going out with the primary email address in the From field, even though a secondary address is being selected before sending the message.

    So… I've got the secondary (and more) addresses appearing as an option in the FROM drop down, it does not matter which one I select. The mail will still appear to come from the primary account. :(

    Has everyone who said this "comma" solution worked for them, actually sent them self an email to confirm it is in fact working right the way through?

    Any suggestions? So close… :confused:

    Jonathan
     
  21. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #21
    just to clarify on your first point above, are you refering to the email address of primary or description

    ie

    My name on account is MY.Full.Name
    I have 2 email address associated with this, separated by commas

    me@gmail.com & me@domain.com

    when I send an email using either of these options, the account name doesn't change, just the email address, so the recipient would see either

    MY.Full.Name <me@gmail.com>
    or
    MY.Full.Name <me@domain.com>
    or just
    MY.Full.Name

    all depends how the client is set up, but it should have the email address correct

    for me, it shows MY.Full.Name as the sender in my inbox, but if I open the mail it shows this with the email address
     
  22. jonathan999 macrumors newbie

    Joined:
    May 12, 2010
    #22
    Have you tested that this is in fact working, by sending yourself a message? :confused:

    With regards to your question… I am not sure there will be a way around that, because there is only one place to put a name.
     
  23. jonathan999 macrumors newbie

    Joined:
    May 12, 2010
    #23
    Thanks Paul,
    I am referring to the email address. The name is the same either way… but when I check the actual email address it will also be from the primary email address as opposed to any of the other ones I loaded in there with commas between.

    Currently working on resolving this. Will post back if I figure it out.
     
  24. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #24
    the only possible solution I found for this is to remove your full name from the account page, then when you send it will just show the email address
     
  25. jonathan999 macrumors newbie

    Joined:
    May 12, 2010
    #25
    Figured it out

    Okay… I figured out the issue I was having.

    I have a few gmail accounts, and I'd mixed up which ones I was using for what, with regards to sending/receiving mail from other non-gmail accounts. Sorted that out, and working fine.

    Thanks for the help and info on this discussion :).
     

Share This Page