Apple Maps data not loading on iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nickponty, Oct 12, 2012.

  1. nickponty macrumors newbie

    Joined:
    Mar 21, 2012
    #1
    For some reason I can't see any map data on the maps app on my new iPhone 5. It worked when I first got it, but not now. Any ideas what might be wrong and how I might fix it? I've tried a hard reset, but to no avail.

    This is all I see, on standard, and on hybrid/satellite views.

    Standard (all I can see is National Parks!)

    [​IMG]

    Hybrid/Satellite

    [​IMG]
     
  2. jimmy575 macrumors member

    Joined:
    Oct 11, 2012
    #2
    Try closing the app (http://support.apple.com/kb/HT4211).

    Try reset network settings.

    Try reset all settings.

    Try restoring phone through iTunes.


    These are the steps I would try, in order.
     
  3. Joshuaaargh macrumors newbie

    Joined:
    Apr 9, 2013
    #3
    Hey did you manage to get it fixed? I'm having the same problem but can't fix it!
     
  4. Mrfatboy macrumors 6502

    Joined:
    Dec 15, 2008
    #4
    I'm having same issue. All apps that have maps in them (apple maps, around me, papa johns pizza, etc) will not load any map data. Google maps works fine.

    Any ideas?
     
  5. Mrfatboy macrumors 6502

    Joined:
    Dec 15, 2008
    #5
    A restore from backup was the only thing that solved the issue.

    FYI I just was in Cancun and had a telcel SIM card in my phone. I thinking that caused the problem. Maybe apn settings didn't get set back to default or something when I put back my Verizon sim.
     

Share This Page