Apple Music and iCloud content not showing on iPhone

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by JarScott, Jul 4, 2015.

  1. JarScott, Jul 4, 2015
    Last edited: Jul 5, 2015

    JarScott macrumors 68040

    JarScott

    Joined:
    May 19, 2011
    Location:
    United Kingdom
    #1
    I have Apple Music and iCloud Music Library turned on, on my iPhone, yet it's not showing any of the music I have in iCloud or any of the albums I've added to Apple Music (on iTunes). I'm wondering whether this is because I had the 'show all music' option turned off, but that seems to have disappeared from settings in 8.4.

    For example, I've created a playlist on iTunes which includes music I own and tracks from Apple Music. When viewing said playlist on my iPhone, the only tracks listed are ones I own with complete disregard for any Apple Music content. The 'My Music' section of the Music app, again, only shows music owned by me and synced with the device. All Apple Music content and purchases in iCloud are missed off.

    In short, my iPhone is only showing me music physically stored on my iPhone and entirely ignoring Apple Music or purchases in iCloud. I've gone into every settings menu I can think of, rebooted my iPhone...I'm stuck as to what I should do next. Is this just a glitch with the service?

    Edit: it's also not working on my iPad.

    Edit 2: thanks for helping me solve this! The setting I was looking for is in the drop down menu when you click the 'view selector' button whilst viewing My Music!
     
  2. MacrumoursUser macrumors 6502

    MacrumoursUser

    Joined:
    Mar 1, 2014
    Location:
    Denmark
    #2
    Same here. So i'm download my purchases. At least i will be able to see it in my music. Complete iCloud meltdown.
     
  3. Paco II macrumors 65816

    Joined:
    Sep 13, 2009
    #3
    From your description, it kind of sounds like Apple Music isn't actually enabled on your phone.
     
  4. JarScott thread starter macrumors 68040

    JarScott

    Joined:
    May 19, 2011
    Location:
    United Kingdom
    #4
    That's what I was thinking too, but I've also tried switching it off in settings, rebooting, and switching it back on. Same results.
     
  5. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #5
    If I understand the problem correctly: Select My Music and then the type selector (Artists, Albums, etc.). At the very bottom of the list is the "Show Music Available Offline" option.

    DS
     
  6. flur macrumors 68000

    Joined:
    Nov 12, 2012
    #6
    The option to show music not in the phone (music in the cloud) still exists. It's in the sort drop down.
     
  7. JarScott thread starter macrumors 68040

    JarScott

    Joined:
    May 19, 2011
    Location:
    United Kingdom
    #7
    It worked! It's a bit hidden away now but I'm glad I found it! I can now see all music.
     

Share This Page