Apple Music not working after iOS 8.4.1 upgrade - asking to join

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Kositch, Aug 25, 2015.

  1. Kositch macrumors newbie

    Joined:
    Mar 2, 2013
    #1
    Hello,

    last week I have updated to iOS 8.4.1 and since then I am not able to use Apple Music. When I open Music app and I want to play something from "For You" section or "News" or "Radio" - windows pops up asking me to join and register to Apple Music. When I click "later" or "Register to Apple Music" the Music app freezes.

    When I restart my iPhone, everything works, but after a while (hour or so) it happens again asking me to join Apple Music. I have tried to disable Apple Music iCloud in settings, reenable it, but the problem persists.

    What I can only play are songs from My Music section I have already downloaded to my iPhone.

    It is doing also on my iPad with iOS 8.4.1. So I think it is somehow account related with connection to new iOS 8.4.1. I dont have problem on iTunes on my iMac.

    I have iPhone 5S and iPad Mini 2, both running on iOS 8.4.1.

    Any help? I am little bit frustrated, because I liked Apple Music service.

    Thanks!
     
  2. markhort macrumors 6502a

    markhort

    Joined:
    Aug 28, 2010
    Location:
    UK
    #2
    A few people now have reported this issue. Same thing has been happening to me since Friday last week.
     
  3. Mad4WDW macrumors regular

    Joined:
    Apr 5, 2010
    #3
    Welcome to the long line of people who are fed up with this "service " it's a disaster zone. I've tried to persevere with it since day 1 but it's just becoming increasingly unusable. It just doesn't work properly. Even simple things like syncing a playlist is a mess.
     
  4. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #4
    It's not the service, it's the 8.4.1 update...it's horrible!
     
  5. Yaboze macrumors 6502a

    Yaboze

    Joined:
    May 31, 2007
    Location:
    The Garden State
    #5
    I had this issue before 8.4.1 and restarted my phone, it then worked OK.
     
  6. Mad4WDW macrumors regular

    Joined:
    Apr 5, 2010
    #6
    I works for a short while after a reboot then goes belly up again. Mines intermittently getting better regarding the music settings and app store problems. The iCloud music problems are persistent though. Smart Playlists on my iPhone, iPad and Mac are all mismatched, like I mean the same playlist on each device is *completely* different.
     
  7. chrishasaflavor macrumors newbie

    Joined:
    Aug 24, 2015
    #7
    I had this problem as well, and I've just come back from the apple store where they appear to have fixed things.

    Try to check the diagnostic logs. After two days since the latest restore, I had hundreds(!) of entries.

    What the apple store employee did was restore my phone after putting it into DFU mode. He claimed that the softer restore option in iTunes does not effect the firmware.
     
  8. Amaze macrumors newbie

    Joined:
    Mar 16, 2013
    #8

    After rebooting your iPhone sign out from:
    • iCloud
    • iTunes and appstore

    Worked for me. Except Apple Music lost all "my music" !! Only empty playlists and U2 album. FU Apple, welcome spotify
     
  9. TsMkLg068426 macrumors 65816

    Joined:
    Mar 31, 2009
    #9
    Time to fire Tim Cook and hire someone like Steve Jobs who understands the importance of things working before putting things out in the public and someone who understands the future of tech innovation. Tim Cook is just some boring guy whose vision is lame as a dog turd during hot summer.
     
  10. jonhlutke macrumors member

    Joined:
    Apr 20, 2015
    #10
    how much of a **** in the bed is Apple Music?
     
  11. MrMoonUK macrumors member

    Joined:
    Jun 2, 2015
    Location:
    UK
    #11
    yeah I get this, I can't seem to fix it, nothing works permanently it always comes back to asking me to subscribe every day now it will stop playing music and give me this ****
     
  12. petsounds macrumors 65816

    Joined:
    Jun 30, 2007
    #12
    Yup, this has been happening to me also since last Friday, on both my 5s and iPad Air (both on 8.4.1). Reboot fixes it for a while. My guess is some authentication token isn't getting updated properly, so the API calls to AM eventually fail. They really should have labeled this trial period a Beta.
     
  13. Fuchal macrumors 68020

    Joined:
    Sep 30, 2003
    #13
    Same issue here and multiple others in my workplace. Not limited to Apple Music though - anything iTunes store is affected, including app store and iCloud. Need to reboot all the time. Ended up upgrading to iOS 9 beta which resolved the issue.
     
  14. mconk macrumors 6502

    mconk

    Joined:
    Mar 10, 2009
    Location:
    Virginia
    #14
    I have an iPad Mini hanging up on the wall in my bathroom. It is not signed into any services, with the exception of Apple Music. Since 8.4.1 I am seeing the exact same issue as the OP.

    I've noticed it will also freeze when going into settings. It looks like AM is confused because I'm not signed into iCloud, but then again when trying to go through the prompts for an Individual subscription, it just gets stuck EVERY TIME. I can reboot, launch AM, and the cycle repeats. Even though all of my playlists and music are showing, if I click on anything it will either take about 15min to start playing (literally) or will go through the process above. Very strange. This is the first device I've added (or tried to add) on 8.4.1 after signing up for AM earlier this month - so maybe there's an issue with devices attempting to enroll on this build. I've got another iPad, Mac and iPhone on iOS 9 betas & El Cap that are running AM just fine.

    Here's where I'm at right now after tapping 'Individual'.

    Sigh.
    image.jpeg
     
  15. Kositch, Aug 27, 2015
    Last edited: Aug 27, 2015

    Kositch thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #15
    OK, it seems it is really backend problem, not SW or HW related. Only we can do is to wait until Apple fixes this issue and I am overwhelmed by how long it takes to them fix this major issue!
     
  16. MICHAELSD macrumors 68040

    MICHAELSD

    Joined:
    Jul 13, 2008
    Location:
    NJ
    #16
    8.4.1, or whatever the cause is, is completely ruining the service for me. Songs not playing, incorrect songs playing, radio not loading, etc.
     
  17. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #17
    Just happened to my partner today. I'm not experiencing it with 9.0 so I might just have to put her on the public beta.
     
  18. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #18
    FWIW Resetting all settings on both my iPad and iPhone seems to have resolved this problem (time will tell)--not only AM and iCloud problems in general but also battery usage problem (which seemed to be directly related to iCloud--possibly IOS continually "calling home" and not getting the right answer.
     
  19. From A Buick 8 macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #19
    Well I restored as new over the weekend (for battery drain issue), however today I am still plagued with the "asking me to sign into AM" issue. Sometimes closing out the music app will fix it but most times it takes a restart. Each time though it is just a temporary fix, because it keeps coming back. I think I may try the iOS9 Beta
     
  20. MrMoonUK macrumors member

    Joined:
    Jun 2, 2015
    Location:
    UK
    #20
    i restored as a new iPhone and its still happening, I would update to is beta to cure this, but i need all day battery and ios9 made my iPhone 6 run hot and eat battery. This ruins apple music for me, its worthless now
     
  21. ascender macrumors 68000

    Joined:
    Dec 8, 2005
    #21
    This seems like a really fundamental problem with the service which makes it useless. I'm having the same issue frequently on my iPhone and iPad which is worrying as i've gone the unenviable task of being responsible for party music this weekend and at the moment i can't get a playlist to work every time.
     
  22. From A Buick 8 macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #22
    I think if you make sure all of the songs are on your phone, then set up your phone to "Show Music Available Offline" it should work (I think)... maybe
     
  23. From A Buick 8 macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #23
    I am going to try out the iOS 9 beta tonight and I will report back.
     
  24. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #24
    So far resetting all settings has been the fix for me--holding strong for me on both my iPad and iPhone--battery drain is back to normal and all iCloud functions including AM working fine.
     

Share This Page