Apple Music Not Working Over LTE

ssimonvii

macrumors regular
Original poster
Jul 29, 2012
166
35
Hey Guys,
I was messing with Apple Music all of yesterday with wifi and had no problems.

I tried using it in the car today and couldn't get anything to load. Restarted my phone, confirmed cellular data is on, etc. I found the only way I can get it to work is by enabling my VPN. I'm wondering if the carriers are maybe placing blocks on Apple Music?

I'm in AT&T w/ unlimited data in CA, USA.
 

Cameront9

macrumors 6502a
Aug 6, 2006
800
99
I think it could just be buggy. mine worked fine on LTE this morning, but this afternoon refused to play. Tried to sign out and sign back in, but it wouldn't let me. Finally accepted my login about an hour later. Lots of bugs.
 

fr4c

macrumors 65816
Jul 27, 2007
1,254
130
Hamster wheel
Ran into the same situation as well. Worked fine this morning, then on the way back home it just refused to work. Eventually it just gives me a connection timeout error.
 

ssimonvii

macrumors regular
Original poster
Jul 29, 2012
166
35
Found a thread on the Apple support forums, although, it sounds like some users had cellular data off for it.
 

ecschwarz

macrumors 65816
Jun 28, 2010
1,304
257
I haven't enabled Apple Music yet, but I'm unable to stream iTunes Match items over LTE (or "4G" also) right now - seems it's some bugginess, as when I turn on wifi, it immediately works. I was on the 8.4 betas and didn't have any issues, so I suspect it's something on Apple's end.

I also have cellular data turned on.
 

Donoghan

macrumors regular
Aug 25, 2008
114
29
Atlanta, GA
Same here. Cellular is on, but nothing is working on LTE. I can stream things from my library that aren't stored on the device, but For You, New, and Radio are all blank white pages.
 

Ty3009

macrumors newbie
Oct 19, 2009
7
0
I'm can't connect to a WiFi network to verify at the moment. But I'm experiencing issues. Cellular data is enabled for Music. The "For You", "New", "Radio", and "Connect" tabs will only load occasionally. And when they do, none of the tracks are available for streaming.
 

ssimonvii

macrumors regular
Original poster
Jul 29, 2012
166
35
I tried toggling use cellular data in settings --> itunes and app store. It seems to have worked. Will report back with any other news.
 

Ty3009

macrumors newbie
Oct 19, 2009
7
0
I tried toggling use cellular data in settings --> itunes and app store. It seems to have worked. Will report back with any other news.
Ah. That corrected the issue. Strange that there's a separate toggle for using cellular data in both "Settings --> Cellular" and "Settings --> iTunes and App Store --> Use Cellular".
 

deadandalive

macrumors member
Apr 25, 2015
63
41
Yeah, completely buggy. On a multi-state trip & was excited to have it in time but it only works about 20% of the time.

Even while playing albums, songs just randomly stop playing. Happened while I was typing this post

At first I thought maybe i didnt have enough 'bars' or that i was in an area with limited/no data coverage but every time I checked, i had 3 or 4 Bars and LTE

Also had trouble adding stuff to my Library yesterday. Said it worked multiple times but didnt.

When I did manage to get stuff in my Library on my iphone, it didnt transfer automatically to my ipad. It wont merge the Libraries, even though it said it would. And if i add stuff on one device, it does not automatically go to the other

Glad i am not paying for this
 

deadandalive

macrumors member
Apr 25, 2015
63
41
Its also randomly bringing up a screen asking me to join Apple Music, even though i joined yesterday
 

BigInDallas

macrumors regular
Oct 13, 2014
218
111
Connecticut
Thankfully Apple should iron out these problems before we have to pay.

I joined AM not expecting much, but this may make me go all streaming.
 

ecschwarz

macrumors 65816
Jun 28, 2010
1,304
257
Ah. That corrected the issue. Strange that there's a separate toggle for using cellular data in both "Settings --> Cellular" and "Settings --> iTunes and App Store --> Use Cellular".
This didn't seem to work for me - I suspect with the issues a few people are having with any sort of streaming (iTunes Match or Apple Music), something is messed up on Apple's end if the right switches are flipped on said devices.
 

mojo522

macrumors newbie
Jun 8, 2009
24
12
I'm having the same issue with the iTunes matched portion of my library, it will play two songs then stop on the third and just hang. I've tried resetting network settings and phone and it didn't help. I've also authorized cellular in settings and turned off and on iCloud music. Once I turn on wifi, all is fixed.
 

Primejimbo

macrumors 68040
Aug 10, 2008
3,295
131
Around
How about the settings under
Settings
iTunes & App Store
Use cellular data

Not sure why they have 2 cellular settings.

Edit: I see someone posted this also. Sorry for the repost.
 

chadsteruw

macrumors member
Jul 14, 2007
84
10
Seattle, WA
I've tried what everyone's mentioned already and went one step further and reset network settings. Apple Music worked fine once I did that, while on the cell network. Pleasant music for the ride home from work. Then once I got home connected to my wifi, still all good. Left the house and tried to connect to Apple Music, and it started ok for about two songs, then stopped working. Couldn't stream anything new.

Hope it's on apple's end and can be fixed soon
 

Mindinversion

macrumors 6502
Oct 9, 2008
357
129
As far as I can tell it's completely borked. Sometimes it works, sometimes it randomly stops. I was listening to music while mowing the lawn, and it was fine. Finished, disconnected my headphones, showered, threw my headphones back on, asked siri to play a song, which loaded [after I pulled out and unlocked my phone] to where I last left off in that song [who does that?] I drug it back to the beginning of the song, and it wouldn't play. I unplugged the headphones and it STILL wouldn't play. I said to heck with it, finished what I was doing, got in the car to go fetch my son from work.

It started playing as soon as bluetooth connected.
 

ecschwarz

macrumors 65816
Jun 28, 2010
1,304
257
Just an update - it seems to be working for me now - I did restart my phone (tried that awhile ago with no luck), but all seems well in iTunes Match Land (should be the same with Apple Music, too)
 

mojo522

macrumors newbie
Jun 8, 2009
24
12
I've tried what everyone's mentioned already and went one step further and reset network settings. Apple Music worked fine once I did that, while on the cell network. Pleasant music for the ride home from work. Then once I got home connected to my wifi, still all good. Left the house and tried to connect to Apple Music, and it started ok for about two songs, then stopped working. Couldn't stream anything new.

Hope it's on apple's end and can be fixed soon
Same here, two songs.....then nothing
 

sotojason

macrumors newbie
Jul 4, 2015
1
0
Is anyone experiencing a skipping / hiccuping in the music? Happens to me often while listening to Apple Music in the car. Really like what they've put together, but the buggy streaming over cellular data is frustrating. No cell streaming issues with Spotify or Pandora. Just Apple Music. Glad it's free right now.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.