Marz8

macrumors newbie
Dec 30, 2015
2
1
I just finally noticed an issue with this. Maybe it's been an issue since I upgraded to Big Sur a couple months ago, but I don't know. I mostly use Notes with an MS Exchange account. So Gallery View only works with iCloud. That means no solution for someone like me.

I noticed this on my 2017 13" MBP. Have yet to see it on my Late 2015 iMac 27". This sucks because of how I differentiate my notes between my iCloud account and MS Exchange accounts. May have to look into using OneNote instead. :/ The advantage of that is it's very much like using Notes. For non-iCloud accounts in Notes, the app is very basic.
 
  • Like
Reactions: BigMcGuire
Comment

Ryan G

macrumors newbie
May 6, 2016
2
1
I am first encountering this issue as of today. I just purchased a new MacBook Pro 16" and migrated from my old MacBook Pro 15" (2018) from a time machine backup where I never had this issue and I use Notes quite a bit.
At first, I actually just thought the fans turning on was because I had a Windows machine running in VMWare Fusion but after a while I noticed that Notes was using a lot of CPU and I did a google search, found this thread, switched to Gallery mode and it's gone.
I was running 11.2.3 on my MacBook Pro yesterday with no issues and have this issue today on my brand new MacBook Pro also running 11.2.3
 
  • Like
Reactions: BigMcGuire
Comment

SuperRob

macrumors 6502
Mar 14, 2011
253
4
Happened across this thread when I noticed this on my new M1 MacBook Air and Big Sur 11.2.3. I have an external 4K screen on HDMI set to scaled (2x, so 1080p) and the internal screen set to the last setting (More Space). As soon as I set the internal display to default, the problem went away, even with the external screen still scaled. My guess is by using the 2x retina scaling for any screen, it doesn't cause the problem, because there's no additional scaling that need to happen ... 2x is normal.
 
Comment

BigMcGuire

Contributor
Original poster
Jan 10, 2012
7,323
9,032
the Alpha Quadrant
Happened across this thread when I noticed this on my new M1 MacBook Air and Big Sur 11.2.3. I have an external 4K screen on HDMI set to scaled (2x, so 1080p) and the internal screen set to the last setting (More Space). As soon as I set the internal display to default, the problem went away, even with the external screen still scaled. My guess is by using the 2x retina scaling for any screen, it doesn't cause the problem, because there's no additional scaling that need to happen ... 2x is normal.
Woo hoo! I think you're right! I just set laptop to default and notes back to list view - I cannot get notes to use high CPU. NICE!!!!
 
Comment

SuperRob

macrumors 6502
Mar 14, 2011
253
4
Woo hoo! I think you're right! I just set laptop to default and notes back to list view - I cannot get notes to use high CPU. NICE!!!!
What's weird is the "Default" for the internal screen on the M1 Air is a scaled resolution! (True 2x should be 1280x800; default is 1680x1050.) So I don't think my hypothesis is totally correct, but hey, at least I found a workable solution.
 
  • Like
Reactions: BigMcGuire
Comment

SuperRob

macrumors 6502
Mar 14, 2011
253
4
Follow-Up: When detached from the second screen, my Air goes back to the More Space setting, and Notes doesn't start sucking down CPU. So it's some odd combination of being connected to an external screen AND scaling. I guess I'm not surprised this got past testing somehow. Hopefully Apple can fix it at some point, but it's certainly not a deal breaker. This thing is great.
 
  • Like
Reactions: BigMcGuire
Comment

inkhorn

macrumors regular
Oct 8, 2009
133
65
MacOS 11.4 beta, and this is STILL a bug. :<

Gallery mode (thank you @BigMcGuire), or ensuring the internal display isn't scaled (thank you @SuperRob) are still the workarounds, or my fans come on and a CPU is pinned at 60%.

Submitted with Feedback Assistant as : FB9085744
 
Last edited:
  • Sad
Reactions: BigMcGuire
Comment

ksec

macrumors 68000
Dec 23, 2015
1,737
1,852
There is something seriously wrong with iCloud Syncing in Big Sur.

Safari Bookmark, iClouddagent and Notes all have these same problem.
 
Comment

BigMcGuire

Contributor
Original poster
Jan 10, 2012
7,323
9,032
the Alpha Quadrant
Are those of us who use external monitors that rare? lol. Most of the other Mac owners I know either use their MBP or an iMac so this hasn't affected them. <shrug>.
 
Comment

sameting

macrumors newbie
May 2, 2021
1
3
I don't know if it's a permanent fix but I read @SuperRob 's post and it didn't work for me at first try because i set my display to default resolution under "scaled" radio button. Then and did these steps:

-open notes app and enable list view
-open activity monitor and check notes app's cpu usage (%60)
-open system preferences / display / display tab
-Set resolution to first radio button that says "default for display", not scaled / default

and poof. Excessive cpu usage is gone. Even with reopening and using notes app. I hope this is a permanent fix.

Btw im using my 13" mbp 2017 (Big Sur 11.2.3) without any external monitors right now.

Update: I changed my resolution back to scaled / more space, I updated to Big Sur to 11.3 and restarted my mac and still notes app working quite well without using too much cpu.
 
Last edited:
Comment

hobspain

macrumors regular
Mar 29, 2010
118
84
Bro, checking "use Rosetta to open" for Notes.app decreased the CPU usage for me!

Well, this made it for me. I don't have an external display and I have tried all the suggested fixes for resolution changes on my M1 MBA (11.3.1) and they didn't work at all. Gointo to Rosetta is the only fix that works, which is terribly sad because this is an Apple app that has to go through emulation instead of native in order to work properly and this is quite shameful, to be honest.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.