[Apple Pages] Oh my god. Stop spacing my words out for me!

Discussion in 'Mac Apps and Mac App Store' started by coupdetat, Aug 1, 2008.

  1. coupdetat macrumors 6502

    Joined:
    Jul 11, 2008
    #1
    Does anyone know how to stop this obnoxious behavior? Pages and TextEdit both like to insert extremely variable amounts of space in lines of text following sentences. For example, in one line I will hit space twice, and get a very, very small gap to the next sentence. On the next line, I'll hit space twice and get a H U G E gap. I'm working on a scientific paper and the inconsistent spacing looks VERY bad. I haven't found any way to disable this "feature", does anyone know how to get rid of it?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    It sounds like it's not the program; it sounds like your space bar is sticking. It may need to be removed and cleaned.
     
  3. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #3
    Have you set your text alignment to "justify"?
     
  4. kgarner macrumors 68000

    kgarner

    Joined:
    Jan 28, 2004
    Location:
    Utah
    #4
    Just a thought, do you have have it set to justify both sides of the text (i.e. the text is aligned at both the left and the right)? That usually results in uneven spacing due to trying to accommodate the add amounts of space needed to align both sides.
     
  5. coupdetat thread starter macrumors 6502

    Joined:
    Jul 11, 2008
    #5
    Thanks!! Justify was my problem.

    And no, I think I would notice if my keyboard was sticking :rolleyes:
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    Justified text is not set as the default on any of the templates I've used.

    Either way, you should learn to use Pages' style settings. Once you do, you will become a much, much happier Pages user.
     
  7. coupdetat thread starter macrumors 6502

    Joined:
    Jul 11, 2008
    #7
    I'm not sure how it got enabled, actually. I thought it was default, but I checked my other paragraphs and they were left-justified. Beats me. Maybe I copied justified text from a different app at some point. Thanks for the help though!
     
  8. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #8
    Okay, but seriously open that Styles drawer and learn how to use it. It's really simple to use and very powerful. Learn how to use styles in Pages and you'll never have to worry about weird formatting being inherited from other documents again. You also wonder how anybody could live with the lousy way Word handles styles.
     
  9. BoyBach macrumors 68040

    BoyBach

    Joined:
    Feb 24, 2006
    Location:
    UK
    #9

    Thanks for the tip. I can now say goodbye to formatting and font changes annoying the bejesus out of me!
     
  10. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #10
    I'm the self-appointed styles evangelist around here. Like any good evangelist, I hope beating people over the head with my bible will knock some sense into them, instead of being merely annoying. ;)
     
  11. exegete77 macrumors 6502a

    Joined:
    Feb 12, 2008
    #11
    I can only echo how critical it is to use styles, whether in Pages, Word, Nisus Writer Pro, Mellel, Papyrus, RagTime, OpenOffice, NeoOffice, etc. (I have used them all, as well as Word on Windows).

    I have been frustrated for years with Word users who never use styles, then wonder why they can't provide a consistent product. :rolleyes:
     
  12. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #12
    They don't use styles because Word implements them so poorly. The sad part is these bad Word habits get carried over into Pages, which actually does them well. I don't know that many even wonder why the end product isn't consistent.
     

Share This Page