Apple Pay not working...

Discussion in 'iPhone' started by MusicEnthusiast, Sep 28, 2015.

  1. MusicEnthusiast macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #1
    I'm having issues with Apple Pay. So far I've only taken it to two different McDonald's locations and experienced the same issue as before. My Apple Pay is set up with two cards and is activated in settings. I move my phone to the terminal and Apple Pay comes up automatically. Lightly resting my thumb on the Touch ID attempts to read the finger for payment and then it shows an ! stating that Touch ID or a passcode is required to pay. What's the deal? I tried both thumbs that are registered to the phone, bringing the phone to different levels of height and even letting the phone touch the terminal, with and without my case. Nothing is working :( the nfc chip is working just fine since Apple Pay comes up automatically.

    Any help here, I really want to try using it. Thanks guys!
     

    Attached Files:

  2. sluggozmom macrumors 6502

    sluggozmom

    Joined:
    Sep 13, 2011
    Location:
    Massachusetts
    #2
    Not sure if it's the same thing... Last week at McDonalds I couldn't make my apple Pay work either.. After 5 or 6 tries someone else came over and told me to select credit or debit on the pad ..worked! Can't remember having that happen before
     
  3. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #3
    I didn't try this... Was it on the touchscreen or a button? And did you press credit or debit?
     
  4. cchunk macrumors 6502

    Joined:
    Jul 31, 2012
    #4
    This same exact issue has been happening to me. I was looking on the forums for someone else with the issue but finally I'm not the only one lol. It has happened to me every single time I try to use AP. Same exact issue where it says passcode or touch ID is needed. Not sure what the issue is though.
     
  5. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #5
    Same with me about an hour ago at Whole Foods and McDonalds.

    Using a 6S 128GB 9.0.1 and set up as new. Verified that all cards were added correctly.
     
  6. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #6
    So annoying huh! Are you on an s model? If not has Apple Pay worked for you before 9.0.1? Could be a glitch in the update.

    Can anyone on the latest update try Apple Pay and report back on the results?
     
  7. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #7
    Have you had any success with Apple Pay since you got your phone?
     
  8. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #8
    Honestly tonight was the first night I used it at two locations and it didn't work both times. Had a 5S before this so didn't have Apple Pay before.
     
  9. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #9
    Hmm interesting. Are you seeing the same behaviors as me?
     
  10. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #10
    Exactly the same issues.
     
  11. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #11
    What's odd is that my settings are perfect. If more users are experiencing the same issues then I'm leading towards a software issue.
     
  12. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #12
    I am inclined to agree. I double checked and made sure everything was fine. I'll test it out at the Apple Store on Wednesday because they have an Apple Pay demo.
     
  13. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #13
    Good idea I'll do the same tomorrow.

    Anyone else feel free to chime in.
     
  14. nikhilnagaraj24 macrumors member

    Joined:
    Mar 14, 2010
    #14
    I tried at Macy's a couple hours ago and AP didn't work on my 6S Plus. I ended up using an actual credit card after 5-6 unsuccessful attempts.
     
  15. cchunk macrumors 6502

    Joined:
    Jul 31, 2012
    #15
    yup very annoying. No i have a 6+. But ever since i updated to 9 it hasn't worked because I've used it before on 8.x. I am on 9.1 beta however, although that shouldn't really matter especially since you have issues as well
     
  16. MusicEnthusiast thread starter macrumors 6502

    MusicEnthusiast

    Joined:
    Jun 23, 2010
    Location:
    Los Angeles
    #16
    Huh... More reason to believe it's all software-based.
     
  17. sluggozmom macrumors 6502

    sluggozmom

    Joined:
    Sep 13, 2011
    Location:
    Massachusetts
    #17
    The keypad on the credit card machine you point your phone at,
     

Share This Page