Apple Peel 520 works with iOS 4.2.1

Discussion in 'iPod touch Hacks' started by cobaltrich27, Jan 16, 2011.

  1. cobaltrich27 macrumors 6502

    cobaltrich27

    Joined:
    Mar 6, 2009
    Location:
    D/FW TX
    #1
    Just finished a few days testing this new device on both my old iPT2GMB.

    I was having trouble getting the Peel 520 to make calls using iOS 4.2.1.

    I followed the steps very easy add the 2 cydia sources & the mobile substrate worked fine with iOS4.1.

    I was working with clean install of iOS then I decided to try different things and on my last attempt with clean install I only added 1 thing extra "Winterboard" and that got it running properly in iOS 4.2.1.

    Winterboard is not listed as one of the steps to get this working so I have sent the peel 520 team my finding. Most people would probably have "winterboard" installed but like I said I was working with a clean install and only using the direction found on the peel520 website.

    I have test this device using H20 SIM, AT&T Go SIM and even my iPhone 4 SIM using an adapter all work good with some bugs here and there but overall a neat toy and the prices have dropped.

    So go grab you one if you got an iPod Touch and want to play around with a new toy. Next up I will test a C Peel once the Novelty price wears off.

    Hope this info might help those trying to use this device with iOS4.2.1 and hopefully they get the "winterboard" step added to the instruction.

    Thanks.
     
  2. KSR macrumors newbie

    Joined:
    Jan 7, 2011
  3. lanulos macrumors regular

    Joined:
    Jun 19, 2010
    #3
    I looked at a set of instructions on a vendor site (bigboxstore.com) for setting this up, and I thought it was odd that they tell you to install AppSync. That's something for cracked apps, but they don't seem to be telling you to install any cracked apps. So I'm wondering why they need AppSync?

    As to where to but it, the site I mentioned above has it for $83 with free shipping. There might be even better deals.
     
  4. cobaltrich27 thread starter macrumors 6502

    cobaltrich27

    Joined:
    Mar 6, 2009
    Location:
    D/FW TX
    #4
    Well from what I read that needs to be installed to get the phone dialer software installed into the Peel 520 device. Kinda like firmware. There is a cellphone circuit board that the iPod Touch plugs into when its inserted into the Peel 520. This board also has the SIM slot, Power button and extra battery connection.

    FYI I drilled a tiny hole right above the power button so I dont need to remove the back panel to turn it on.

    Also note I dont see anywhere on any websites that say it works with iOS 4.2.1 and I have read some people asking and not able to get it working.

    I was experimenting with different variables using a fresh install & Jail Break following all the instructions and discovered it does work just fine with iOS 4.2.1 after installing winterboard which is not included as part of the installation instruction.

    I think the problem here is the developer probably has winterboard already installed and so do most others when they attempt to use the device overlooking the fact or unaware that some people may be using a clean install.

    I have been trying to spread the word of my findings hoping to get the guides updated to this good news.

    I have seen the Peel 520 selling $60-$120. From what I read the $60 takes about 2 months to get delivered. I paid $89 free shipping, mine was sent from China only took a week to get it and I was able to track the order via USPS peel520.net.

    There is also another similar device called the C Peel will try it next after prices drop to the $80 range.
     
  5. MTCca macrumors newbie

    Joined:
    Jul 27, 2010
    #5
    Installed on 4.2.1 but apps don't launch

    Followed the install instructions http://www.peel520.net/installation/
    Turned on the apple Peel 520

    I click on the SMS or phone app and they launch to the screen then back to the home screen. can't ever get into settings or phone number just goes back to home every time... help please...:confused:

    TIA

    MTCca
     
  6. dictodude macrumors newbie

    Joined:
    Mar 6, 2011
    #6
    Why not do this....

    :apple:If u have 4.2.1, and the peel isnt workin 4 u, downgrade to 4.1. :apple:

    :apple: Heres how 2 do it: :apple:

    1. go to itunes and plug in ipod :apple:
    2. open internet
    3. google: 4.1 firmware download
    4. download 4.1 and open up itunes
    5. click on your ipod and then restore.
    6. locate 4.1 and wait
    7. let your ipod install 4.1 and there it is.... your ipod is downgraded to 4.1.

    if this does not work:
    1. download the limera1n jailbreak and open it up.
    2. click make it rain and wait until ur ipod has the 'connect to itunes' picture.
    3. then, before the limera1n logo appears, disconnect ur ipod.
    4. after, close limera1n and open up itunes again.
    5. minimise it and google: 4.1 firmware download
    6. download firmware and reopen itunes
    7. click ur ipod and click restore
    8. locate 4.1 and wait
    9. let it install and there u go again!!! :)

    Happy Living!!!
     
  7. Luminator macrumors member

    Joined:
    Jul 24, 2008
    #7
    Does the 520 have an integrated microphone and speaker?
     
  8. dictodude macrumors newbie

    Joined:
    Mar 6, 2011
    #8
    Yes

    All versions of peel have a microphone and speaker, but the speaker volume is lowered a bit.
     
  9. Luminator macrumors member

    Joined:
    Jul 24, 2008
    #9
    Yosion has disappeared

    It sounds like a decent product, however yosion.net and it's cydia repository seems to have vanished off the face of the earth.
     
  10. Aqua Bliss macrumors 6502

    Joined:
    Dec 6, 2010
    #10
    Where is the Peel 520 2nd gen already! They posted a video on peel520.net on January 15th that said coming soon.... Cmon guys get with it... (sigh)
     
  11. Luminator macrumors member

    Joined:
    Jul 24, 2008
    #11
    It can be purchased at DealExtreme.com, just search for iSky Apple Peel 520 II. I guess iSky is the new company name for the apple peel. The new repository for the app is @ http://coming.hk/cydia.
     
  12. blainehamilton, Mar 17, 2011
    Last edited: Mar 18, 2011

    blainehamilton macrumors newbie

    Joined:
    Mar 17, 2011
    #12
    There are 3 different Apple Peel products.

    There is the Yosion Apple Peel 520 (And Apple Peel 520 2G coming if the company is still around)

    There is the Coming iSky Apple Peel T166 and T168 (and T188 coming in april)

    There is the ZTE Peel for Sprint (useless imoh since no phone/sms, data only)


    Yosion dissapeared from the earth a week or so ago and hasn't been seen since. People can't download the install files, and it's possible support for their products is gone. Too bad since the 2G product looked amazing.

    It's possible Apple offered them a pile of money to make them vanish. It's possible they are silenced in a Chinese prison. (or worse) It's possible that the Coming iSky T188 upcoming product is the former Yosion 2G product just sold under a new name.

    Such a shame since I was ready to put down the cash for the Yosion 2G product the moment in released. Coming's iSky current T166 and T168 products look stupid and ugly in comparison.
     
  13. Luminator macrumors member

    Joined:
    Jul 24, 2008
    #13
    Actually, @applepeel520.net tweeted two days ago that the yosion apple peel 520 V2 would be available March 28th. So it looks like yosion is still a live and well. here's the link that was posted: http://www.peel520.net/news/apple-peel-520-2nd-generation-latest-updates/#more-675
     
  14. garykliu macrumors newbie

    Joined:
    May 21, 2011
    #14
    Which version is the dial software (YosionApp) you are using ?
    I got a Peel 520 1st generation for my iPod Touch 2 a couple days ago, and upgrade to iOS 4.2.1, but with no luck.

    My YosionApp version is 0.9.9.
    The App shows the module is ON, SIM is ready, but when I dial a number, it hangs up immediately. :(

    The newest version 1.5.4 does not work at all. I think it might designed for Peel 520 2nd generation.
     
  15. garykliu macrumors newbie

    Joined:
    May 21, 2011
    #15
    Problem solved. It's due to the password protection of my SIM card. Disable the protection and finally I can dial numbers!! :D
     
  16. J.Slade macrumors newbie

    Joined:
    May 4, 2011
    #16
    I've been looking into getting the 1st gen Peel. Are the repositories back, or would it be pointless for me to buy a Peel at this point?
     

Share This Page