Apple pulled API for virtual devices in El Capitan !

Discussion in 'OS X El Capitan (10.11)' started by Cecco, Dec 3, 2015.

  1. Cecco, Dec 3, 2015
    Last edited: Dec 3, 2015

    Cecco macrumors member

    Joined:
    Jun 11, 2008
    #1
    Finally wanted to upgrade a bunch of Macs to El Capitan, but realized my Silex USB servers don't work any more. Contacted Silex and got this response (freely translated by myself):

    "With the leap from 10.10 to 10.11 Apple removed the API, which is necessary to connect virtual devices to the system. Apple realized this end of July in the early beta and informed us but so far has not reimplemented the API nor mentioned, whether/when they will. Due to the lack of this API currently no manufacturer of USB device servers is able to offer a device, that works with El Capitan."

    It is really annoying that Apple silently pulls APIs and renders peripheral devices useless. To upgrade the whole line of my Macs to El Capitan, I would have to buy about 10 additional USB scanners and 5 USB printers or switch the current USB devices against network devices. For printers this would be possible for the scanners this would be an expensive task as some are very specialized devices, which are not cheap or not available with network interfaces at all.

    Thanks Apple for this great innovation in El Capitan! May I sent you an invoice for the additional costs I'd have with an upgrade to El Capitan? I'll be generous, you can pay me with a couple of Retina iMacs. ;-)

    I post this here, because not many people might be aware of this serious limitation in El Capitan. And only a massive public request might push Apple to reimplement that now missing API. The request from the manufacturers themselves doesn't seem to put enough pressure on Apple to move their a**.

    So please send your you request to www.apple.com/feedback

    Cecco
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    Which APIs are those? I know that they have completely reimplemented their USB stack. But Apple themselves say that old code should work unchanged.
     
  3. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #3
    I've not come across a scanner or printer that worked with 10.10 that doesn't work with 10.11. I'm not sure why their little USB server doesn't work, but if you connect the scanners/printers to any Mac, you can turn on device sharing and use it over a network.

    Regardless of what you do, it seems silly that you think you have to buy 10 scanners and 5 printers to continue to use what is essentially a USB hub plugged in to the network.
     
  4. Cecco, Dec 3, 2015
    Last edited: Dec 3, 2015

    Cecco thread starter macrumors member

    Joined:
    Jun 11, 2008
    #4
    @leman: According to Silex support they use the commands UIMCreateControlTransfer(), und CreateRootHubDevice() from IOUSBControllerV3. And these commands have been removed in 10.11.
    Well can't say whether Apple has implemented alternative commands in El Capitan and Silex is not aware of them. ;-)

    @MacGizmo: Thanks for the hint with device sharing. Have to check whether the individual scanner and printer drivers can work with the devices shared that way. With the USB server they always worked as if plugged directly into the USB port of the Mac. Even if it works, it is not as convenient as an USB server device, because you have to make sure the Mac where the USB device is plugged-in, is running. Try to make this work in a company with more than 10 people and I can tell you it drives you crazy. ;-)

    Concerning USB server being just a kind of USB hub: I tried all this including manual USB switches. The distances are too far for USB. Especially with scanners even a 2m cable might be to long to work reliably. And manual USB switches make the whole thing much less reliable.

    And if I can't share a device between 5 workstations, I have to buy 4 additional devices, what is silly about this?

    The USB servers though expensive where a solid solution up to Yosemite.

    Cecco
     
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    I sympathize!

    The response you got from Silex seems more detailed so I don't know if there's any hope for those using this page.
     
  6. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #6
    So That's why USB is suddenly so buggy. I'd've thought they'd put the final nail in most of that back in 2012.
     
  7. leman macrumors 604

    Joined:
    Oct 14, 2008
    #7
    Ah, yes, that stuff is deprecated. But there is a bunch of new APIs, which, in my understanding, should offer the same capabilities. I never wrote a USB driver though, so I have to honestly admit that I have no clue :D I am sure Silex will know much better.

    I don't have any issues with my machines. And copying stuff to/from USB disks got much faster with 10.11 for me. So I like it :D
     
  8. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #8
    From what I've seen, it seems like Silex has their own kext to make this all work, so, SIP, signing, and what not with El Capitan, can see them having some issues (who knows what hacks were in the kext to make it work).

    Doesn't sound like Apple "silently" pulled/depreciated APIs, since per the note, Silex knew about this back in July. If anything, the beef is more with Silex, especially since SIP was adverised a year before El Cap. And the APIs calls that were depreciated were probably advertised well in advance as well.
     
  9. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #9
    USB drives are having huge issues on the last few beta versions of 10.11.2. Beware.. No USB issues here on 10.11.1 though.
     
  10. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
    #10
    Several brands of USB PCIE cards installed in Mac Pro towers stopped working in El Capitan. Even a USB 3.1 card would work in Yosemite (as a 3.0 device) but does nothing now.
     
  11. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #11
    Ohh, Applesauce!
    Is there any chance Apple will assign enough engineers to this little side project, computers, to make things work right, soon?
    Or should I start thinking in terms of Thunderbolt to SCSI adapters?
     
  12. verdi1987 macrumors regular

    Joined:
    Jun 19, 2010
    #12
    I have a couple of external USB 3.0 drives that would not mount or even show up in diskutil after reboot when connected to an iMac 5K running 10.11.2 beta. They mounted fine under 10.11.1, and once I reverted from 10.11.2 beta back to 10.11.1, they were once again correctly detected and mounted.

    Strangely, those same drives do mount fine when connected to a Retina MBP running 10.11.2 beta.
     

Share This Page