Apple QuickTime trailer not launching

Discussion in 'Mac Apps and Mac App Store' started by kublaiboy, Dec 21, 2011.

  1. kublaiboy macrumors member

    Joined:
    Sep 5, 2009
    #1
    Hi,

    I just upgraded my FF to 8.0.1. When I was trying to launch one of the downloadable 1080p trailers on this site:

    http://trailers.apple.com/trailers/w...rkknightrises/

    It wouldn't launch the quicktime app outside of FF. Usually the downloadable 1080p trailer plays in QT outside of FF. The previous FF worked fine with this. My other Macbook Pro has the same v8.0.1, it launches QT trailer outside of FF just fine.

    I think something is not right with my FF. All other FF browsing function seems to be normal. Can someone help? :confused:

    Thanks.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    So are you saying you downloaded the file, then when you double-click to launch it, it opens FF instead of QT? If that's the case, right-click on the file, Get Info, change "Open With" to QT, then click "Change All".
     
  3. kublaiboy thread starter macrumors member

    Joined:
    Sep 5, 2009
    #3
    See my attached screen shots from my MBP.

    The first one shows how QT should work with FF. If you select one of the "dowload" options(480p, 720p or 1080p), it will trigger the QT outside of FF, and start loading the movie(second screenshot). If you have QT Pro, you can flatten the QT trailer and save it to your HD.

    This used to work just fine on my Mac Pro, but after upgrading to FF 8.0.1, the FF on my Mac Pro doesn't work this way anymore. When you select any one of the download options, nothing happens, QT doesn't start to download movie out side of FF. However, it works on my MBP just fine. It has FF 8.0.1. That's how I took these two screen shots.

     

    Attached Files:

  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Have you looked for any Firefox ad-blockers or plug-ins that might be interfering?
     
  5. kublaiboy thread starter macrumors member

    Joined:
    Sep 5, 2009
    #5
    I did. I turned off pop-up blocker, it still doesn't work. I'm not sure what other plug-ins would interfering quick time launcher. :(

     
  6. phip900 macrumors newbie

    Joined:
    Jan 3, 2012
    #6
    I've been suffering from this problem for a couple of months now, and I rely on Apple Trailers!

    Firefox 8 and Chrome are not working, Safari is. This is on three different Macs for me. Seems very odd that it's been going on for so long but they apparently don't care over at Apple...
     
  7. hashashin, Feb 5, 2012
    Last edited: Feb 5, 2012

    hashashin macrumors newbie

    Joined:
    Feb 5, 2012
    #7
    Same problem, Lion, Firefox 10

    I have exactly the same behavior. I posted some extra information on mozilla bugs (https://support.mozilla.org/en-US/questions/908599) and specially, you can see a movie of it here: http://youtu.be/PfABP0u1POs

    So, safari works pretty well. Firefox don't. I had this problem with 9, before. Same thing with 10. :(

    Oh, tried to disable all plugins, other than quicktime, and all extensions. I even tried to delete all my FF profile. No luck.
     

Share This Page