Apple RAID card stripe size

Discussion in 'Mac Pro' started by Minor Threat, Mar 28, 2010.

  1. Minor Threat macrumors newbie

    Joined:
    Jun 13, 2009
    #1
    So I just got a RAID card and I am re-doing my system. Previously, I had 2 SSD's set up as a software RAID 0 with a stripe size of 128; AFter a bit of testing, I found that for the work I was doing this was the best size. The thing that is frustrating me is there seems to be NO place to set the stripe size when using the Apple RAID card; Nothing in disk util, or the raid utility. Anybody have any insight into this? I'm getting good performance with the card but I know I could be getting better.
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    Get rid of the card. Though it's possible to set the stripe size (not sure exactly where it is, but it's there somewhere), it's too slow, limited to a single OS, has battery issues, and is too expensive for what you get. Seriously.

    It's not capable of handling SSD's, particurlarly if you'd want more than 2x of them. You'd do better to look at a 3rd party solution, such as offerings by Areca, Atto, or even Highpoint's RR43xx line (Areca = ODM, but Highpoint is lousy for support).

    If you're after a card that can only handle 2x SSD's, the ARC-1210 would do the trick (uses SATA cables, and is ~$300USD, which is less than half of what Apple wants for that POS you bought, and it works with other OS's as well). It can even boot OS X (EFI firmware available). :eek: :D
     
  3. Minor Threat thread starter macrumors newbie

    Joined:
    Jun 13, 2009
    #3
    See the thing is that the card is a hand me down haha; That other card sound stupendous but I'd really like to make use of what I already have. The numbers I've been getting in xbench are already way better than the software raid across the board, but I just know they could be a lot better with a different stripe size. The old docs refer to a CLI util called megaraid and that had a stripe size flag you could change. The new CLI, raidutil, seems to have no stripe adjustment. Any ideas? Google has yielded nothing:apple:
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    CLI would still work, as it's a low level communication with the card (BTW, MegaRAID = LSI, which is the ODM for that card). The ability to adjust the stripe size is there somewhere, but I don't know exactly where to tell you to look.

    I'm starting to wonder if you missed the interface application when you ran the installation disk (card presumably came with a disk, not OS X disks)? :confused:
     

Share This Page