Apple Releases Aperture 2.1.1

MacRumors

macrumors bot
Original poster
Apr 12, 2001
49,594
10,908



Apple today released Aperture 2.1.1.Whats New in this Version
This update supports general compatibility issues, improves overall stability, and addresses a number of other minor issues.The update is free for Aperture 2 users, requires a minimum of OS X 10.4.11 or 10.5.2, and weighs in at 48 MB.

Article Link: Apple Releases Aperture 2.1.1
 

bobbleheadbob

macrumors 6502a
Feb 6, 2007
653
0
Massachusetts
Does anyone know what the other "minor issues" are? I downloaded it, but I can't see anything different. Gotta love the detail you get from :apple: with these updates...NOT. :(
 

alphaod

macrumors Core
Feb 9, 2008
22,177
1,231
NYC
You can go to the Apple Support site and it will tell you what each update fixes. For most people, it's download and be done.
 

Otaviano

macrumors 6502a
Nov 22, 2007
601
237
I wonder if it fixes the irritating bug that prevents you from adding custom folders in the wallpaper settings in OS-X. Right now if you add a folder to the wallpaper list it just shows another Aperture Library isntead, really annoying.
 

CaptainHaddock

macrumors 6502
Jul 6, 2004
382
0
Nagoya, Japan
I wonder if it fixes the irritating bug that prevents you from adding custom folders in the wallpaper settings in OS-X. Right now if you add a folder to the wallpaper list it just shows another Aperture Library isntead, really annoying.
That is super annoying (I had it too), although the problem goes away if your computer also has an iPhoto library.
 

psxguru

macrumors 6502a
May 19, 2006
512
0
On the surface it looks like mobileme related changes.

Judging from what I've heard, it looks like they've also blacklisted certain serials that were floating around!
 

Otaviano

macrumors 6502a
Nov 22, 2007
601
237
That is super annoying (I had it too), although the problem goes away if your computer also has an iPhoto library.
Another solution is to go to "Preferences / Previews" and uncheck "Share previews with iLife and iWork. That could help anyone reading this that doesn't have iPhoto on their computer, like me.

It wasn't without much irritation that I found this fix.
 

law guy

macrumors 6502a
Jan 17, 2003
997
0
Western Massachusetts
So this update really seemed to more or less add some mobileme interface bits. And yes, the update appears to have "broken" at least one function in Aperture as is being discussed on various photography boards. So, mobileme apparently breaks anything it comes in contact with. Not so good Apple.

Of course the update that I'm waiting for is D700 RAW support. LR is a good program, and I loved using it, but I like the Aperture integration and open editing ability (e.g. I can edit at any time even when doing book layout). I don't know if I'll pay the $99 to upgrade my LR, but... at least I'd have D700 RAW support today.
 

MauiBoy

macrumors member
Sep 7, 2005
38
0
Another annoying bug

Is anyone else seeing this bug?

Go into Aperture, and create a Web Journal (a few pages worth). Add a new page, and add about 30 pictures to that page. Then, add a text block at the bottom. Type several paragraphs of text, and then go to one of the other pages. My text disappears when I come back to that last journal page. It doesn't matter how many times I type or paste text back onto that page, it will not "stick" to the page. I even exported the journal to MobileMe, and it still doesn't show the text.

This bug is extremely annoying, as I'm stuck in the middle of a vacation trip and can't describe the rest of the trip to my family. :(

BTW, this bug was in 2.1 as well, but it didn't manifest itself quite so badly. Usually, the text would disappear, but pasting it in again made it "stick" to the page. There is no "save" function in Aperture, so I have no idea how to make the text stay attached to the page. Very frustrating....
 

MauiBoy

macrumors member
Sep 7, 2005
38
0
I've already reported it to Apple; just wondering if others were seeing the same thing. :)
 

Roy Hobbs

macrumors 68000
Apr 29, 2005
1,813
114
Is anyone else seeing this bug?

Go into Aperture, and create a Web Journal (a few pages worth). Add a new page, and add about 30 pictures to that page. Then, add a text block at the bottom. Type several paragraphs of text, and then go to one of the other pages. My text disappears when I come back to that last journal page. It doesn't matter how many times I type or paste text back onto that page, it will not "stick" to the page. I even exported the journal to MobileMe, and it still doesn't show the text.

This bug is extremely annoying, as I'm stuck in the middle of a vacation trip and can't describe the rest of the trip to my family. :(

BTW, this bug was in 2.1 as well, but it didn't manifest itself quite so badly. Usually, the text would disappear, but pasting it in again made it "stick" to the page. There is no "save" function in Aperture, so I have no idea how to make the text stay attached to the page. Very frustrating....
Enjoy your vacation and deal with the bug later.
 

Merriadok

macrumors newbie
Jun 2, 2008
7
0
a very annoying thing!! i did this just to test and yes! it works just as you said it will.. dammit. hope the'll fix it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.