Apple Safari Full-Screen Issues

Discussion in 'OS X Mavericks (10.9)' started by blujein, Jan 14, 2014.

  1. blujein macrumors newbie

    Joined:
    Jun 26, 2011
    Location:
    Australia
    #1
    When I use Apple Safari in full-screen mode I sometimes experience some issues that disrupt workflow significantly.

    The first issue is encountered with pop-up windows (typically advertisements). These windows open in a new Space (separate to the Space with the original instance of Apple Safari) and cannot be closed without exiting full-screen mode and then closing the window.

    The second issue is when activating a magnet-link. When the link is clicked, the Space slides to the right (displaying the Desktop), and then nothing happens. This, I assume, is due to the activation of the Transmission app window, but there is no visual indication of that. If I am activating a series of magnet-links this process becomes frustrating as I am having to return to the Space containing Apple Safari after each link click.

    Does anyone know whether there's a way to stop either of these issues from occurring?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    what are your settings in Safari / Preferences / Tabs ?
     
  3. blujein thread starter macrumors newbie

    Joined:
    Jun 26, 2011
    Location:
    Australia
    #3
    Thank you for your reply.

    My current Apple Safari settings for Tabs have the 'Open pages in tabs instead of windows' option set as 'Always' and the '-click opens a link in a new tab' and 'When a new tab or window opens, make it active' fields are both unchecked.
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    Mmmm... I don't know, sorry.

    In System Preferences / Mission Control, do you have this checked ?
     

    Attached Files:

  5. blujein thread starter macrumors newbie

    Joined:
    Jun 26, 2011
    Location:
    Australia
    #5
    No. I tested the same scenarios with the option enabled, though, and the issues don't seem to have been fixed.
     
  6. cbs20 macrumors member

    Joined:
    Feb 26, 2013
    #6
    In Safari preferences turn on the pop up blocker in the security settings.
     
  7. blujein thread starter macrumors newbie

    Joined:
    Jun 26, 2011
    Location:
    Australia
    #7
    That seems to have fixed the issue with pop-up windows, but the issue with magnet-links still seems to be present.

    Thank you for your help, too.
     

Share This Page