Apple Script error during Automator Workflow

Discussion in 'Mac Programming' started by iyacyas, Feb 9, 2009.

  1. iyacyas macrumors member

    Sep 4, 2008
    I'm new to this forum so I hope you all will be easy on me. I have built a workflow in automator for my mother to easily back up files to cd. I put a ask for Confirmation action at the beginning asking her to insert her backup disk. I needed her to wait until the disk spins up so after the confirmation I put a Wait for User Action-action telling her to wait until she she the cd on desktop. This works flawlessly when I run the workflow from the automator application itself. But when I save as an application or plug-in and run it, it bombs with this error "Apple Script Error NSReceiverEvaluationScriptError: 4 (1)". This does the same thing when I run it as a finder plug-in. I built another one with just these two action, Ask for confirmation and wait for user action with the default text and it acts the same way. I am using 10.4.11 and obviously automator 1.0.5. Any help would be much appreciated.
  2. HiRez macrumors 603


    Jan 6, 2004
    Western US
    Can you post the code? (Even just the short version that shows the error).
  3. iyacyas thread starter macrumors member

    Sep 4, 2008
    Thanks fo rthe reply

    Not to sound really stupid but it is in automator so I do not have a code as far as an error in the script. What I get is a dialog bow that says AppleSript Error then under that it says NSReceiverEvaluationScriptError: 4 (1) then you can only press ok from there. So what I have done since then. I created a workflow with only the Wait for User Action and with only the defaults set. I then can run it in automator and it works no problem. Dialog box pops up and has the default text for that action then I can press continue and it works. Then I save the workflow as an application, then run and it bombs with this code. I also tried this same proses on my Leopard machine and it works. Unfortunately the workflow from leopard wont work with Tiger. I did however figure out how to open the actual workflow script in xcode and I am in the process of elimination. So I could dump that script code if that would help. Any help or suggestions are greatly appreciated. The reality is, it is giving me a reason to play with xcode and cocoa.

Share This Page