MacRumors

macrumors bot
Original poster
Apr 12, 2001
53,022
14,765
https://www.macrumors.com/images/macrumorsthreadlogodarkd.png

Apple has seeded yet another version of OS X 10.5.7, this one termed Build 9J44, to developers. The release comes a little more than a week since the last developer seed was released. World of Apple republishes the seed notes, again revealing that a lack of support for Safari 4 beta is the only known issue mentioned by Apple.

In addition, the seed notes reveal five new fixes since the last developer seed, including a fix for PDF font rendering. Apple has also added Perl to its list of "general focus areas" upon which developers are asked to concentrate their testing.

Article Link: Apple Seeds OS X 10.5.7 Build 9J44 to Developers
 

Michael73

macrumors 65816
Feb 27, 2007
1,081
39
It can't be long now. I'll admit when I'm wrong...I predicted this would hit last week.

For that matter, how many more of these 5.x releases will we see before Snow Leopard? My guess (and that's purely what it is) is 10.5.9 before 10.6 hits in Sept. Assuming a .x release every 2 months.
 
Comment

Riemann Zeta

macrumors 6502a
Feb 12, 2008
661
0
Good god, what is it with the Safari 4 Beta that is so evil? For the last 5 releases, this has been the only issue. Clearly, it works on 10.5.6, so what's the bloody hold up? And if I already have the Safari 4 beta installed on my system (actually, that and the latest in Webkit nightlies), will my OS commit suicide if I update to 10.5.7?

And I'm betting we see OS 10.5.8 over the summer, right before 10.6 is released in late September.
 
Comment

wrldwzrd89

macrumors G5
Jun 6, 2003
12,109
76
Solon, OH
My suspicion is that the Safari 4 installer simply needs to be updated. I totally agree with Riemann Zeta though - it can't be much longer before this is released.
 
Comment

Ed91

macrumors 6502
Dec 22, 2007
267
1
Good god, what is it with the Safari 4 Beta that is so evil? For the last 5 releases, this has been the only issue. Clearly, it works on 10.5.6, so what's the bloody hold up?

I'm guessing that there is no real problem and that the reason the beta fails to install is that it checks for version 10.5.6, which with 10.5.7 it obviously doesn't find, so installation cannot proceed.

Apple are probably putting it in the seed notes so that people know that it won't work. The next Safari beta will fix this.. if I'm right, that is.
 
Comment

Eric S.

macrumors 68040
Feb 1, 2008
3,599
0
Santa Cruz Mountains, California
It can't be long now. I'll admit when I'm wrong...I predicted this would hit last week.

Same here. But I think this build may be it.

For that matter, how many more of these 5.x releases will we see before Snow Leopard?

At least one, probably two, but it could be as many as three if SL is delayed much.

Assuming a .x release every 2 months.

It's been almost 4 months since 10.5.6, which is why I thought we'd have seen this one before now.
 
Comment

Amdahl

macrumors 65816
Jul 28, 2004
1,438
1
I think there is a good chance we will see it today.

The new Xserve's are Nehalem, and their tags appear in 10.5.7. They are available 'immediately,' which suggests 10.5.7 is done.
 
Comment

gr8fl4295

macrumors member
May 25, 2006
48
0
USB problem fixed?

Not sure if this issue has been addressed either on these forums or in the seed notes, but anyone know if the USB problem is being fixed? When tethering a dslr to the computer via USB cable, after around 100 frames the CPU grinds to a halt, requiring a restart of the whole system.
This has been a BIG problem with 10.5.6. No other previous OS version has had this problem.

What do you think?
 
Comment

Michael73

macrumors 65816
Feb 27, 2007
1,081
39
I think there is a good chance we will see it today.

The new Xserve's are Nehalem, and their tags appear in 10.5.7. They are available 'immediately,' which suggests 10.5.7 is done.

Heh! I just had to hit software update to check...nope! :(
 
Comment

fhall1

macrumors 68040
Dec 18, 2007
3,573
833
(Central) NY State of mind
Not sure if this issue has been addressed either on these forums or in the seed notes, but anyone know if the USB problem is being fixed? When tethering a dslr to the computer via USB cable, after around 100 frames the CPU grinds to a halt, requiring a restart of the whole system.
This has been a BIG problem with 10.5.6. No other previous OS version has had this problem.

What do you think?

I think you should have reported this to Apple as a bug....they probably don't read this thread.
 
Comment

brop52

macrumors 68000
Feb 26, 2007
1,620
3
Michigan
I think there is a good chance we will see it today.

The new Xserve's are Nehalem, and their tags appear in 10.5.7. They are available 'immediately,' which suggests 10.5.7 is done.

Keep in mind that when the MBs/MBPs were released, they had a version of 10.5 that none of the other machines had yet. When 10.5.6 finally came out the update for the unibodies was smaller than the update for older machines with the prior 10.5.5 version. I assume it will be the same with the Xserves.
 
Comment

aeaglex07

macrumors 6502
Mar 18, 2007
399
1
United States
hmm. What if Safari beta doesn't work because 10.5.7 will include the Safari release?

That would be my guess. As for those who think it will be released with snow leopard, I don't see that happening. For one Safari is no longer a Mac only product and secondly I dont think most people "make the jump" to a new OS for a newer web browser.

LOL

I think the hold up is safari 4. THey're getting at GM level first.
 
Comment

kolax

macrumors G3
Mar 20, 2007
9,181
115
Yeah.. hoping it'll fix some 802.1X problems, Mail to actually hide at startup as well as improved performance.
 
Comment

iBug2

macrumors 601
Jun 12, 2005
4,239
497
That would be my guess. As for those who think it will be released with snow leopard, I don't see that happening. For one Safari is no longer a Mac only product and secondly I dont think most people "make the jump" to a new OS for a newer web browser.

LOL

I think the hold up is safari 4. THey're getting at GM level first.

Well if they were going to release Safari with 10.5.7 the test builds would work with it so people can test Safari 4 with the system. I really think Safari will arrive with Snow Leopard. It's not gonna require SL to run but it won't be complete until then. Don't forget the same thing happened with Safari 3. Many public betas and finally it got released with Leopard.
 
Comment

Scotty Dangles

macrumors newbie
Apr 8, 2009
3
0
Saint Paul, Minnesnowta
I don't know if anyone else noticed this but when you select the ATI option for the new iMac the lead time has gone done significantly, down to 7 - 10 days from 3-5 weeks! Looks like I'll be getting my iMac in the next week or so! :D

Either this could mean an imminent release or the iMacs and xServes have a version of 10.5.7 loaded...

Scott
 
Comment

Amdahl

macrumors 65816
Jul 28, 2004
1,438
1
Keep in mind that when the MBs/MBPs were released, they had a version of 10.5 that none of the other machines had yet. When 10.5.6 finally came out the update for the unibodies was smaller than the update for older machines with the prior 10.5.5 version. I assume it will be the same with the Xserves.

Ya, but the launch windows are too close this time. If 9J44 isn't the final, then perhaps they have done a whacko-build, but I doubt it.
 
Comment

texstorm2442

macrumors newbie
Apr 8, 2009
2
0
Ya, but the launch windows are too close this time. If 9J44 isn't the final, then perhaps they have done a whacko-build, but I doubt it.

hmmm
smile.gif

smile.gif
 
Comment

VSMacOne

macrumors 603
Oct 18, 2008
5,087
1,742
Well if they were going to release Safari with 10.5.7 the test builds would work with it so people can test Safari 4 with the system. I really think Safari will arrive with Snow Leopard. It's not gonna require SL to run but it won't be complete until then. Don't forget the same thing happened with Safari 3. Many public betas and finally it got released with Leopard.

I agree.. I think it's going to be a marketing move. New OS will come with a lot of new quirks but most likely Safari 4 will be officially launched with SL.
Obviously Safari 4 on 10.5.7 is NOT a priority, otherwise it would've been out for testing to the developers.
 
Comment

edbeta

macrumors newbie
Mar 3, 2008
8
1
MONTREAL
Well Apple like making users nervous because with all the seeds of 10.5.7 it should have been release by now .... or NAB 2009 with a the new FCS 3 required 10.5.7 and all must be close to perfection.:rolleyes:
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.