Apple slow downloads

Discussion in 'OS X Yosemite (10.10)' started by burgman, Feb 1, 2015.

  1. burgman macrumors 65816


    Sep 24, 2013
    For the past week or so software updates have been silly slow from Apple. 2 days for IOS 8.1.3, one day for 212 meg iTunes 12.1, Apple TV can't finish downloading update. My home connection is 46 meg Centurylink. First call to Apple had them blame my connection then after a remote screen session saw the 46 down and said oh their servers are busy. So today same issue, I tried to contact Apple again and got the extended wait time message so something is going on, I researched this problem and found a fix for me. I just installed a VPN program and my IOS download went from 2 days to 46 minutes, which is normal download time last week in the past for me from Apple. What is going on here any ideas?
  2. airsound, Feb 11, 2015
    Last edited: Feb 11, 2015

    airsound macrumors newbie

    Feb 11, 2015
    Me too, Burgman - although I'm on Lion 10.7.5

    Software Update told me it would take 40 hours to update my IoS via iTunes. But doing it directly to the phone was fine.

    Now I'm trying to update iTunes, and it's taking 5 hrs.

    My server isn't superfast - about 16 Mbps - but I've not had these problems before

    And Software Update doesn't complete checking availability.

    I've deleted Software Update plist in library preferences.


    edited to add: I've now downloaded the iTunes update - except that it "couldn't be updated", because the download was corrupted, or somesuch bollox. I tried again. Same result.

    I give up....
  3. w0lf macrumors 65816


    Feb 16, 2013
  4. airsound macrumors newbie

    Feb 11, 2015
    Sorry? Torrents?

    I'm sure they're an extremely good thing.

    But I haven't the remotest idea what you're talking about....

    I only came on here as a last resort because nothing I was doing seemed to have any useful effect - and the idea of trying to explain on the phone to someone at Apple left me cold.

    My MacBook is merely a tool for my daily life - I have zero interest in how it works, and probably even less knowledge. I just want it to work as advertised. And preferably without my spending hours upon hours trying to fix something that seems pretty clearly a problem of Apple's making, not mine.....

    Perhaps I'm in the wrong place.


  5. sohaloh macrumors regular

    Apr 10, 2012
    London, Ontario
    Change your DNS. Go into settings>network>advanced choose the wifi network and change your DNS to either google DNS or Open DNS. Googles DNS is and after this restart your wifi and try again. Should work properly.

Share This Page