Apple spell popup appearing

Discussion in 'OS X El Capitan (10.11)' started by Razer(x), Oct 14, 2016.

  1. Razer(x) macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #1
    Hello everybody, once every 2-3 days this popup appears on my screen for no apparent reason

    What is it? how do i disable that?

    [​IMG]
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Your computer seems to have lost the path to the AppleSpell application. It should be located at:

    /System/Library/Services/AppleSpell.service/Contents/MacOS

    First of all check to make sure AppleSpell is in that folder.

    If it is, when the popup comes up, navigate to the folder and select AppleSpell.
     
  3. Razer(x) thread starter macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #3
    I tried, but the popup doesn't let me select that package
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
    Can you be a bit more specific? Does it allow you to navigate to the folder? What happens when you try to select the package? Can you post a screen shot?
    --- Post Merged, Dec 16, 2016 ---
    Are you logged in with an admin account?
     
  5. Razer(x) thread starter macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #5
    Yes it does allow me to navigate to it but it does not let me select it

    [​IMG]

    Yes admin account

    This started happening on my desktop too, so it must be some apps or settings
     
  6. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #6
    You could go to System Preferences > Keyboard > Text and turn off "Correct Spelling Automatically".
     
  7. Razer(x) thread starter macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #7
    Yes i could, but i would like to find the culprit since it is a recurring issue

    I'm starting to think it may be related to SIMBL
     
  8. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #8
    I just went back and looked at your screen shot. AppleSpell should not be in

    /System/Library/Services/

    where you have it.

    It should be in

    /System/Library/Services/AppleSpell.service/Contents/MacOS

    You seem to be missing a file called AppleSpell.service in /System/Library/Services/

    See my screenshots attached.
     

    Attached Files:

  9. Razer(x) thread starter macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #9
    It does not have the .service ending, but in the info the file is correctly named "AppleSpell.service"

    Are you on El Capitan, could you share that Applespell.service file?
     
  10. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #10
    BTW, AppleSpell.service is a package file. See attached. I don't know whether the AppleSpell file you have in Services is the actual AppleSpell file, or whether the package has become misnamed by losing its suffix. Maybe you could make a copy of it on your desktop, rename the copy to AppleSpell.service and see if you can see contents of the package by right clicking. If it shows up as a package, it may simply be a matter of renaming the file. (Check to see if the contents of the package correspond to my screenshot.)
    --- Post Merged, Dec 24, 2016 ---
    I am on El Capitan. The AppleSpell.service file is over a megabyte.
     

    Attached Files:

  11. Razer(x) thread starter macrumors regular

    Razer(x)

    Joined:
    May 7, 2014
    #11
    The file seems to be ok, it must be some incompatibility
     
  12. JohnDS, Dec 24, 2016
    Last edited: Dec 24, 2016

    JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #12
    Just make a copy of the original file on your desktop, then rename the original in the Services folder to AppleSpell.service
     

Share This Page