Apple TV 2.2 breaks encode compatibility?

Discussion in 'Apple TV and Home Theater' started by zero hectic, Oct 8, 2008.

  1. zero hectic macrumors newbie

    Joined:
    Oct 8, 2008
    #1
    Noticed today that some of the movies I encoded using Handbrake no longer play after the ATV 2.2 update. It looks to be confined to foreign movies with subtitles. So far I've found 8 movies (a mix of Hong Kong & Russian) with English subtitles that won't play at all. Any attempt to do so gives me nothing but a black screen. At least I can menu out of it.

    On the other hand, I have found other movies with subs that seem to play fine. All where encoded in Handbrake using the same preset.

    I just did a factory restore (1.1) and all movies are playing fine, just as they did up till 2.1.

    My roommate is having the exact same problem with his Apple TV after the 2.2 update.

    Found 2 threads at the Apple Discussion Forum discussing the same thing.

    http://discussions.apple.com/thread.jspa?threadID=1743122&tstart=30

    http://discussions.apple.com/thread.jspa?threadID=1739649&tstart=60

    Anyone here been hit with this "bug"?

    -m
     
  2. zero hectic thread starter macrumors newbie

    Joined:
    Oct 8, 2008
    #2
    OK, I think I just figured something out.

    Under Settings/Audio & Video/Audio Languages, I noticed that Chinese & Russian aren't available. All the movies I've been having trouble with have either Chinese or Russian dialog tracks.

    I opened one of my movies in Quicktime and selected Show Movie Properties.

    I selected Stereo/Other Settings. The Language was properly set as Traditional Chinese. I reset it to English.

    I next went to Surround/Other Settings and did the same, Traditional Chinese to English. This wouldn't apply unless you have two audio tracks in your file.

    I re-saved the file. Quicktime will append your file with .mov. Changing it back to .m4v or .mp4 seems to make it unplayable.

    Added the file back into iTunes and suddenly it's perfectly playable on the ATV

    So it seems that ATV won't properly play a file that's tagged with a language that's not available in the Audio Languages menu.

    Does anyone know of a way of changing this language tag (?) without having to go through the trouble of opening/editing/resaving it in Quicktime?

    -m
     
  3. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
  4. zero hectic thread starter macrumors newbie

    Joined:
    Oct 8, 2008
  5. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #5
    np. we are possibly looking at a way around this issue.
     

Share This Page