Apple TV 2 - Multiple Speakers Feature Not Working? Help.

Discussion in 'Apple TV and Home Theater' started by boltjames, Oct 26, 2010.

  1. boltjames macrumors 68030

    boltjames

    Joined:
    May 2, 2010
    #1
    [​IMG]

    I can't get my ATV2 to act as a Remote Speaker as I did with my ATV1.

    On the ATV2, I've got myself configured here: Settings > AirPlay > AirPlay Speaker > On

    On iTunes, I've got the Multiple Speakers dialog box up (see screencap) by hitting the icon on the lower right of the window and iTunes can see my Apple TV. Problem is, when I try to tic that checkbox it won't take.

    Are there any other settings in iTunes or ATV2 that I'm missing that would somehow a) allow the Apple TV option in the Multiple Speakers dialog and b) not allow the damn box to be checked?

    I'm a big fan of the Crossfader and multiple-room listening and without the ATV2 having the ability to act as a speaker its messing me up bigtime.

    TIA

    BJ
     
  2. EvilC5 macrumors 6502a

    Joined:
    Sep 22, 2010
    Location:
    Hanover MD
    #2
    your picture is blocked here so im not sure what version of itunes you are running, but I had to upgrade to the 10.(whatever the newest) version of the itunes for it to see my ATV2's in addition to my ATV1's and AE's.
     
  3. wolrabsj macrumors newbie

    Joined:
    Nov 1, 2010
    Location:
    Houston
    #3
    You're not alone

    I have EXACTLY the same problem. ATV2 just showed up yesterday and everything else works. I'll give it another shot tonight and see if I can figure it out. I'm guessing the ATV2 thinks it's in charge, and somehow has to be put into "slave" mode. Will let you know, if someone else doesn't first.
     
  4. autumnmike macrumors member

    Joined:
    Oct 12, 2005
    #4
    To work around this bug you have to turn off airplay on the atv, then turn it back on. That did the trick for me.

    I just noticed you're on a pc. That trick worked for me on a Mac, but this should probably be addressed with the updates rolling out.
     
  5. wolrabsj macrumors newbie

    Joined:
    Nov 1, 2010
    Location:
    Houston
    #5
    I tried turning AirPlay off and back on - no luck for me, unfortunately, but thanks for the suggestion. I'm still in the honeymoon period for the ATV, so I suppose I can call them up.
     
  6. TheCheapGeek macrumors 6502

    Joined:
    Jul 10, 2008
    #6
    I am having this issue as well, airplay direct from iPhone/iPad works great but i cant do whole house audio any longer.
     
  7. wolrabsj macrumors newbie

    Joined:
    Nov 1, 2010
    Location:
    Houston
    #7
    Problem solved - for me, anyway. Power-cycled the ATV2 and closed and re-opened iTunes. Kind of embarrassed that I had to have the Apple help lady tell me that, after years of screwing around with PCs!
     
  8. EvilC5 macrumors 6502a

    Joined:
    Sep 22, 2010
    Location:
    Hanover MD
    #8
    i hope this isnt the start of windows type technical support....lol

    sees allot of little quirks i have with my ATV setup can be solved with a quick reboot and closing itunes out and bringing it back up.
     
  9. heywoodja macrumors member

    heywoodja

    Joined:
    Feb 14, 2005
    Location:
    Milpitas, Ca USA
    #9
    no suggestion...but....

    I like your mix of music taste. A little of everything...BTW..I love my ATV2. Sorry I can't help you, mine is working fine..so far..knock on wood!!:D
     
  10. gatorson macrumors newbie

    Joined:
    Aug 4, 2008
    #10
    Is anyone having this problem with an airport express as well? I can see my AX from the dropdown menu but itunes will not let me connect either. I also am running bootcamp and the fresh install of windows itunes has the same exact problem...leaving me to believe that the problem exists at the AX level. I also have a ATV2 but am no longer even hooked up to it because I moved from the house which had it. Has anyone found a solution?
     

Share This Page