Apple TV 2 randomly reboots/crashes

Discussion in 'Apple TV and Home Theater' started by nioted, Mar 12, 2011.

  1. nioted macrumors regular

    Joined:
    Sep 14, 2007
    #1
    I recently bought a Apple TV 2 a week ago and just today I decided to jailbreak the device today to include PlayOn functionality. The Apple TV has the 4.2.1 iOS and I used the Greenpision 6.1 release to jailbreak. I followed the instructions to the T and jailbreaked it on the first try. I installed XBMC through the menu system then proceeded to add PlayOn. Once everything was done I noticed I would leave the apple tv sit there and do nothing and it would reboot. I really didnt think much of it. So I start looking through the menu system in XBMC and within 5 minutes, it would reboot again. I start streaming a video through the PlayOn server and within 5 to 10 minutes of watching, the apple tv would reboot. As I'm typing this post I am testing the airplay feature from my iphone to he apple tv and notice it hasnt rebooted at all in the last 20 minutes. The rebooting must be related to the jailbreak somehow. I used the device stock with no jailbreak for a few days and it never did this. I did searches in google and on this forum and found nothing. Has anyone experience this problem?
     
  2. mbleopard macrumors regular

    Joined:
    Sep 8, 2008
    #2
    It sounds like your having the same issue that I had with mine last night, Apple is trying to push a new update to the Apple TV and thats whats causing your Apple TV to kick you out of XBMC. There are a couple solutions to it, the first being to go to NitroTV-> Settings and disable Apple Updates, also some people reported updating NitroTV itself fixed the problem. If neither of those solutions work for you then you have to SSH into the Apple TV and edit the /etc/hosts file so that the Apple TV won't communicate with Apple's servers.

    For a more in-depth explanation:
    http://forum.xbmc.org/showthread.php?t=96362
     
  3. nioted thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #3
    mbleopard, thanks for the advice. I'm gonna give it a try and report back with my findings.
     
  4. SimonMTL macrumors newbie

    Joined:
    Feb 7, 2005
    Location:
    Montreal Canada
    #4
    @Nioted I also had the same problem, I disabled the Apple Updates, but it didn't help. In the "install software" section of NitoTV, there should be a new program called "updateBeGone". Install that one, and you'll be good to go!

    No need to try all the other tricks with SSH. That new ware works it perfectly.
     
  5. nioted, Mar 16, 2011
    Last edited: Mar 16, 2011

    nioted thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #5
    I tried updatebegone but it never fully installed and got a error message. Disabling Apple updates didnt help either. I tried SSH'ing in the unit but it took forever because I didnt know any commands in terminal. I was finally able to use Cyberduck to Sftp into the unit and change the host files. It took about 3 hours to accomplish this feat! It took a while to find the username/password. BTW its root/apline, not frontrow/frontrow. And make sure to pick sftp and not ftp because it wont work. I used the basic editor in OSX to add the IP's. Now I dont get any crashes from XBMC anymore! Loving my Apple TV 2 so much I bought a second one!
     

Share This Page