Apple TV 2: Stop the HDMI sound when using optical audio out?

Discussion in 'Apple TV and Home Theater' started by J.C, Oct 30, 2010.

  1. J.C macrumors 6502

    Joined:
    Nov 12, 2008
    #1
    I have my Apple TV 2 connected to my TV via HDMI and also to my iPod HiFi via the optical audio out. A signal is sent to both connections at the same time, so I'm getting sound from the TV *and* the HiFi. Annoyingly they are out-of-sync (slightly), so there is an annoying echo effect.

    I can't find any settings on the TV to ignore the HDMI audio; is there any way to stop the ATV sending an audio signal to the HDMI connection?

    Perhaps a way to ensure both speaker systems remain in sync, or a solution I haven't thought of?

    Thanks in advance for any help!

    Josh :)
     
  2. weststar macrumors newbie

    Joined:
    Jul 11, 2008
    #2
    Just turn down the volume of your tv ;)
     
  3. J.C thread starter macrumors 6502

    Joined:
    Nov 12, 2008
    #3
    Yeah that's what I've been doing but it's not ideal. I'm surprised that the ATV even sends audio to both connections simultaneously.
     
  4. hans.peeters macrumors newbie

    Joined:
    Sep 8, 2009
    #4
    Solution

    I have a brand new Apple TV2 and am experiencing the same problems. It has nothing to do with ripping or compression issues as suggested on many forums like apple techsupport. It is an Apple TV problem. The way to overcome it is to connect your TV back to your HiFi amplifier/receiver through audio-out on the TV and a free audio-in connection on your amp. Do not forget to change the input setting on your amp to the chosen audio-in connection (Aux, CDR, V. Aux or whatever). So, now you can listen to your iTunes music through your optical connection and watch and hear your movies through the analog sound connection described above. One could argue that analog connection is lower quality as optical, but for video the sound is compressed anyway, so the 16-bit analog connection will deliver sufficient quality, whereas the 24-bit optical connection is ideal for listening to lossless quality in iTunes. Have Fun!:)
     
  5. spice weasel macrumors 65816

    Joined:
    Jul 25, 2003
    #5
    In my opinion, this is a bonus. I have a PS3 as well, and you have to choose which port you want your audio to be pumped through. I use my 5.1 system. But there are times when I don't necessarily need or want my receiver on, and would rather have the audio just come through the television. Watching a movie or playing a game late at night, for example, when I don't want to annoy the neighbors.
     
  6. mchalebk macrumors 6502a

    Joined:
    Feb 4, 2008
    #6
    The reason the sound is out of sync is probably due to processing in the TV (especially if you have an LCD TV with frame insertion technology). The TV will delay the audio to allow it to be in sync with the video which lags because of processing. You might be able to get them more in sync by changing to game mode (if your set has one). However, that's probably more work than turning the volume down.

    In my case, I have the TV speakers turned off and use my receiver for all audio. With the Harmony One remote, it's as simple as just using the TV speakers (and sounds a lot better).
     

Share This Page