Apple tv 3 can't connect to home share.

Discussion in 'Apple TV and Home Theater' started by superx, Mar 18, 2012.

  1. superx macrumors member

    Aug 8, 2005
    Hey Guys,

    Just got a new Appletv3 and got everything hooked up, but the apple tv only connected once to my iTunes Library.

    Everything was working during that time. now a MSG on the apple tv says turn on home-sharing.

    I have a Dlink dir-815. The Apple TV is connected through n 5ghz.
    I went through and forwarded the ports.

    I have turn off home-sharing and turn it on. Restarted my machine.

    It is a windows Vista Machine.

    As I said earlier I have only been able to connect once to my home-sharing and it stopped.

    Thanks for any help.
  2. DaveOP macrumors 65816

    May 29, 2011
    Portland, OR
    My ATV2 did this tonight as well, wondering if there is some type of outage or something.
  3. superx thread starter macrumors member

    Aug 8, 2005

    Still having issues. I am wondering if its the wireless connection, but I connect to itunes fine, and am able to stream fine.

    Hope I can get some help.

  4. colshine macrumors regular


    Mar 2, 2011
    I'm getting the same problem with my ATV 3 - I got it Saturday but have been unable to connect to iTunes/Home Share.
  5. jmantn macrumors 6502

    Mar 13, 2012
    Shot in the dark here but try these:

    In your Network settings make sure TCP/IPv6 setting is unchecked but leave TCP/IPv4 checked.

    Restart your router (I know most probably have).
    In your Router's settings under security make sure Multicast is checked if you have that option.
    Try a complete reset of your router.

    Windows PC's check bonjour settings:
    To enable, right click on My Computer and select Manage. Click on Services under Services and Applications. Right click Bonjour Service and select Properties. Change Startup type to Automatic. And, click Start under Service Status. Click Ok. Restart iTunes

    Make sure if you have a firewall you don't have something apple related set to untrusted or blocked.

    Check your ports for bonjour on a router:

    In iTunes, click "Advanced". Turn OFF Home Sharing. Turn it back ON and it will ask for your iTunes password. Put that in and click "Done."

    Try turning off wifi sync in iTunes for your iPhone and iPad, home sharing may now work.

    Also check this thread:

    Try assigning each device on the network a static IP.

    I hope this helps.
  6. Rallo macrumors newbie

    Mar 19, 2012
    I have the same problem with AppleTV3.

    I tried open port forwarding, port triggers, assigned a static network address to the ATV3, even tried setting the ATV3 into a DMZ zone, turning home sharing on and off both in itunes and the ATV3, Bonjour is running fine, wifi sync is off, rebooted the computer with itunes... and still no joy.

    Both my ATV2 work fine. I swapped the ATV3 with both of the ATV2 units and the problem followed the ATV3 and was not there with either ATV2 units. The problem is repeatable, i.e. I can swap the units out and only ATV3 can home share.

    I'm open to suggestions. If I can't run this down soon, I'll take it back to an Apple Store and ask for a replacement or return.
  7. jmantn macrumors 6502

    Mar 13, 2012
    Are you using home share with a Mac or windows pc?

    Also if you have MAC filtering turned on in ur router settings make sure to add the new apple tv MAC address to the allow list.
  8. Rallo macrumors newbie

    Mar 19, 2012
    ITunes is on a PC. Mac filtering isn't set. I have replicated this wired and wifi.

    Tonite I was going to try resetting factory settings. When I hooked it in place of one of the ATV2 units, home sharing came up. I hadn't reset it, just reconnected it. Tomorrow I'll try in the other place and see if it is resolved. If it is, I'm even more confused since nothing has been changed from the last time it didn't work.
  9. jmantn macrumors 6502

    Mar 13, 2012
    Glad to hear it is working now! Several threads that were half a dozen pages or more typically ended saying it started working after a reset. That's not to say you didn't do one earlier but it seems that either some type of "cache" or setting got reset/changed on your network or on the apple tv.

    Either way let us know as I've got a friend who is having issues and compiled the list I posted above for him earlier tonight.
  10. Q Bert macrumors regular

    Q Bert

    Mar 7, 2011
    Chicago Burbs
    I think iTunes has to be open on your PC for this to work.
  11. bluestarCVO macrumors member


    Mar 20, 2012
    I have a similar issue. I have three Apple Tv 3's hooked up, 2 wired, the other one wireless. I can stay connected to home sharing all day on all three of them without issue. But for some reason, every morning they have all three lost connection to home sharing. Even restarting the device does not reconnect it. All I can do is exit out of itunes and restart it. Then the home sharing is connected again and I can access my files.

    This wouldn't be such a big deal if it was just me, but my wife does not want to have to fool with this every morning to play videos for our daughter. I was using Boxee Boxes prior to this and they worked flawlessly.

    The computer does not go to sleep or hibernate and neither do the apple tv's. I have tested with firewall and anti-virus disabled. Called Apple support and they are clueless. Any ideas?
  12. jmantn macrumors 6502

    Mar 13, 2012
    Just guessing here but I would say the issue lies with iTunes or your router based on your description as I highly doubt you have 3 defective units.

    One possibility which would be a longshot if I'm correct (I'm not at home so I won't be exact), there is a setting your router for either a static or dynamic IP from your ISP depending on how that's configured could be impacting your setup whenever the IP gets refreshed.

    Also as I've listed in a previous post in this thread the most common issues these links may help you out:

    Apple's Official Home Sharing trouble shooting page

    Official setting up Home Sharing on a PC

    Official setting up Home Sharing on a Apple TV 2 (it's a little old)

    Here's a possible fix, click on the link on this page to see one possible fix

    and lastly one more solution:

    1. Close iTunes application
    2. Remove all of the contents from inside of this folder - C:\Users\YOUR USERNAME\AppData\Roaming\Apple Computer\iTunes (it is recommended that you move them to your desktop as a backup - so that you can move them back in case this does not work).
    3. Repeat step 2 for this folder as well - C:\Users\YOUR USERNAME\AppData\Local\Apple Computer\iTunes
    4. Launch iTunes application.
    At this point - itunes will re-create all of the data inside of these two folders that you just removed and you should be back up and running.

    All the links posted will refer to Apple's support (in case there is a concern about following links). I've compiled these yesterday to help out a friend who couldn't get his apple tv or itunes to show up over the network (iPad couldn't see the ATV or his Computer running iTunes).

    If this doesn't help I'll dig a little more later tonight and go through my own setup and see if I can figure anything else out however from your description it definitely seems like an iTunes/Router issue more so than a hardware issue in my mind. I've also suggested this earlier but does each device have it's own IP assigned? If all three go to sleep overnight and try to use the same IP that could cause an issue but I'm doubting this is the culprit. And have you possibly tried resetting your router? I know that could be a major pain but a lot of times that does the trick if you can't narrow it down.
  13. bluestarCVO macrumors member


    Mar 20, 2012
    Hello and thank you for your reply! I have tried resetting the router to factory settings, and even using a different brand router. As far as assigning addresses to the atv's, I just did this today so I won't know if this worked until I wake up in the morning as the disconnects always happen over night.

    Thanks for the links. I have tried some of the steps listed but am about to dive in a little further and see if I can get this issue knocked out. I will keep you posted in the morning. Hopefully they are still connected when I wake up in the morning.
  14. jmantn macrumors 6502

    Mar 13, 2012
    ALrighty and sorry some of my wording was a little confusing above as I was multitasking when I responded and didn't proofread :eek:

    If you get this working please post what steps you took that seemed to resolve your issue, conversely if it doesn't work then please list what else you've tried. Hopefully sooner rather than later we"ll get this resolved :)
  15. illest813 macrumors member

    Oct 5, 2006
    i dont mean to hijack your thread bud, but i just bought the apple tv for me and my mom and have been having the same problems on different networks (hers doesnt work at home , mine doesnt work at my apt)

    both are the home sharing issue. ive tried the resetting router, apple tv, itunes, everything is up to date.

    i have a time capsule as my router in router mode: dhcp and NAT and have nat port mapping protocol enables. i have tried manually entering the port numbers apple tv says it uses but i cant add them because it says it conflicts with something already in use (assuming they are already open)

    my apple tv recognizes the time zone, itunes app works yet home sharing STILL can not find the itunes library, and vice versa

    any suggestions guys? this is crazy. i am using time capsules in both my apt and my mothers house and have essentially same settings how can this be so difficult???
  16. jmantn macrumors 6502

    Mar 13, 2012
    Have you tried all the suggestions from my previous 551pm and 9pm replies earlier? I only ask as between both posts there are solutions that others have come across after countless hours of troubleshooting.

    With your set up which is quite nice btw seems like it could be something simple such as the the IPv6 or iTunes password issue listed in my first post on this page (2nd link, my first post here).

    Also assuming none of this helps, do you have an idevice that can see either the ATV or your iTunes library? Also is your iTunes library running on a Mac or pc?
  17. gtg381z macrumors newbie

    Mar 21, 2012
    I've tried it all, finally got ATV3 working with Windows 7-64bit

    So, like many I've been painfully trying to get homesharing to work between a new ATV3 and my Windows 7 box. After literally DAYS of checking and double-checking settings, I decided to try a new, faster N900 router. BINGO. Seriously, I didn't have to change iTunes, software, PC settings, or do anything different, just plugged in the new router and bam, homesharing came up and is super stable for about 36 hours now.

    My previous router was a fairly new Linksys WRT120N. The ATV3 was about 15 feet away in my living room, great signal, able to stream perfectly using Airplay (i.e., having iTunes send 1080p video to ATV). But, homesharing would not work. I tried a wired connection, worked intermittently. After further research, I figured there was a conflict in the routing of the bonjour service, possibly the multicast packets.

    The new router is a Linksys E4200. I used the included CD for installation, upgraded firmware, and then set up a first 5GHz wireless network for the ATV3 using N-band only, and a second 2.5 GHz wireless network for my 802.11G devices using G-band only.

    Works perfect and I am running out to get a second ATV for my bedroom to see if the network holds up with more than one ATV. I believe it will.

    In summary, although my previous router worked flawlessly for streaming directly to the ATV, homesharing was not working. Because the new router has a full 450Mbps 5GHz band and a separate 350Mbps 2.5GHz band, little connection glitches in the bonjour service are mitigated and the connection is fast enough to recover from larger errors. Further, because even the wired connection was pretty glitchy in the previous router, I'm making an informed assumption that there was a router software problem in routing the bonjour multicast packets which are essential for homesharing.

    Now, I never recommend upgrading hardware unless absolutely necessary, so first try upgrading your router's firmware if possible. You can also try DDRWT if it is available for your router (this is why I chose the E4200, DDRWT ROM is available). If this doesn't work, try borrowing a newer router with documented support for multicast packets between networked elements and see if homesharing works.

    If anybody needs further information on my system specs to gauge similarity to their setup, please feel free to ask.


    John S.
  18. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    I had a Dlink DIR-601 at my dads and it was one rubbish router. Even put DD-WRT on it but its issues ran deep. I avoid Dlink whenever possible.
  19. kentdmt macrumors newbie

    Mar 21, 2012
    Apple TV Home Sharing

    You gotta have both of the devices in the same wifi network to make the home sharing feature works. Make sure you don't have your computer switching between two or more wifi networks. Good luck!
  20. monkey28 macrumors newbie

    Mar 20, 2012
    I had drop connection to itunes home sharing after couple hours if connected it.

    After I tried every method I found here, still no luck, so I called apple support, and saying the exact same thing, (reset atv, reset howe share both side, open ports at router, reboot every single machine involved I the same net work, switch wifi or wired network) and my atv won't connect to iMac anymore!!!!!WTF?!

    And I "restore" the atv, which re-download the firmware again and installed it.
    And it works again..........for couple hours. But at least I bring it back up....I am going to visit apple store to find out what's happening on .

    See how it goes.
  21. jmantn, Mar 21, 2012
    Last edited: Mar 21, 2012

    jmantn macrumors 6502

    Mar 13, 2012
    Additional possible fixes for some users

    So this may not work for everyone but here's some more possible solutions I've came across in addition to my previous posts on this thread:
    trouble shooting software issues (3rd party)

    Try turning off Home Sharing in iTunes. Then turn Home Sharing back on. This time don't click on done in the last step. Try clicking on My Music instead. By just clicking My Music instead, Home Sharing would stay in place and Apple TV may work. - From Apple Support Community

    For those with issues with Apple TV dropping WiFi connection: I checked the logs and noticed the WGA Key timeout coincided with the TKP rotation. Which matched the time the ATV dropped Home Sharing. I had the timeout key to default 1 hr, I have now changed it to several days. - From Apple as well, sorry don't have some of the links handy.
    removing itunes and related componets, will not remove your library FYI
    diagnostics Highly Recommend following this

    Some users had issues with Avast antivirus and disabling didn't fix however uninstalling did fix their issue.

    Make sure you don't have two firewalls going:
    I accessed windows firewall exceptions and noticed that Itunes wasn't selected, I selected Itunes, restarted all my devises and bingo, its all back up and running, if your unsure how to access the firewall settings here's what you do.

    Control panel
    - security
    - windows firewall
    - select change settings
    - Exceptions tab
    - scroll down to itunes and make sure it is selected.
    --From Apple as well

    Linksys routers:
    I just got off the phone with Linksys tier 2 tech support and I finally have a work around that is different from what everyone else has been doing and ostensibly we don't have to sacrifice anything.
    Applications & Gaming -> QoS -> WMM -> ENABLE IT
    Administration -> Management -> CTF -> DISABLE IT

    Also make sure that both the AppleTV and the computer are on the same Wifi network. Check your router status menus for list of connected devices, this will also let you know if they are at least on the network (even if you have just one).

    Lastly (for now) try this link:
    Screenshots of all the places homesharing must be turned on.

    If all else fails call: 800 APL Care

    Also let us know what works if you find a solution. If not it helps to know a little about your home PC (win or mac and version), router, and if homesharing with other devices works (can iphone see ur pc itunes library?).


    Edit: added Official Airplay troubleshooting


    For those extremely rare situations:
    Check for interference on your network using (netstumbler for windows)

    2nd edit:
    Make sure Home sharing is enabled in both the Music AND Video settings on you iPhone/iPad.
    Until tonight my iPad Remote wasn't connecting to my Apple tv but my iPhone was due to this.
  22. smp99 macrumors newbie

    Mar 23, 2012
    ATV3 - I have same issue - connection is only good for 5 mins or so. Tried many of the remedies listed, no luck. But another PC running XP 32bit works like a charm, it has never dropped.

    So I am wondering if this is a 32bit vs 64 issue. My problem is on the 64 bit machine (win7). I have another Win7 (32bit) machine, currently not connected, that I will test over the weekend.

    So my question is, for those with problems, is your OS 32 or 64bit.
  23. dgalvan123 macrumors 6502a

    Feb 16, 2008
    Issue with new ATV software

    I have two ATV2's. One is jailbroken and still on 4.4.4. The other is not jailbroken and has the latest ATV software update (with the colorful button "apps" on the home screen).

    The latter (with the latest software update) has had the same problem described by others here (sporadically losing the homeshared mac). The former (with 4.4.4) has not.

    I suspect it is a bug with the latest software version for the ATV2. There may be settings that can be adjusted on your router or in iTunes to work around this bug; I'm not sure.

    But my point is it seems likely that the problem came about with the new software, since it is not affecting people with 4.4.4, and is affecting many ATV2s and ATV3s with the new software.

    Hopefully Apple will fix it with another software update.
  24. monkey28 macrumors newbie

    Mar 20, 2012
    Update: talked with tech over the phone, still no luck, went to apple store and exchanged new unit, problem still here. I think its gotta be the firmware issue.

    I think I have wait until they come with new update in the mean time.
  25. colshine macrumors regular


    Mar 2, 2011
    I had auto generated 32 character password I changed it to something smaller and now my ATV 3 is working fine. Not sure if it didn't like the large password or if it was something else but I'm happy at the moment.

Share This Page

51 March 18, 2012