Apple TV 3 Home Sharing Help!!?

Discussion in 'Apple TV and Home Theater' started by entropyfl, Aug 27, 2012.

  1. entropyfl macrumors regular

    Joined:
    Oct 12, 2009
    #1
    Hi Guys,

    I've searched and can't find my issue anywhere else.

    Apple TV 3 wont accept streaming from the Mac mini sat right next it or the iMac which is upstairs in the office.

    It wouldn't work with Lion and still doesnt work with Mountain Lion. It will load up my itunes library very slowly and when I click play its just stuck on the loading screen.. If I leave it long enough It says it will be available to play in 2-4hours! I've never waiting that long though to find out.

    Any idea's? I'm using the 1st Gen time capsule as the router. which is connecting via a DHCP. and on 802.11n

    It's been like it from day 1 but rentals and netflix work ok.
     
  2. Deadeyeshark macrumors regular

    Deadeyeshark

    Joined:
    Aug 1, 2011
    Location:
    England
    #2
    Reset Your router, shut down your Mac mini and anything else on your network. Change the ATV3 to never sleep, bring it all back online. Make sure itunes is set to home sharing on, as it the ATV. HS was a pain for me until I set ATV to never sleep. Good luck!

     
  3. entropyfl thread starter macrumors regular

    Joined:
    Oct 12, 2009
    #3
    Thanks for the reply.

    That didn't work but did find fix in the end.

    The ATV3 and Mac Mini have always been slow but then I only have 6 meg internet so just put it down to that.

    However, today I was upgraded to 17 and I still had the same issues.

    I have a BT Homehub router which is supplied by my service provider and I plug in my time capsule to that and its always worked at last house etc.

    Anyways I tried connecting the ATV3 and Mac Mini to the BT home hub wireless and it worked like magic.. fast speeds and home sharing worked flawlessly.

    any idea why the machines downstairs aren't working with the time capsule? they both have full WIFI signal.. I just can't figure it out.I can use my laptop and ipad on time capsule wireless downstairs and that works fine.
     
  4. boomhower macrumors 68000

    boomhower

    Joined:
    Oct 21, 2011
    #4
    You need to change the settings on the TC. Both are trying to act as direct routers and that isn't going to work. You need to change the settings on the TC. Essentially your making it a slave to the ISP's router. I'm not a networking guru and can't tell you the settings you need to change though. It sounds like what you really need to do is sell the TC and pick up a NAS. Your essentially trying to use the TC as a NAS and it performs pretty poorly at it. Get a device designed for the job your wanting it to do and you'll be a lot better off.
     

Share This Page