Apple TV 4: Constant Netflix buffering and subtitles issues.

Discussion in 'Apple TV and Home Theater' started by dbrewer80221, Dec 30, 2015.

  1. dbrewer80221 macrumors regular

    Joined:
    Jun 16, 2009
    #1
    i received a new Apple TV for Christmas, to replace my 3rd generation unit. I mostly use it for Netflix, and have been having problems since the day I got it.

    Netflix is constantly buffering, no matter what time of day, day of the week, or what the content is. It's making it virtually un-watchable. I downloaded the speedtest app, and I'm getting over 30mbps, with less than 10ms of ping latency.

    My previous Apple TV never had a single buffering issue, so I'm led to believe it's a problem with this Apple TV, or the Netflix app.

    That brings up my second issue: subtitles keep turning themselves on. I've never used subtitles before, so I'm not sure how they keep getting turned on. It's only in the Netflix app too. I can get them to turn off by telling Siri to turn off subtitles, but as soon as I watch something else, they're back on.

    Any thoughts?
     
  2. benjitek, Dec 31, 2015
    Last edited: Dec 31, 2015

    benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #2
    Could be the ATV4, but then everything you stream from other apps would also rebuffer. Mine is a 32MB model and Netflix vids start nearly instantaneously with no rebuffering at all. I configured my Netflix account via the website settings to only stream HD, not the default 'auto' setting. If you set it to HD, it looks at your connection speed to determine how much pre-buffering, if any, to do; it'll also make adjustments if speed fluctuations result in rebuffering and buffer a little more.

    My speed is a little faster, 50MBPS up/down -- but your 30 should be plenty for instant playback without rebuffering. If your ATV is connected to the router via 2.4GHZ WiFi there could be some interference from other devices going on, if possible force a 5GHZ connection. If you're connected via a network jack, try switching to WiFi -- I've read that's cleared rebuffering issues up for some users.

    When I first got the ATV4, I ran into the same thing with subtitles but I found a setting somewhere that fixed it. Can't recall though whether the setting was in the ATV Netflix app or on the website. Whichever it was, it cleared it up.

    Screen Shot 2015-12-31 at 3.53.58 AM.png
     

Share This Page