Apple Tv 4 drops network connection

Discussion in 'Apple TV and Home Theater' started by Knowlton82, Dec 4, 2015.

  1. Knowlton82, Dec 4, 2015
    Last edited: Dec 4, 2015

    Knowlton82 macrumors newbie

    Knowlton82

    Joined:
    Oct 31, 2015
    #1
    Hi,

    I bought a ATV 4 when it came out. I have since been having problems with the network connection on it.
    After trying diffrent things I finally brought it in and got a new one since they couldn't explain why it dropped the connection. Now I am experiencing the same with the new ATV.
    Every time it drops the connection I have to restart my router. I actually thought it was the router at one point. My ATV is plugged in with cable when it happens.
    However all other devices works perfectly on my network.

    Today I have tried to set it at wi-fi 2.4 ghz and so far it's working like a charm.

    Anyone else inhere having the same problem and got any solutions?
     
  2. rolsskk macrumors 6502

    Joined:
    Sep 1, 2008
    #2
    Have you looked for WiFi channel saturation, and have you considered plugging directly into the router?
     
  3. Knowlton82 thread starter macrumors newbie

    Knowlton82

    Joined:
    Oct 31, 2015
    #3
    I'm sorry if I wasn't clear. It happens while being plugged in with cable...
     
  4. Mac... nificent macrumors 6502

    Joined:
    Nov 20, 2012
    #4
    How old is the router? Intermittent connection is a symptom of a router going bad.
     
  5. Knowlton82 thread starter macrumors newbie

    Knowlton82

    Joined:
    Oct 31, 2015
    #5
    The router is a couple of years. It's a Cisco SA540 and it works like a charm with all other devices. New iPhones, iPad, NAS etc... So I would be surprised if that was the problem. But I can test it quite simple since I have a Time-capsule

    Btw since I changed from cable (This morning) to wi-fi. I haven't experienced any drop of connectivity.
     
  6. rolsskk macrumors 6502

    Joined:
    Sep 1, 2008
    #6
    Okay, time to do some troubleshooting with the router, first change out Ethernet cables. If problem persists, change which jack you plug into on the router.
     
  7. Jme Saunders macrumors member

    Joined:
    Mar 5, 2015
    #7
    I have wrote time and time and time again about this on these forums. I also keep getting the same advice.

    I am also having this problem, I usually get it when I'm using Plex (I've moved over to Infuse now). I've had the same problem via Wi-Fi and Ethernet. I do know that tvOS 9.1 will have some network fixes with it.

    You tried it via Wi-Fi? Do you have 802.11n/ac? Uncrowded 2.4GHz or better yet 5GHz you could check it on? It's more to see if the issue is specifically OS related.
     
  8. yourmn Contributor

    yourmn

    Joined:
    Jun 28, 2010
    Location:
    United Kingdom
    #8
    I am getting a similar issue, however restarting the Apple TV seems to correct the problem.

    My router is only a couple of months old, and I am using the Apple TV on a different band
     
  9. Jme Saunders macrumors member

    Joined:
    Mar 5, 2015
    #9
    Which band might I ask? Also, when do you notice it happening the most?
     
  10. Armandrab, Sep 2, 2017
    Last edited: Sep 2, 2017

    Armandrab macrumors newbie

    Armandrab

    Joined:
    Sep 2, 2017
    Location:
    Chicago
    #10
    Did you ever resolve this? I too have been having issues on one of my 2 Apple TV 4's with PLEX locking up network connectivity on Apple TV OS. I have to reboot to restore and then I can watch a minute of a movie before it happens again. I even deleted Plex and rebooted and reinstalled 2 times and signed it in again. Still drops TCP/IP connections.
     
  11. Jme Saunders macrumors member

    Joined:
    Mar 5, 2015
    #11
    This is a blast from the past! I had all sorts of problems in the first 9 months of my Apple TV to do with networking. By time tvOS 10 was around the corner all the bugs had fixed for me. Same router, same setup, same everything.

    I'm sorry I haven't got a nice big fat solution for you .

    Also, I much prefer Infuse to Plex. I stayed with Infuse after I tried it.
     

Share This Page