Apple TV 4 lagging on remote input

Discussion in 'Apple TV and Home Theater' started by caramelpolice, Nov 22, 2016.

  1. caramelpolice macrumors regular

    Joined:
    Oct 6, 2012
    #1
    My Apple TV 4th gen has recently started having a weird problem. Every now and then, it'll suddenly stop responding when I do something on the remote, but a few seconds later it'll suddenly do whatever I did while it wasn't responding. So say I'm trying to swipe through a menu. It doesn't respond at all, and I keep swiping, and then ten seconds later it does every single swipe all at once. And it's not just the Siri Remote, the Remote app does it too. Already rebooted the thing and did a "reset and update", but it's still happening. Anyone else dealt with this?
     
  2. AshleyHredone macrumors newbie

    Joined:
    Feb 21, 2016
    #2
    I get very similar to this when I find the battery on the remote needs charging.
    Annoyingly the battery indicator still shows around two thirds full but charging the remote does seem to cure it. When this happens the remote app works fine though so although similar it might not be the same problem.
    Still annoying though.
     
  3. caramelpolice thread starter macrumors regular

    Joined:
    Oct 6, 2012
    #3
    I thought I'd update here so that in the event someone in the future has this problem and finds this thread, they get an answer.

    In my case, it confusingly ended up being the HDMI cable that was the culprit. So, the Apple TV uses HDMI to determine your TV model so that the Siri Remote can control the TV volume and power, right? In my case, I was using a very, very long HDMI cable with a kink here and there, and it seems to have been causing issues with the Apple TV getting that info - so whenever it tried to read that info, it would stop taking remote input temporarily until it could get a response from the TV. I believe this is the case, because I noticed going to the remote settings was a pretty consistent way to trigger the issue, and often it was not reading the "use remote for power and volume" settings correctly. I swapped the HDMI cable with a much shorter one and now it works perfectly fine.
     
  4. Childs macrumors member

    Joined:
    May 28, 2010
    #4
    I've experienced something similar, and I found re-pairing the remote fixes it for awhile.
     
  5. Jiraphat macrumors newbie

    Jiraphat

    Joined:
    Oct 5, 2017
    #5
    I had the same problem, this is how you fix it!

    Hold down the "Menu button" and "Volume down - " hold at the same time for 10 sec and your remote should be normal again :)
     
  6. PerioSEAL macrumors newbie

    PerioSEAL

    Joined:
    Dec 27, 2017
    Location:
    DC
    #6
    I’ve had following issues:
    **4K ATV no available for ~5 Sec when iPhone remote seeking for ATV. While older model is already awake. (Maybe my fault and need to check settings)

    **while watching show on ATV, tv suddenly goes blank and flashes fuzzy screen and blank. Takes a minute for system to reboot. (I think I solved this by upgrading HDMI to 4K 18Gbs cert cable; highly recommend this if your just using an old HDMI. Most cables from past are not 4K HDR certified)

    **and I agree, the Siri remote is crap. The iPhone remote needs updating from previous versions also if you haven’t done so.
     
  7. tomandersen macrumors newbie

    tomandersen

    Joined:
    Mar 20, 2018
    #7
  8. appleken macrumors newbie

    Joined:
    Oct 31, 2013
    #8
    Worked like a charm for me. Just told Siri to “Open Netflix”. No more lag in menus. Bizarre.
     
  9. estabya macrumors 6502

    estabya

    Joined:
    Jun 28, 2014
    #9

Share This Page