Apple TV 4k... buggy or just my hdmi cable?

sirwoodland

macrumors member
Original poster
Jan 28, 2014
43
22
Just upgraded from a 4th gen ATV and I'm getting all kinds of bugs. Remote disconnecting, UI lag and unresponsiveness, audio dropping, flickering on screen, etc. Don't have any of these problems with my ATV 4th gen on the same TV. Called Apple and was working with support and then they went silent after couldn't resolve my issues with a replacement unit. I've bought the expensive HDMI cable from their store after my Amazon basics high speed cable was deemed inadequate but that hasn't helped.

Am I an outlier or does this thing need to go back until Apple updates it?
 
  • Like
Reactions: thasoul

vertical smile

macrumors 68040
Sep 23, 2014
3,930
5,133
I'm getting all kinds of bugs. Remote disconnecting, UI lag and unresponsiveness, audio dropping, flickering on screen, etc.
I think yours is buggy.I have 32GB ATV 4k and no problems at all.
One thing that I have noticed about the ATV since tvOS is the inconsistencies in experience from user to user.

If you go back and look at ATV4 threads at its launch, there where a crap load of posts either saying that it was the buggiest Apple device, or that the ATV4 ran flawless.

The ATV3, for the most part, seemed to have a lot less bugs/complaints, but once the ATV4 came out, it was a totally different story. I have experienced all those things you have mentioned, but on my ATV4. Sometimes an update fixes them, but many of the issues have came back with tvOS11. Some of my favorite apps are so buggy, they are almost unusable.

Called Apple and was working with support and then they went silent after couldn't resolve my issues with a replacement unit.
I would say that it is most likely a bug issue if two units displayed the same exact symptoms. Considering I am now experiencing a lot of those bugs on my ATV4 since the tvOS11 update, that is probably your issue too.

I think it is a tvOS issue.
 

Rychiar

macrumors 6502a
May 16, 2006
525
597
Waterbury, CT
Netflix won’t play on mine. Every other movie app works but Netflix just hangs after pressing okay. Can’t get any help to figure it out either
 

400

macrumors 6502
Sep 12, 2015
370
94
Wales
Just upgraded from a 4th gen ATV and I'm getting all kinds of bugs. Remote disconnecting, UI lag and unresponsiveness, audio dropping, flickering on screen, etc. Don't have any of these problems with my ATV 4th gen on the same TV. Called Apple and was working with support and then they went silent after couldn't resolve my issues with a replacement unit. I've bought the expensive HDMI cable from their store after my Amazon basics high speed cable was deemed inadequate but that hasn't helped.

Am I an outlier or does this thing need to go back until Apple updates it?
Cannot help with the rest however, who decided it was the Amazon basics lead? Do you have another source to check? I use the cheapest I can get away with providing they meet a minimum specification. I have a mix of Amazon basics and some other non branded however they all work with my 4K devices. Some were in the region of £3.

Edit. You could have a faulty cable from new, high speed and premium certification should do. As always the proof of the pudding etc. You could switch the output to a lower resolution in the 1080p range to try the lead, thinking out loud on that one as I have not needed to test one.
https://www.hdmi.org/consumer/buying_guide.aspx#Choose
I am using High speed at 4k with 4:2:2 OK but already had the cable. If it had not worked then I would have bought the Premium. But still no more loot than I needed to. And especially not from Apple shop at £30.
 
Last edited:

Rychiar

macrumors 6502a
May 16, 2006
525
597
Waterbury, CT
Does other DRM content (i.e. Carpool Karaoke or other Apple Music content) work?
yes and even apple geniuses couldn't figure this out. last night i found out that if i play something on airvodeo hd and then go back to netflix it will work. just makes no sense. this has only been an issue since i went 4k. netflix always plays immediately from my smart tv itself
 

ErikGrim

macrumors 601
Jun 20, 2003
4,227
2,767
Brisbane, Australia
yes and even apple geniuses couldn't figure this out. last night i found out that if i play something on airvodeo hd and then go back to netflix it will work. just makes no sense. this has only been an issue since i went 4k. netflix always plays immediately from my smart tv itself
That’s an odd one. Two of the 11.1 betas stopped playing video from Netflix from me, but neither AM video or iTunes worked either so I figured it was an HDMI DRM bug.
 

coolbreeze2

macrumors 6502a
Sep 24, 2009
615
352
Just upgraded from a 4th gen ATV and I'm getting all kinds of bugs. Remote disconnecting, UI lag and unresponsiveness, audio dropping, flickering on screen, etc. Don't have any of these problems with my ATV 4th gen on the same TV. Called Apple and was working with support and then they went silent after couldn't resolve my issues with a replacement unit. I've bought the expensive HDMI cable from their store after my Amazon basics high speed cable was deemed inadequate but that hasn't helped.

Am I an outlier or does this thing need to go back until Apple updates it?
I just received the Belkin cable that Apple sells and it solved all my bugginess including black screen, random restarts, and not waking up.
 
  • Like
Reactions: OddyOh and ErikGrim