Apple TV 4K: Performance issues

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Hi,

Since I switched my Apple TV 4K to 4K Dolby Vision output (since I got a new TV a few days back) I have severe performance issues. A few examples:

- Tried to resume a rented movie. First I got a black screen then the loading circle appeared and it loaded and loaded... Nothing happened. I then tried scrolling to a different position in the movie and that solved it. This happened two times already.

- Tried to rent and play a movie: Black screen appeared, loading circle appeared for a fraction of a second, disappeared, reappeared again etc. After about a minute it appeared again but was stuck (didn’t move). When scrolling on the trackpad I heard the sound of scrolling through menu items. After repeatedly hitting the menu and TV buttons I could go back to the home screen and resume playback which then worked.

Basically my Apple TV is incredibly glitchy since switching to 4k.

Any idea on how to fix that?

Thanks and best wishes
Chris
 

FarmerBob

macrumors regular
Aug 15, 2004
150
40
Are you running the latest Firmware update or did the latest update cause the issues. I'm running, as of last night, 13.3, and have mine set to 4KSD and "Match Content" turned on, as suggested in many tech forums, and when necessary it steps up and all is well. Not everything on the box is Top of the Line. Set it so it can mingle with the meanial masses and step up when needed. I was having general picture issues thinking I had to have the ATV4K set to all the best settings off the top and all the time. Not so. Also make sure, if your TV supports it, to have the HDMI port that the ATV is connected to set to the appropriate setting for the port to utilize what the ATV will be sending to the TV. This made the world of difference on my TV.

It's the little things that make all the difference . . .

P.S.
I have noticed that there are loading issues with Amazon Prime 4K HDR fare.
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Thanks for your answer. I‘m running tvOS 13.2. I noticed the glitchy performance since switching to 4K Dolby Vision on the Apple TV. I enjoy the look of HDR e. g. on the screensavers so that’s why I have it set to Dolby Vision. But I turned on Match Dynamic Range and Match Frame Rate. On my Sony TV I enabled the Enhanced Format option for the HDMI port that my Apple TV is connected to.
 

HDFan

macrumors 68000
Jun 30, 2007
1,706
408
Try downloading the speediest app. What are the results? You might not have enough bandwidth.
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Could it be an issue related to the HDMI cable?
That also came to my mind but then I did the HDMI signal test that you can do in the settings and then tvOS told me that everything is working fine.
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Okay, I'm gonna give another cable a try if the problem persists.
 

gnomeisland

macrumors 6502a
Jul 30, 2008
660
328
New York, NY
I don't have any personal experience with that TV. I did look at getting a Sony at one point, and I remember that some models had . . . issues with Dolby Vision. I didn't follow it too closely but it seemed Sony's implementation was either non-standard or just somehow different than Apple's. Sorry to be vague but I'm going off of memory.

Do you have the same issue with non-Dolby HDR? Are both the TV and Apple TV running their latest firmware/software?
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Do you have the same issue with non-Dolby HDR? Are both the TV and Apple TV running their latest firmware/software?
Since getting the new TV I either watched Dolby Vision HDR or SDR. What's interesting is that (so far) I had no problems with Netflix 4K Dolby Vision content. So far the performance problems only occurred with 4K Dolby Vision movies that I rented via the "movies iTunes" app.

Yup, running the lastest firmware everywhere.
 

gnomeisland

macrumors 6502a
Jul 30, 2008
660
328
New York, NY
Ah. That is really strange. I think this is a "call Apple" problem, especially since the issue is limited to JUST iTunes rentals. Wish I could offer more help!
 

Marshall73

macrumors 68000
Apr 20, 2015
1,602
1,330
I use my Apple TV with Dolby Vision on and sometimes get a spinning wheel when playing Apple content. If this happens I just hit the play button twice on the remote. The first press pauses the video and the second plays it and it starts playing straight away. Doesn’t happen all of the time just occasionally.
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Certainly sounds like it could be a cable issue given that the only change you made was the TV.
Quick update on the situation: I now also encountered a similar problem watching a 4K series on Prime Video. The audio and video stuttered and the TV even switched to a different HDMI input 😯 I then tried the cable that the Apple TV came with and that so far works like a charm now 🤗
 

chris4565

macrumors 6502
Original poster
Sep 22, 2018
321
82
Would have been too good to be true: Now had a similar problem with Prime Video: When an episode started the time bar at the bottom (or whatever that’s called) flickered rapidly on and off for quite some time and the loading indicator showed up. Eventually I got it to play by pausing and resuming a couple of times. I think there’s something wrong with my Apple TV or is anyone also having these issues?
 
Last edited: