Resolved Apple TV 4th no longer execute automation

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by mbfanos, Oct 20, 2016.

  1. mbfanos, Oct 20, 2016
    Last edited: Oct 21, 2016

    mbfanos macrumors newbie

    Joined:
    Apr 12, 2011
    #1
    Hello, I have been using homekit with ecobee3, roughly 10 Hue lights, Schlage Sense for about a month and everything worked flawlessly. All the automation tasks were executed properly by the Apple TV 4th gen (hub). All the scenes like Arrive Home, Leave Home, Good morning, Good night were done by Apple TV automatically. However, for the past few days, all the automation tasks just stopped. I did some tests and all of them failed. For example, yesterday at 4:00PM, I set a task to turn on all the lights at 4:05PM. At 4:05PM, nothing was turned on :(.
    So, today, I just reset everything (Homekit, lights, locks, ecobee3), including resetting the Apple TV to factory default settings. I re-paired everything to HomeKit. I did the automation task like yesterday and it still didn't work :(.
    Has anyone got this problem before? How do you solve it?
    Thank you

    P/S: It works again. No idea why. Anyway, I guess the problem is solved.
     
  2. rjjacobson macrumors 6502a

    rjjacobson

    Joined:
    Sep 12, 2014
    #2
    Well iOS 10.1.x broke it for me with same results. My iPad pro was hub -- it grabbed the initial config of homekit rather than my apple TV (but thats another story). I found that I had to reboot my iPad hub, open the Schlage app, install a firmware update to the lock. Then homekit worked again and my iPhone app could see the lock, and thus SIRI can see it on my Apple Watch now ;-) So if you have any iOS app working make sure your firmware is updated on the lock. That seems to solve alot of these problems for me and others (on other threads)
     

Share This Page