Apple TV and constant problems - surely it's not just me?

Discussion in 'Apple TV and Home Theater' started by themoffster, Nov 22, 2012.

  1. themoffster macrumors regular

    Apr 26, 2011
    I love my ATV2, i really do.... when it works.
    I've a fantastic collection of tv shows and movies on my 2011 iMac which i stream over onto the ATV2 via wifi.

    Time after time however, I see the following problems:

    1. ATV2 is on, iMac is on and iTunes running, ATV2 says that i need to start a computer that my shared library is on.
    2. ATV2 is on, iMac is on with iTunes running. I select computers and it just displays "connecting to themoffster's library" (or something similar) and does nothing else
    3. iMac is on, ATV2 is on and the icon for airplay is not in the top corner of the iMac screen
    4. ATV2 has played a tv show, when i click to start the next one the spinning icon appears and nothing happens. When i 'menu' all the way up to the main screen, the computer icon shows the "turn on a computer that contains themoffster's library" (or something similar).
    5. On my iPhone 4S and my wife's iPhone 4, the airplay icon frequently drops off despite sitting literally two meters from both the ATV and the routers.

    I can't see a pattern to what causes any of these problems.

    These are the problems that happen over and over. Sometimes a restart of the ATV2 and iTunes will resolve the issue, but sometimes it won't.
    I leave my ATV2 on all the time ('sleep never' in settings). The iMac sleeps after a period of inactivity.

    I've got two routers in repeat mode, with both settings all working fine.
    I frequently work from home via VPN and I never have connection issues with my work laptop (which unfortunately runs Windows 7).

    It's not a bash apple thread - I just seriously wonder why i have all these problems continually. A google reveals a lot of similar issues, but dating as far back as 2010. I struggle to believe in nearly three years these issues have not been resolved as they are affect the core functionality of the ATV.

    When it all works fine, the ATV is amazing - by far the best piece of apple kit i have.
  2. Wavell macrumors regular


    Nov 7, 2007
    Essex, UK
    I used to have an ATV2 and experienced very similar issues to you - if it's not so already, try hardwiring it. Oddly enough my ATV3 only behaves if its wireless

    As you've noticed, these issues have been known about for years and Apple still haven't fixed them - it's frustrating :(
  3. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
  4. themoffster thread starter macrumors regular

    Apr 26, 2011
    Unfortunately hardwiring isn't an option as the router is in another room and would require going trough a wall


    Not jailbroken and every piece of equipment is upgraded as much as it can be
  5. scottw324 macrumors 6502

    Mar 5, 2012
    Try a Powerline adapter to get the hardwire effect. I use a rocketfish Powerline adapter in my house to wire my laptop in my bed room which runs my iTunes server for my three Apple TV 3's in my house. They all run off of wifi without any problems. Only thing I noticed with both ATV3 and ATV2 is that some times I have to back out of the computer menu and go back into it 2 or three times to get to my movie library.

    I contribute this to my ext HDD spinning down when it isn't being accessed. So it takes a minute for it to spin up and for the computer and iTunes to get access to the video files on it. Typically doing this will fix the issue. This is my experience with the ATVs and why I think it does this. Now I do not have a computer with an SSD so I cannot say that this wouldn't be an issue if the HDD never turned off. Maybe in the future I will find out but my laptop is still running strong after being on for the last two years and being a 4-5 yr old laptop. It is a windows laptop. I might get a Mac mini when it dies.
  6. slothrob macrumors 6502

    Jun 12, 2007
    It sounds like your aTV might be suffering from wifi interference. It tends to be susceptible to this due to the small size of it's antenna and the fact that it is placed close to other electronics.

    I had trouble with mine when it sat next to my cable box. I moved it up to the next shelf and all my problems went away. In some cases, moving your router a little can double it's performance.
  7. mdapplefan macrumors newbie

    Nov 23, 2012
    Had some of the problems you mention. At the advice of others on one of the forums, I assigned a static IP to my ATV3. That seemed to help somewhat. After just installing 2 power over electric (Asoka Pluglink 9650) at my daughter's house and seeing a tremendous increase in performance on her ATV3, I ordered 2 for my house. There was no setup required of the pluglinks...just plugged one in a recepticle near the router and connected a cat5 cable between the two. The second pluglink was plugged into a recepticle near the ATV3, and connected the pluglink to the ethernet port on the ATV3 with a cat5 cable. The performance improvement is ten-fold better than what I was experiencing with wi-fi.

    You can get new power over electric (POE) devices on EBay for well under $30. My 2 new Asokas were under $20. There are many other brands that can transmit at even faster mbps.
  8. themoffster thread starter macrumors regular

    Apr 26, 2011
    thanks for the replies...
    I can't understand why it would be wifi interference, when the ATV2 itself reports a "full bars" signal strength.

    The ATV2 is next to my Sky+ HD box, so i might try and move it along slightly and see if it improves.
    The fact it can be working fine one minute, then not the next (when nothing has been changed by me) made me think that it was an issue with the ATV2 itself.

    It's also setup with a static ip
  9. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    It could be your router.

    Just an FYI, you can sell your old ATV2 for more than a new ATV3.
  10. mdapplefan macrumors newbie

    Nov 23, 2012
    One of the reasons I switched from wi-fi to powerline adapter was the startling reduction in bandwith when I tried something as simple as watching a movie preview on my ATV3. I had full bars on the ATV, but it was taking 5 minutes to buffer a 2 minute preview.

    I downloaded the free SpeedTest app from the app store onto my ipad3. I placed the ipad directly beside the ATV and ran the speed test. I was getting 6-8 mbps consistently from several speed tests. So then I started a speed test and quickly clicked on a movie "Preview" to buffer on the ATV. In every instance, bandwidth went down to almost zero on the speed tester! I can imagine that if I had another wi-fi device nearby suddenly requiring bandwidth, both would have suffered in performance.

    You might try a similar experiment with your devices to see if turning one of them on at a time while running the speed test causes a performance issue. I don't know how accurate the speed tests are, but they should be accurate enough to help narrow some things down.
  11. themoffster, Nov 23, 2012
    Last edited: Nov 23, 2012

    themoffster thread starter macrumors regular

    Apr 26, 2011
    That's an excellent post. Thanks very much for your input. Ill let you know how I get on.

    Update: it made absolutely no difference. The speed test on my iPhone stayed the same when right next to the router, next to the ATV when nothing is streaming and when streaming.
    I'm horribly confused
  12. mdapplefan macrumors newbie

    Nov 23, 2012
    Really sorry to hear that that didn't help! Now you have me wondering if my ATV3 was having a wi-fi issue, which caused me to switch to ethernet.
  13. macnjack macrumors member

    Oct 11, 2011
    Are you fully updated? Because the latest update caused my apple tv3 to begin losing wifi connection regularly. Unplugging was the only solution to restore.

    Convinced it was my router (Apple extreme), I seperated my wifi bands, assigned static ip, but then saw there are thousands of people with wifi connection issues with atv2 and atv3 after the latest update. For some people it has taken a few months for the gremlins to come out and appears as degraded wifi performance. Others it's instant.

    I had to downgrade from 5.1 to 5.02 to get it working again. All is well for now but I've only been reverted a week.

    A few links below on the topic..

    Instructions to downgrade:
  14. themoffster thread starter macrumors regular

    Apr 26, 2011
    quick update....
    i think i have solved the issue. I have two routers wired together and setup to repeat.
    I had both routers on separate channels instead of the same one. also the WDS settings on the router i disabled as you only need that when the two routers aren't wired together.

    so far (2 days later) it's all worked swimmingly.

    thanks for the help everybody - it looks like it was my own fault all along!

Share This Page