Apple tv and iTunes home sharing problem

Discussion in 'Apple TV and Home Theater' started by afteryouwho, Jul 14, 2014.

  1. afteryouwho macrumors newbie

    Joined:
    Dec 31, 2007
    #1
    I am running a last generation ATV with 6.2 software with an LG SmartTV.

    There seems to be something unstable about this product and I don't know where the problem lies.

    My ATV consistently loses connection to iTunes and I have to go into iTunes and turn off Home Sharing and turn it back on to get the ATV to reconnect to my movies. Once I do this, it all works fine... until it loses connectivity again.
    I don't know if the problem is with my ATV box, my wifi connection or iTunes.

    If this problem sounds familiar to anyone, I would appreciate any help on how to fix it.

    Thanks very much.
     
  2. StevenB14 macrumors regular

    StevenB14

    Joined:
    May 23, 2012
    Location:
    Scotland
    #2
    I had a similar issue where home sharing would drop while I was watching something.

    What solved my issue was to allocate static ip addresses to the devices on my home network. It has been pretty stable ever since.
     
  3. NikkiJayne macrumors regular

    NikkiJayne

    Joined:
    Mar 23, 2012
    Location:
    England
    #3
    Hi, how would you go about doing this? My Apple TV keeps dropping the connection from iTunes on my Macbook, but works fine with my iPhone streaming to it.
     
  4. StevenB14 macrumors regular

    StevenB14

    Joined:
    May 23, 2012
    Location:
    Scotland
    #4
    You would need to log into your router and change the settings in there. Should be called DHCP settings or something along those lines.

    If you google the model of your router model and "assign static ip addresses" you should find steps to do it pretty easily.

    If you are struggling let me know and I'll do my best to help you set it up.
     
  5. Deadeyeshark macrumors regular

    Deadeyeshark

    Joined:
    Aug 1, 2011
    Location:
    England
    #5
    Also, ensure your Apple TV is set to never sleep, this can cause a disconnect from Home Sharing.

    I've been using Home Sharing for years, it used to be horribly flakey but ever since I swapped out my router for an AirPort Extreme It has been very reliable.
     
  6. afteryouwho thread starter macrumors newbie

    Joined:
    Dec 31, 2007
    #6
    Thanks for taking the time to answer my query. I am not computer savvy so this will seem pretty sorry:

    From the replies and some digging on internet, I am guessing my problem is from my wifi connection between my mac mini and my TV through AppleTV. I am also guessing that I can change to a static ip through network on System Preferences. I think I see how to do this but am scared to actually carry it out until I am sure. (see attachment)

    If I give my wifi connection a static ip that should stop the disconnecting?

    I just reread that and it seems pretty obtuse. Hope you can make some sense out of it. :)

    Thanks.
     

    Attached Files:

  7. macalla macrumors member

    Joined:
    Jul 13, 2014
    #7
    The static IPs have to be set in the devices themselves. So you have to do it in the AppleTV. Make sure it's on the same subnet as the router.

    The router has to be DHCP on the WAN side because it is receiving its IP from your internet provider. Looks like your AppleTV is set up correctly from the photo and has IP of 192.168.1.1.
     
  8. StevenB14, Jul 15, 2014
    Last edited: Jul 15, 2014

    StevenB14 macrumors regular

    StevenB14

    Joined:
    May 23, 2012
    Location:
    Scotland
    #8
    The way I did it on my router was to assign an IP address against the MAC address for the device under the DHCP settings.

    As macalla pointed out you could also assign a static ip address manually on each device. When I am home later I will post a step by step for assigning a static IP address on your Mac and the Apple TV unless someone beats me to it :)

    **edit**

    Just realised something. If you were to assign the IP on the device only there would be potential for conflicts as the IP address isnt reserved against the device on the router so that address would be available if your Mac is turned off.

    If you post the make and model of your router I'll help find a step by step.
     
  9. macalla macrumors member

    Joined:
    Jul 13, 2014
    #9
    Yes, that's true. One has to be on top of it, if you want to properly manage a home network with a mixture of static and DHCP IPs.

    So my method is to keep a spreadsheet with a IP listing of all my devices. Then I reserve a block of IP addresses for the DHCP server/router to use and never assign any static IPs for my devices in this space so there won't be conflicts. :)

    i.e.
    192.168.1.1 - router/DHCP server
    192.168.1.2 - firewall

    Reserved for DHCP (tell router to assign in this space)
    192.168.1.10 - 90

    Servers
    192.168.1.100 - iTunes Server
    192.168.1.101 - Lacie NAS

    Workstations
    192.168.1.150 - iMac
    192.168.1.151 - MDD G4
    192.168.1.152 - PC Gaming

    Streaming devices
    192.168.1.160 - AppleTV
    192.168.1.161 - Roku 3

    etc...
     
  10. afteryouwho thread starter macrumors newbie

    Joined:
    Dec 31, 2007
    #10
    If you post the make and model of your router I'll help find a step by step.[/QUOTE]

    Home Station ADSL Amper ASL- 26555
     
  11. StevenB14 macrumors regular

    StevenB14

    Joined:
    May 23, 2012
    Location:
    Scotland
    #11
    A lot of the information I have come across is in Spanish which I don't speak.

    From what I can gather you will need to log into the router. Either by typing http://192.168.1.1 or http://homestation into your address bar. I think the default username/password is 1234 unless you have changed it.

    From there you want to find LAN settings and, from the look of the user guide, you will need to turn DHCP off and it should give you the option of assigning static IP addresses to every device in your network. With DHCP off you will need to make sure any device you want to access the network is allocated an IP address.

    I'm not sure you are able to assign an IP address to a specific device without turning DHCP off. Normally you can but the user guide isn't clear.

    User guide

    Hopefully this helps. Couldn't find much detailed information.
     
  12. afteryouwho thread starter macrumors newbie

    Joined:
    Dec 31, 2007
    #12
    Thanks a million. I speak Spanish so that's no problem. Funny thing is that when I clicked on the link, the guide came up in English!!

    Now up to me to get it all set up.

    Cheers.
     
  13. Gimped80 macrumors newbie

    Joined:
    Feb 17, 2015
    #13
    Offer to help still stand?

    I'm having similar issues with my connection. Every time I try to use my AppleTV to play stuff from iTunes on my Mac it drops the connection. Might be for a second or 2, or it might be until I reconnect it. It's beyond annoying. My iPhone craps out, too, but I think it's a distance thing...

    AppleTV is Gen2. My Mac is running Yosemite. Using a Cisco DPC3825 -- yes, it's the one my ISP gave me.

    Not a total networking newb, but a helping hand would appreciated :)
     
  14. GraemeS macrumors newbie

    Joined:
    Oct 11, 2017
    #14
    Try the following. On your Mac, click System Preferences > Security&Privacy > Firewall > Advanced > Deselect Log out after xx minutes of activity. This will stop iTunes switching off while watching Apple TV. If the number of minutes in the prior selection equals the time at which the connection is lost, this is probably your problem.
     
  15. Artitu macrumors newbie

    Artitu

    Joined:
    Jun 19, 2016
    Location:
    Dallas, Texas
    #15

    After much frustration, I have found a solution, at least for me.



    Downgrading is not necessary.



    IOS 11 for Apple TV will not read AAC encoded MP4 files anymore. I re-encoded all my movies as AC3 mpeg-4 files and they all play flawlessly. When people create videos from their DVD's, almost every encoder uses AAC MG4 as the default setting. Some people only have iTunes movies, and they should all work fine. This is why some people were having problems and others were not.



    Just recode all your movies to AC3 MPEG-4 and you should be fine.



    Hope this helps.
     

Share This Page