Apple TV audio language localization bug

Discussion in 'Apple TV and Home Theater' started by Magpie69, Mar 22, 2009.

  1. Magpie69 macrumors newbie

    Joined:
    Nov 17, 2008
    #1
    I think I've found a bug in the Apple TV software (version 2.3.1 - I don't know if this occurs with other versions too).

    My general language setting in the Apple TV is Italian.

    I encoded a multi audio track (italian and english) movie with Handbrake. Opening it with Quicktime I can choose the soundtrack:
    - English (United States)
    - Italian
    It works perfectly, so encoding is OK.

    I uploaded it in iTunes and synced the Apple TV.

    When I play it on the Apple TV, pressing the Play button for a while the chapters/audio menu appears. Choosing the audio options, I see 2 "Italian" audio tracks, both tagged! In fact, one is the english one, the other is the italian. The problem is the way it is shown.
    See picture:

    [​IMG]

    I tried to choose English as the general language setting.... trying again, the audio option inside the movie shows the 2 audio tracks correctly (English, Italian).
    See picture:
    [​IMG]

    So I guessed it might be an issue in the software localization. And it surely is.
    Evidence is that, choosing Italian as the general language setting (menu Settings/General/Language), and then going to the Settings/Audio & Video/Audio Language, the Italian option occurs TWICE, the first where the English one should be (the first after "Default").
    See picture:
    [​IMG]

    That's the reason why, in video files, the English track is shown as "Italian".

    Some more tests showed that the same problem is present in French and Danish localization.

    Anybody else noticed that?

    Apple: please fix it in the next upgrade....
     
  2. realityking macrumors member

    Joined:
    Dec 9, 2008
    #2
    I doubt Apple is following the forum ;) So this post doesn't help you at all.

    I suggest you actually write a bug report in the intended place: https://bugreport.apple.com
     

Share This Page