Apple TV Cannot Join Encrypted Networks

Discussion in 'Apple TV and Home Theater' started by EmpireStateMan, Aug 3, 2008.

  1. EmpireStateMan macrumors newbie

    Aug 3, 2008
    I have a 14-month old Apple TV that has worked perfectly since I bought it. However, starting about 2 weeks ago, the Apple TV has been unable to join any wireless network that requires encryption. The Apple TV has no problem joining an unencrypted/unsecured network. The Apple TV lost its ability to join encrypted networks within about a week after I upgraded to the 2.1 version of the Apple TV software. My Apple TV has never before had any problems connecting to my wireless router (a Linksys WRTP54G-VR), and nothing has changed about my wireless network's settings in the last 18 months, leaving me very puzzled. After I type in the correct 26 character alphanumeric encryption code after selecting "WEP 40/128-bit ASCII", the Apple TV reports, "There was a problem connecting to the network. There was a problem with your network connection. Check your settings and try again. (-6)"

    I am 100% positive I am supplying the correct encryption code, as I am very experienced with networking and have 4 other devices that connect perfectly to my wireless router using 128-bit WEP encryption, including my iPhone, iMac, and 2 IBM ThinkPad notebook computers, so this definitely is not a case of my mistyping the 26 character encryption key or getting CaPiTaLiZaTiOn wrong.

    When I disable encryption on my own router, the Apple TV connects to it with no problem, so signal strength is not an issue. I can also join other unsecured networks with no problem. The problem joining a network only happens when I am trying to use encryption.

    I have tried EVERYTHING I can think of:

    1. I tried restoring the original factory settings. (I could not join the network even using the original 1.0 Apple TV software.)

    2. I tried re-upgrading the Apple TV software to 2.1 to no avail.

    3. I tried changing the SSID to something different.

    4. Instead of selecting "WEP 40/128-bit ASCII" as I have always used on the Apple TV, I tried selecting the "WEP Password" method to no avail. I also tried joining the network by selecting "WEP 40/128-bit Hex" and supplying the Hex version of my WEP password to no avail.

    5. I temporarily modified the encryption settings on my router to WEP 64-bit and then tried having the Apple TV join the network using a 64-bit encryption key to no avail.

    6. Even though all my other devices accept the router's 128-bit WEP encryption key in lower case, I tried typing the 26 digit encryption key using ALL caps and again in all lower case.

    7. I tried multiple soft reboots.

    8. I tried multiple hard reboots after disconnecting the power cord from the wall.

    9. I tried joining the network while the Apple TV was connected to my TV using HDMI instead of component video, which I have always used on this device.

    10. I tried stroking it gently, kissing it, and whispering sweet things to it. ;)

    I called Apple and tried to purchase Apple Care, but as my 1 year warranty expired 53 days ago, I was ineligible to purchase the extended warranty. The technician was kind enough to suggest rebooting, restoring the factory defaults, and he also suggested that I type a "$" symbol before the Hex password, which unfortunately was a bad suggestion because Apple TV does not permit you to type a "$" symbol when the Hex password option is selected.

    I am at my wits end. :confused: Can someone please help me and make some further suggestions? I have a feeling this may be due to a bug in the 2.1 revision of the software, but I cannot find any confirmation of that fact nor any workaround. I am doubtful my hardware is damaged because it joins unencrypted networks perfectly. Thank you very much in advance for any help you can offer me.
  2. RGunner macrumors 6502a


    Jul 3, 2002
    Midnight Sun
    Only one suggestion

    Use WAP.

    WEP is not secure.
  3. EmpireStateMan thread starter macrumors newbie

    Aug 3, 2008
    I would be delighted to use WAP. However, I do not believe WAP is an option on the Apple TV, or I cannot find out how to select WAP.

    Apple TV presents me with 3 options for joining a secured/encrypted network:

    1. "WEP Password"
    2. "WEP 40/128-bit Hex"
    3. "WEP 40/128-bit ASCII"

    Where do I choose WAP instead of WEP? Thanks....
  4. RGunner macrumors 6502a


    Jul 3, 2002
    Midnight Sun
    not sure..

    My aTV is using WAP2, not sure within what menu its in.... will look

    ooops, meant WPA2
  5. dbwie macrumors 6502

    Jun 11, 2007
    Albuquerque, NM, USA

    I think the earlier poster meant WPA or WPA2 encryption. My AppleTV was connected to such a network at one point. Change the settings on the router first, and then plug in the AppleTV and set it up. WPA is more secure then WEP.

    Can you connect the AppleTV via wired ethernet? That is the best and most reliable solution if you can do it.
  6. SASouth macrumors member

    Jan 7, 2006
    What troubleshooting have you done on the router side? You might want to start looking there next.

    Have you tried just doing a simple reboot of your Linksys to see if the problem goes away?

    Have you applied any firmware upgrades to the Linksys recently? If you have, you might try going back to a previous version of firmware. If you haven't, you might want to look to see if there is a new version that could possibly solve your problem.

    I'm curious as to why you aren't using WPA2 on your router? It's much more secure than WEP which can be broken in a matter of minutes.

    Try changing the encryption your router is using to WPA2 to see if that makes a difference. Also, use a shorter password of between 8 to 16 characters to make the password easier to type and let you be reasonably certain that you've typed the password correctly. You can make the password more secure by using a random sequence of letters and numbers, or barring that use two unrelated words with numbers separated by punctuation. This means of course, that you'll have to reconfigure the other devices on your network to use WPA2, but in the long run it is really more secure for your network if you do that anyway.

    I hope this helps...

    BTW, my :apple:TV 2.1 is using WPA2 with a hidden SSID and works great.
  7. EmpireStateMan thread starter macrumors newbie

    Aug 3, 2008
    Thank you for this reply. Since every other device I own (4 other devices) connect perfectly to my router, I am very doubtful that the router is the problem. However, I recognize that the router needs to be considered. I have indeed tried rebooting the router many times. I have not installed any firmware upgrades to my router lately, and I am using the latest revision of the firmware for the router.

    Regarding WPA2, I have no good reason as to why I have been using WEP. Taking your advice, I have now disabled WEP and enabled WAP2. I rebooted the Apple TV and selected my network's SSID. I am now only prompted for a password to join the network. I typed in the new WPA2 password that I assigned, and I get the same error: "There was a problem connecting to the network. There was a problem with your network connection. Check your settings and try again. (-6)"

    So it appears I am back where I started. :(
  8. kolax macrumors G3

    Mar 20, 2007
    Change the wireless channel.

    I have an Airport Extreme which my Apple TV connects to, and I had to play around with the wireless channel in order for my MacBook Pro, Apple TV, and my flatmate's Dell to connect.

    Some wireless channels everything worked apart from the Apple TV. I'd have a play around with that - I'm confident that will fix your problem.
  9. sandman42 macrumors 6502a


    Oct 23, 2003
    I'll second trying another channel. I had to do that on my wireless network recently, because my :apple:TV was periodically dropping the connection -- the channel change did the trick. Could be that one of your neighbors has started using some device that interferes, and it may only affect your :apple:TV (possibly even just due to it's location), and the 2.1 upgrade was just coincidence.
  10. EmpireStateMan thread starter macrumors newbie

    Aug 3, 2008

    I changed the encryption method to WPA2. Apparently, a hard reboot of the router AFTER changing the encryption type made the difference. I went back to the Apple TV to try joining the network again (after the hard reboot of the router), and then magically the Apple TV successfully joined the network.

    I am not sure why WEP stopped working, but WPA2 is a better encryption method anyway. Thanks to everyone who responded. Now I can enjoy multiple speaker sharing throughout my apartment and control it all on my iPhone like the major dork that I apparently am. :D

Share This Page