"Apple TV cannot play the current song" Why not?!?

Discussion in 'Apple TV and Home Theater' started by IdiddidI, Feb 19, 2008.

  1. IdiddidI macrumors member

    Jan 22, 2008
    I upgraded to Take 2 when it came out and everything has been working just fine. I'm streaming my whole music library and have not had any issues... until yesterday. While listening to an album, ATV came to track 2 then stalled. The screensaver turned black, and then ATV restarted itself (had to choose language and screen resolution when it rebooted).

    So I tried to play the same song again and got the message: "Apple TV cannot play the current song." (I could leave this screen by hitting Menu--did not reboot ATV.)

    I played it on my computer and it was fine.

    So I tried a different song on ATV and got the same message. Same song works on iTunes.

    Now it seems none of my songs can play on ATV, but they are all playable on iTunes. ATV is obviously seeing my iTunes DB since it is letting me select the songs, and it was all working fine before.... any thoughts on what do to do next? :confused:
  2. Peace macrumors Core


    Apr 1, 2005
    Space--The ONLY Frontier
    Make sure your hosting computer isn't going to sleep. In Apple TV 2 the "My Music" includes music on the actual Apple TV AND music from your iTunes library on your computer if the computer is set up to be the sync computer.
  3. IdiddidI thread starter macrumors member

    Jan 22, 2008
    Thanks for the reply, but my iMac is set to never sleep.

    Also, I should point out that this music was ripped, not purchased through iTMS, so it cannot be an authentication issue.
  4. bradden macrumors newbie

    May 1, 2008
    Any resolution here?

    Hi, I have the same problem, anybody have a resolution?
  5. SilentPanda Moderator emeritus


    Oct 8, 2002
    The Bamboo Forest
    Since the music was ripped, can you post a screenshot of the settings either from the get info on the file in iTunes or from the ripping program. It might be possible that you have some codecs installed on your Mac that are not available on your Apple TV or you are using settings that are not compatible with Apple TV.
  6. hauntedcity macrumors member


    May 4, 2007
    I get weird little glitches like that with my :apple:TV every few weeks. I usually restart my MacBook, unplug & restart my Airport Extreme, and unplug & restart my Apple TV. It's annoying (and should be unnecessary), but effective.
  7. kolax macrumors G3

    Mar 20, 2007
    Streaming from your Mac to Apple TV doesn't work - both ways?

    1. Select the song in iTunes and use AirTunes to play it
    2. Use Apple TV remote and go into Music and try accessing iTunes library there

    Try restarting your Mac (or iTunes if you haven't already).
  8. IdiddidI thread starter macrumors member

    Jan 22, 2008
    Ultimately, this is what has worked for me as well. It doesn't happen very often, but when it does, restarting the Mac, the router, and the ATV seems to do the trick.
  9. ipedro macrumors 68040


    Nov 30, 2004
    Toronto, ON
    I've just had this error. Everything has been working fine. I sync my entire library. None of the songs will play. Videos do play.

    I unsyched and resynched my library and still nothing. I've tried hard restarting all my equipment and still nothing.

    I'm thinking all I have left is to Factory Restore... the issue with that is that I have 2 video rentals that I'm afraid I'll lose if I wipe my tv clean.
  10. ipedro macrumors 68040


    Nov 30, 2004
    Toronto, ON
    I contacted AppleCare and thought I'd share my results with them:

    They were unable to locate the source of the issue. The only way to resolve my problem was through a factory restore. It was kind of cool to see AppleTV 1.0 again. :)

    AppleCare referred me to iTunes support which put my rentals back in the download qeue (including 2 rentals that I had already watched and expired).

Share This Page