• Did you order new AirTags? We've opened a dedicated AirTags forum.

bcblackmer

macrumors newbie
Original poster
Dec 9, 2019
3
1
Hi,

This is a new issue for me. My Apple TV automatically connects to speakers in other rooms. I have 2 Homepods in my kitchen and an Airport Express.

It's quite annoying as I don't want the sound going through those speakers.

Any idea of how to make this stop or what to look for?

Thank you in advance!
 

Itinj24

macrumors 68000
Nov 8, 2017
1,972
840
New York
I haven’t really messed around with this much but I know that at the least, a Siri Shortcut could accomplish this.

I have a Shortcut called “Disney Time” for the kids and it turns on the Apple TV, opens the Disney+ app, opens the respective Apple TV Remote on my phone and sends audio to that TV’s speakers and the HomePod in that room and sets the volume for the HomePod to 50%.
 
Comment

bcblackmer

macrumors newbie
Original poster
Dec 9, 2019
3
1
I haven’t really messed around with this much but I know that at the least, a Siri Shortcut could accomplish this.

I have a Shortcut called “Disney Time” for the kids and it turns on the Apple TV, opens the Disney+ app, opens the respective Apple TV Remote on my phone and sends audio to that TV’s speakers and the HomePod in that room and sets the volume for the HomePod to 50%.
True. That could be a good workaround. Although I'm still hoping to find a root way to fix this.
 
Comment

Itinj24

macrumors 68000
Nov 8, 2017
1,972
840
New York
True. That could be a good workaround. Although I'm still hoping to find a root way to fix this.
Yeah, I understand. Have you tried restarting (reboot) the Apple TV and Homepods?

I’m just getting started with the entertainment aspect of my Homekit/Home. I’ll play around a little and see if I can find something else. Mine always default to the TV that the Apple TV is connected to.
 
Comment

bcblackmer

macrumors newbie
Original poster
Dec 9, 2019
3
1
Yeah, I understand. Have you tried restarting (reboot) the Apple TV and Homepods?

I’m just getting started with the entertainment aspect of my Homekit/Home. I’ll play around a little and see if I can find something else. Mine always default to the TV that the Apple TV is connected to.
No, but as always, that is an excellent idea!
 
  • Like
Reactions: Itinj24
Comment

Itinj24

macrumors 68000
Nov 8, 2017
1,972
840
New York
No, but as always, that is an excellent idea!
Hopefully that works for you. Another thing I thought of is if you have other users in your Home, it might be a setting someone else played with. On the Apple TV in any screen, press and hold the TV icon looking button and that will show the users. You can select which user in your home is getting their own Apple TV experience. Next check the Airplay screen on the Apple TV in any screen by pressing and holding the Play/pause button. Maybe if you uncheck from there, it will stay put the way you want.
[automerge]1576102509[/automerge]
Ok, I just tested this out. I selected a HomePod in the Apple TV Airplay screen and the audio was going there as well as the TV. I then put the Apple TV to sleep and woke it up and the audio was still going to the HomePod. I then removed the HomePod as a target from the Airplay screen and it defaulted to the Apple TV only, after that. This may fix your issue.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.