Apple TV "Could Not Connect To Library

Discussion in 'OS X Yosemite (10.10)' started by ryan.hayes79, Sep 15, 2014.

  1. ryan.hayes79 macrumors member

    Joined:
    Jun 27, 2008
    #1
    Just updated to 14A361c and both of my Apple TV's no longer connect to my iTunes library. I am running iTunes 12.0.0.117 and was before this build with no problems.

    Anyone else having this issue?
     
  2. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #2
    Do you happen to mean the Home Video library, or are you referring to your complete iTunes library?
     
  3. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #3
    The whole library. Mac running Mavericks and iTunes 11.4 works fine. Yosemite and 12 worked fine before this build.
     
  4. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #4
    Have you tried restarting your computer? That's always a good place to start, especially after an update.
     
  5. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #5
    I had a problem with iTunes build 12.0.0.117 that didn't allow me to see my home video library on my ATV, found a work around for that. I'm assuming you have tried all the normal things such as restarting the ATV, Mavericks, and turned off and then back on Home Sharing. Also it doesn't hurt to reboot the router.
     
  6. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #6
    Yes, I have tried a restart of the iMac, Apple TV, Airport Extreme but it still displays the message:

    Could not connect to "Ryan Hayes's Library"

    It will not let you see any content on it. I have tried to turn off and back on home sharing. I can however use the Apple TV as speakers and the sound plays fine so they are able to connect that way.

    Any other ideas?
     
  7. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #7
    Try this, it sometimes works for me. Turn off Home Sharing on iTunes, restart iTunes, Turn 0n Home Sharing in iTunes.
     
  8. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #8
    I have already tried turning off home sharing, quitting and re-starting iTunes. Anyone else experienced this?
     
  9. zen macrumors 68000

    zen

    Joined:
    Jun 26, 2003
    #9
    iTunes 12 caused no end of trouble with my Apple TV and Home Sharing, so I downgraded back to 11.4. Seems to work at the moment. Running Yosemite PB3 here.
     
  10. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #10
    How did you downgrade?
     
  11. creativet macrumors member

    creativet

    Joined:
    Nov 1, 2012
    Location:
    Toronto
    #11
    Try "Sign out" under itunes store menu to sign out of your itunes account. Then sign back in. Turn off Home sharing and then turn it back on. Also restart your appleTV.

    I had the exact same issue when I installed yosemite Beta 3 and the new itunes Build.
     
  12. zen macrumors 68000

    zen

    Joined:
    Jun 26, 2003
    #12
    It's actually pretty easy.

    Turn off Mac App Store auto-updates so it doesn't undo the downgrade.

    Download the standalone iTunes 11.4 installer from Apple. iTunes 12 beta is just for Yosemite, so the regular iTunes 11.4 is still the current release.

    Move your current iTunes folder out of the Music folder, otherwise anything you do will be automagically undone by the OS (clever, but annoying). I put mine on the desktop.

    Delete iTunes. Not sure you can just trash it - I used AppZapper. You can probably do a sudo-something from Terminal too.

    Install iTunes 11.4 from your downloaded installer.

    The tricky bit is next - go into Time Machine and restore your old, pre-Yosemite iTunes music folder. I have six months of Time Machine back-up available so I looked for the last folder I had before I upgraded from Mavericks to Yosemite, as I knew this was the last iTunes 11.4 folder I would have had.

    Once that library is restored, if you open iTunes 11.4 it'll recognise it and you'll be back to where you were, pre-Yosemite.

    If you leave the new iTunes folder where it is, iTunes 12 beta will reappear, overwriting iTunes 11.4, no matter how many times you try and run the 11.4 installer. It's pretty neat - some kind of self-repairing install - but damn annoying. Took me a few goes to figure out what was going on, but moving the iTunes 12 beta/Yosemite folder out of Music did the trick.

    Now I have Yosemite beta 3 running with iTunes 11.4.
     
  13. iSquirrelu macrumors newbie

    Joined:
    Nov 9, 2012
    Location:
    Brisbane, Australia
    #13
    I have exact same issue and tried all the troubleshooting as advised above running DP8, I get either the Apple TV does a mini restart or error message cannot connect to ******** library.

    I have tried restarting etc etc, nothing works, cannot even get airplay to work via Apple TV. This worked fine with DP7 and all previous builds and with the update to iTunes so this is a DP8 issue for me.
     
  14. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #14
    It was exactly the same for me, same iTunes Beta 12 with DP 7 worked with no issues but stopped as soon as DP8 was installed. So I am thinking the hassle of downgrading to iTunes 11 may not help.

    Can anyone confirm that is does with this specific issue?

    Thanks.
     
  15. sorryiwasdreami macrumors 6502a

    sorryiwasdreami

    Joined:
    Apr 24, 2004
    Location:
    way out in the sticks
    #15
    Same issue here; have tried all the usual steps to resolve the issue but still persists. I have submitted a bug report.
     
  16. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #16
    I have as well. I thought more people would have experienced it.
     
  17. jimmyusmc macrumors member

    Joined:
    Jul 3, 2011
    Location:
    San Diego, CA
    #17
    Same here:confused:
     
  18. K4LK macrumors 6502

    K4LK

    Joined:
    Jun 18, 2009
    #18
    Try turning off home sharing on the Apple TV, then turning it back on.
     
  19. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #19
    Did this issue go away in the GM or with the release of the latest version of iTunes for you as I still have the same problem.
     
  20. sorryiwasdreami macrumors 6502a

    sorryiwasdreami

    Joined:
    Apr 24, 2004
    Location:
    way out in the sticks
    #20
    Issue still persists after GM release and new iTunes 12 release.
     
  21. ryan.hayes79 thread starter macrumors member

    Joined:
    Jun 27, 2008
    #21
    I am now running 14A388a with iTunes 12.0.0.140 and am still having the same problem. Re-installed Yosemite and iTunes but still can't get it to work.
     
  22. freudsigmund macrumors newbie

    Joined:
    Sep 8, 2013
    #22
    solution

    I had the same issue but found the right solution:

    Go to system prefs -> sharing -> and change the computer name

    restart apple tv and one happy camper!
     
  23. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #23
    Fortunately just restarting my AppleTV2 "fixed" it for me #
     
  24. AtlDave macrumors newbie

    Joined:
    Jun 11, 2015
    #24

    freudsigmund! Thank you! Tried your solution and it worked! I was so frustrated with this thing I was ready to toss ATV in the garbage. Finally back in business after changing the computer name.
     

Share This Page