Apple TV Has Gone Haywire

Discussion in 'Apple TV and Home Theater' started by JPM42, Dec 3, 2010.

  1. JPM42 macrumors 6502

    Joined:
    Oct 21, 2007
    #1
    After receiving the new ATV2 for my birthday in October, things had been going pretty well. No problems, everything just worked, as you'd expect from Apple.

    Anyways, last night, my internet connection went out (technical glitch) for a few hours and it was brought back later in the evening. So as I head to bed, I want to stream some music to it, but then things started getting weird. When I turn it on, the TV Shows menu is missing (I'm in the U.S., so it shouldn't be an iTunes license issue), and it couldn't detect my library. I figured it was a wifi issue, so I go into the settings and reenter my password and it can't connect to wifi, even though I'm able to access the internet from my Macbook.

    During this whole experience (and still happening), the remote is almost completely unresponsive. When I push a button, the ATV2 light will blink, but it won't do anything. And when it does respond, I can't get very far before the screen goes blank and then it returns me to the very same menu. In fact, right now, without me even doing anything, the menu is randomly going blank and reappearing.

    I've noticed over the past couple of weeks that the ATV2 has been acting slightly strange at times (occasionally unresponsive remote), but now it's just gone whacko. I've tried resetting the ATV2 multiple times and have reset my internet and wifi router. I'm pretty much at a loss as to what's causing this, much less what else to do.

    Your help is greatly appreciated. Thanks!
     
  2. powerman macrumors regular

    powerman

    Joined:
    Aug 19, 2010
    #2
    This may not be the problem but try to reset your Itunes. In the dock quit Itunes and then restart it. This is what I have to do sometimes when my internet is disconnected. Hope this helps.
     
  3. OldSchoolMacGuy macrumors 68030

    OldSchoolMacGuy

    Joined:
    Jul 10, 2008
    #3
    Sounds like you may want to connect your Apple TV to your Mac and restore it using iTunes. You'll need a micro USB cable. This shouldn't be confused with a mini USB cable. If you don't have one or don't want to order one, you can take it to an Apple Store to have them restore it for you.
     

Share This Page