Apple TV messing up network connections

Discussion in 'Apple TV and Home Theater' started by obey908, Oct 5, 2010.

  1. obey908 macrumors 6502a

    Sep 21, 2008
    San Francisco
    My old apple tv started doing this and now the new one.

    In the middle of streaming a show or movie, it will pause and no longer stream. When I go to use a computer, I can't access the internet, although the connection shows as full.

    I am using an airport express.

    Any help? I never have internet problems, besides when the apple tv is streaming. Computers, 360, ps3, etc always work fine.
  2. DJinTX macrumors 6502

    Sep 15, 2010

    This seems pretty weird, although I do not believe it has anything to do with the AppleTV (new or old). Sounds like your Airport express is having issues and needs to be reset. If you haven't already cycled the power on your Airport and Cable/DSL modem, then you should try that first. Also, if the express isn't your only router, then make sure you cycle power on all routers.

    If the power cycle doesn't improve the situation, then likely the next step is to do a full reset of your airport express. Sometimes the network preference files become corrupt and you need fresh copies. So, basically resetting it to factory conditions and then going through the setup process again.

    I can't really think of any other ideas for you.
  3. OsageCowboy macrumors newbie

    Apr 21, 2010
    Mine does this too. It stops streaming and then I am forced to exit the movie and re-load it in order to resume playback.

    HIGHLY annoying. Yes, I am running wi-fi and have no way to directly connect. I am hoping a future firmware update will improve the ATV's ability to stay on task with the streaming.
  4. MicroApple macrumors regular

    Jul 26, 2010
    WOW same thing happened to me yesterday:

    Netgear Router

    I was watching youtube, it stopped streaming, and my laptop stopped working, but my VOIP that was connected by wire was still working, its like it took out my WiFi. After a powercycle it worked again. Not sure if it is a coincidence or Apple TV is doing this. Also my WiFi bars on my laptop were full too.
  5. tripjammer macrumors 6502a

    Apr 28, 2010

    Dude it is your wifi router which is having an issue not the Apple TV. Update or reset your router. Get a simultaneous dual band router. Put the AppleTV on the 802.11n 5GHZ.
  6. IgnatiusTheKing macrumors 68040


    Nov 17, 2007
    das Fort
    I have the same issue, occasionally, when I stream content from my computer to my older model ATV. I have a Time Capsule, and I have to restart it to get the network connection working again.
  7. arcade99 macrumors member

    Jul 5, 2010
    Same Problem or at least more or less the Same.

    My New ATV has These Problem After Waking up from Sleep. It Shows an ip and Perfect Reception but no connection to iMac or Movies Section. Reconnect to Router and Typing wifi password Solves Problem. But this is definately an issue of ATV. So man user complain about this wifi issue.
  8. obey908 thread starter macrumors 6502a

    Sep 21, 2008
    San Francisco
    Still can't get it to work, crashes the network every time.
  9. wwchris macrumors regular

    Nov 13, 2009
    Atlanta, GA
    It is Apple TV

    I am using the new Apple TV and a brand new cisco router 3000, strongest signal 2.4 and 5ghz simultaneous. I bought it because I was getting network interruptions since I installed the Apple TV. When I try to access my mac library over wifi my other devices lose Internet connectivity. It was not a problem before Apple TV and I have probably 15 devices on my network. It has now happened on both wireless routers I have used. Very strange and troubling for a device designed to work over wifi.
  10. wwchris macrumors regular

    Nov 13, 2009
    Atlanta, GA
    Problem somewhat solved

    So I ended up disconnecting the wifi on Apple Tv and plugging it in via Ethernet to an airport express I happen to have nearby. The problem has stopped, so it is definitely something with the Apple TV wifi.
  11. philipk macrumors 6502

    Jun 11, 2008
    I have two ATV2's. The one I use the most has always been connected via an Ethernet cable and works fine.

    My second ATV2 is in my bedroom set on 5 Ghz WiFi and only used occasionally. After two or three uses my network gets messed up and slows down to a crawl. When I reset everything and don't use the ATV2 in the bedroom everything is fine.

    Today, I hard wired the bedroom ATV2 and my network works without any problem.

    It is the ATV2 wireless causing the problem.

    I have a Dual Band Airport Extreme, two Cisco switches, and a DirecTV Whole House DVR system (network over coax). I added one of the Cisco switches to the DirecTV Deca in the bedroom.
  12. benoitgphoto macrumors 6502

    Jul 19, 2007

    Absolutely right. It's most likely an issue with your router or interference from other devices and/or the load of the 2.4 GHz band in your neighborhood. Want proof of that, download AirRadar and scan the wifi networks in your neighborhood. Check how many networks are set-up on the same channel as yours. As tripjammer said get a simultaneous dual band router and set-up the aTv on the 5Ghz band.

    Think about it, it's the router that pushes the signal to the devices. If the signal gets interfered, the device can't keep it on.
  13. philipk macrumors 6502

    Jun 11, 2008
    Half wrong.

    You are right that the router has the more important job in the process.

    However, you are wrong that the router is a PUSH device. WIFI is two-way communication. Thus any device can upset the apple cart.

    I am sure there are other factors than just the ATV2 in the problem. However, I tried to eliminate as many factors as I control and still had the problem. The ATV2 may not be the main cause but it may be the catalyst.

    Your advice on getting a dual band router may help. However, in my case I have the dual band router and it still had a problem.

    Best advice is hard wire as many fixed devices as you can and leave WIFI for only your portable devices.
  14. laurim macrumors 68000


    Sep 19, 2003
    Minnesota USA
    There are also signal boosters you can buy. When I got cable eleven years ago and tried to split it three ways, I couldn't get a good picture on my tv. I bought a signal booster and now my signal is strong enough for everything. I also have a network extender (Extreme) to keep the wifi strong to feed my ATV and XBox. A network signal is not an infinite source. The more stuff you connect to it and the further away from the source you are, the weaker your signal is going to be. Maybe adding the ATV is the final straw that broke your network's back.
  15. BoulderBum macrumors 6502a

    Feb 3, 2008
    Dual band and signal boosting don't have anything to do with the issue, and I've never heard of a single device connected to a router that manages to bring the whole network down.

    The router simply keeps track of where packets to and from the internet need to go and it sometimes performs prioritization and filtering roles. Devices see it as something to move data through, not something to control.

    Most likely, there's an issue with the router, not the Apple TV (or some other device that's causing interference). The problem may manifest itself when streaming video, but I'd hesitate to blame the issue on the Apple TV itself.
  16. obey908 thread starter macrumors 6502a

    Sep 21, 2008
    San Francisco
    I just turned my imac to internet sharing and run an ethernet cord to the apple tv. No problems streaming any more
  17. benoitgphoto macrumors 6502

    Jul 19, 2007
    Well...PUSHES is not exactly the right term. Sorry about that. Better term would be manages. The rooter manages network and not he opposite. I have never seen any end devices turning down a network. You have a dual band...have you tried the 5 GHZ band ?
  18. cosmichobo macrumors 6502


    May 4, 2006
    I blame the ATV too


    I picked up an original AppleTV in September when the new one was released (steal at AU$129).

    For at least the past 2 months my Airport Extreme (white dome) network has been failing - Airport Utility reports the device is "Ready" without any issues, however none of the devices using it can access the internet.

    Motorola Surfboard cable modem, into Airport Extreme
    -G5 PowerMac connected via ethernet
    Wireless devices:
    -Macbook Pro 13" 2009
    -G3 Powerbook

    Sometimes (maybe 30% of the time) a software reset of the Airport (via Airport Utility) will restore connection. Other times, I have to pull the plug on the Airport. This will guarantee restoration of the network.

    I've tried resetting to default, but no change to problem.

    Just today I've turned off the Pismo's Airport connection, and disabled the Wii's 24/7 internet connection.

    If the problem persists, I'll pull the plug on the AppleTV for a few days and see what happens, but I do believe it's involved in this problem... just HOPING it isn't, cos I doubt Apple's going to give a damn/have a solution.
  19. sloshnmosh, Sep 8, 2014
    Last edited: Sep 8, 2014

    sloshnmosh macrumors newbie

    Sep 8, 2014
    same problem here

    I am new to macintosh but when i try things i go big...I have always used linux and windows. 3 weeks ago i took the plunge and bought a macbook air, an apple airport extreme and an apple tv to see how things are in "mac-land."

    Today the internet came to a stand-still and i could not update my linux machine. i turned on tcpdump and i could see a lot of odd requests coming from the apple tv, it was making requests to itself instead of the router, then it would flush the cache and send a request back to router. the strange thing was at various times there would be a ton of neighbor requests in ipv6!
    (no bueno!)
    I verified that the odd requests came from the ATV using dsploit from my android phone because the wifi was so slow. dsploit verified the ip address as the ATV as well the manufacturer and what open ports it was listening on.

    I will run some tests on it with netcat and wireshark and see what gives with that little black box. p.s. I had a similar problem with a Roku tv/hdmi device. (there is no such thing as free.:mad:)
  20. sloshnmosh macrumors newbie

    Sep 8, 2014
    I beg to differ..I had first-hand viewed with a witness my roommates linux laptop shut down the entire network and it took 6 hours to get it back up and running. I was teaching him how to use audacity music editor on his linux machine and when i hit rewind the whole laptop froze up and the network manager dissapeared from the task bar. then we noticed none of the devices in the house had network. theres a off chance that it was a coicidence that my roommates complete software failure happened at the exact moment of network loss but just about any device can cause a denial of service.

Share This Page