Apple TV NEVER works!

.Logan

macrumors regular
Original poster
Aug 7, 2010
105
23
Houston, Texas
Not sure how else to describe it, but Apple TV plays fine for a couple songs, and then cuts out or the song stops altogether. Especially when streaming from iTunes on my MBP, it's no longer in play mode and the button will appear orange until I press play again. Streaming from iPhone has same result.

Have tried everything, resetting the device, network settings, updating it... etc.

I've owned a couple of them, and lived in a few different apartments with different network setups, and the same result.

I really, really want it to work. Any brilliant fixes I'm not thinking of? I'm sure others experience this too.
 

paulrbeers

macrumors 68040
Dec 17, 2009
3,960
120
Not sure how else to describe it, but Apple TV plays fine for a couple songs, and then cuts out or the song stops altogether. Especially when streaming from iTunes on my MBP, it's no longer in play mode and the button will appear orange until I press play again. Streaming from iPhone has same result.

Have tried everything, resetting the device, network settings, updating it... etc.

I've owned a couple of them, and lived in a few different apartments with different network setups, and the same result.

I really, really want it to work. Any brilliant fixes I'm not thinking of? I'm sure others experience this too.
Interference from other wifi networks and/or a poor router that can't maintain a solid connection. My guess is that it has nothing to do with the AppleTV at all
 

jdag

macrumors 6502a
Jun 15, 2012
827
212
Have you tried connecting an ethernet cable? Not that I am suggesting you need to go with a wired setup permanently, but at least try it to troubleshoot.
 

Mildredop

macrumors 68020
Oct 14, 2013
2,410
1,458
Not sure how else to describe it, but Apple TV plays fine for a couple songs, and then cuts out or the song stops altogether. Especially when streaming from iTunes on my MBP, it's no longer in play mode and the button will appear orange until I press play again. Streaming from iPhone has same result.

Have tried everything, resetting the device, network settings, updating it... etc.

I've owned a couple of them, and lived in a few different apartments with different network setups, and the same result.

I really, really want it to work. Any brilliant fixes I'm not thinking of? I'm sure others experience this too.
I had no end of problems with Apple TV. It got so frustrating I just gave up. I now have Sonos (amazing) and WDTV for my films and Netflix for all the rubbish.
 

brentsg

macrumors 68040
Oct 15, 2008
3,406
766
I have Apple TV's all over the house, on every TV. My family uses them daily, take them on vacation, etc.. Never had a single issue..

The reports of people pulling their hair out with them really baffles me.
 

gpspad

macrumors 6502a
Feb 4, 2014
587
19
I have a 2013 macbook pro retina, shutting bluetooth off stops the interference. Problem is I got a macbook for handoff and continuity.

Hoping a future upgrade solves this.
 

ixxx69

macrumors 65816
Jul 31, 2009
1,119
635
United States
I have a 2013 macbook pro retina, shutting bluetooth off stops the interference. Problem is I got a macbook for handoff and continuity.

Hoping a future upgrade solves this.
That article is over a year old. If they haven't fixed it by now, they're not likely to. The article only mentions a/b/g networks. Are you using an n or ac wireless network?

I also recall there's a problem with certain AppleTV gen 3's having a wireless issue? MacRumors article link.