Apple TV not Connecting to iTunes Library

Discussion in 'OS X Yosemite (10.10)' started by jasonwaterfalls, Jul 9, 2014.

  1. jasonwaterfalls, Jul 9, 2014
    Last edited: Jul 9, 2014

    jasonwaterfalls macrumors newbie

    Joined:
    Jul 9, 2014
    #1
    I have a 3rd gen TV, I'm using home sharing but getting issue "Could not connect to "JasonWaterfalls Library"

    I vaguely remember before installing DP3 that someone mentioned signing in and out of home sharing. I've done that on both the MBP and the TV to no Avail.

    Any pointers?

    Edit: Worth noting that if I play from iTunes to the AppleTV it works, I just don't have browsing function via Apple TV of my Library.
     
  2. satinsilverem2 macrumors 6502a

    satinsilverem2

    Joined:
    Nov 12, 2013
    Location:
    Richmond, VA
    #2
    I am also having this issue with DP3. I need my iTunes Sharing back!!!!
     
  3. BenGieCruz macrumors member

    BenGieCruz

    Joined:
    Nov 8, 2012
    Location:
    Oklahoma
    #3
    Restarting itunes and the apple tv usually fixes this for me...
     
  4. ajiuo macrumors 65816

    Joined:
    Apr 9, 2011
    #4
    Has anyone found a way to fix home sharing in dp3 yet? Worked fin in DP2.

    even after an iTunes and apple tv update.. it still doesn't work. It must be something with DP3
     
  5. biebel228 macrumors newbie

    Joined:
    Jul 5, 2013
    #5
    Plenty of restarts, etc. here. No luck getting home sharing to work.
     
  6. sfwalter macrumors 68000

    sfwalter

    Joined:
    Jan 6, 2004
    Location:
    Dallas Texas
    #6
    Hopefully someone will submit a bug to Apple on this.
     
  7. Picho macrumors member

    Joined:
    Jan 26, 2010
    #7
    Happened to me too. Solved it by restarting my router and assigning a new IP address to my Mac. That took care of the problem for a day, but when the lease expired, had to do it all over again.

    I think it has to deal with the fact that the AppleTV can't establish a direct connection to your Mac with iTunes. Changing the IP address makes the AppleTV see your Mac again
     
  8. kultschar macrumors 6502a

    Joined:
    Mar 26, 2010
    #8
    Also have this problem with my Apple TVs and DP3. DP2 worked great but something in DP3 broke it.

    I can still enable Airplay and send the movies etc to my ATVs from iTunes on my Mac as a short term solution. Strangely the movie artwork *sometimes* appears in ATV home screen but it never works.
     
  9. bsearle74 macrumors newbie

    Joined:
    Jul 14, 2014
    #9
    Me too

    I am also not apple to connect to my itunes music with the apple remote app to stream music to my airport. No Apple TV connection either after Yosemite update 3. I used these features everyday now I am waiting for a fix. Tried everything. Nothing works.
     
  10. bushido Suspended

    bushido

    Joined:
    Mar 26, 2008
    Location:
    Germany
  11. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
  12. carmic macrumors newbie

    Joined:
    Jul 15, 2014
    Location:
    Vancouver, BC Canada
    #12
    Had same problem with DP3. I have a nMP connected directly to my router and found my Apple TV and my MacBook Air (Mavericks) would not network with my nMP (Yosemite). That was, until I connected my nMP to the router via Wi-Fi. It makes no sense, but all is working fine so long as Wi-Fi is connected.
     
  13. bsearle74 macrumors newbie

    Joined:
    Jul 14, 2014
    #13
    I added a MacBook Pro to my network and accessed my itunes library now my remote works like before. Weird. Not sure why now it's working but thankful.
     
  14. RWinOR macrumors 6502

    Joined:
    Sep 11, 2010
    Location:
    Greenest and wettest place in North America
    #14
    I am having issue too.

    I had an airport Extreme, I started to have issues, so I upgraded my router to an ASUS. Reset ATV to factory and reinitialized. I turned on home sharing, see my libraries until I go to connect, it does not respond to my iPhone anymore either.
    Using remote I can stream from Apple, but I have a ton of movies on my server that I would like to have access to.

    Hardware is
    ASUS RT-AC87R Dual Band Router
    2 different Apple TV 3rd gen (both have issues)
    MacBook Pro running Mavericks.
    Iphone 5S

    Anyone know how to fix this yet?

    Thank you in advance.
     

Share This Page