Apple TV not connecting to network -07 error

Discussion in 'Apple TV and Home Theater' started by KrisKT, Aug 12, 2009.

  1. KrisKT macrumors newbie

    Aug 12, 2009
    Does anyone know what the -07 error is? The Apple TV sees my network, but won't accept the WPA2 password.

    It has worked great for over 2 years. But in the last week, I upgraded all software for my iMac and Apple TV. Only then did the Apple TV no longer appear in my iTunes devices. So I tried to unlink the iTunes to the Apple TV and then I was going to relink. But now I can't even do that because it won't accept the password. So now I wish I hadn't unlinked it, because before I did that, it at least had the content on it even though it wouldn't sync.

    Now it is a worthless dust collector. I know many others have similar issues. But, I haven't seen this exact problem. Any ideas on what I should do now, other than wait for another Apple update.

    BTW, all of my other devices (computers, wireless printers, iPhones, etc. connect to the network fine with no issues).

  2. musicman0725 macrumors member

    Oct 25, 2007
    I would still suggest power cycling your router even though other devices are able to connect. There may be something going on in the router not letting the Apple TV connect that a simple reset could fix. If that doesn't work, try disabling wireless protection in your router and see if that helps you get on the network.

    If you still can't get it connecting wirelessly, I'd suggest trying to test the ethernet port. If it does work, you could try getting a cheap wireless access point so that you can connect the Apple TV via it's ethernet port (and other internet enabled devices in your living room if you have any).

    Another thing to try is holding Menu + - on the remote. This will reset the apple tv into diagnostic mode where you can perform a restore. This will take you back to whatever software version your apple tv shipped with (be careful as if the issue wasn't the apple tv update but was hardware related, you could be stuck on software 1.0).
  3. KrisKT thread starter macrumors newbie

    Aug 12, 2009

    Well, it is syncing now...

    The only thing I did was load the iMac with the new security update.

    Oh well, at least it is working at the moment!

Share This Page