Apple TV not recognizing my Apple ID and password

Discussion in 'Apple TV and Home Theater' started by Ovenall, May 11, 2011.

  1. Ovenall macrumors member

    Joined:
    Sep 2, 2010
    Location:
    Chicago
    #1
    I can use it just fine to stream Netflix, which is what I primarily use it for. But last weekend I tried buying a movie through the Apple TV option. It asked me to verify my password, which I did. It said it was incorrect. I tried several times, very carefully. Same result. I tried powering the unit down and restarting. Same result.

    Finally I logged into my account on my MacBook Pro -- the same account I have had and have used successfully for years, with the same password. I went in and changed my password. Back on Apple TV, it is still giving me the "incorrect password" message even when I put in the new one. Note that I had to go in and change my password on my laptop and iPhone to get my mail, so I did change it correctly.

    Anyone have any idea what I can do to fix this? Thanks.
     
  2. GrantMeThePower macrumors regular

    Joined:
    Apr 12, 2011
    #2
    I know this may be a dumb answer, but its happened to my mom and dad a few times...

    Is the Apple ID correct? If you use an email address for your apple ID you need the "@aol.com" at the end also. No matter how right the password is, if there is a typo on the Apple ID it won't work.
     
  3. Ovenall thread starter macrumors member

    Joined:
    Sep 2, 2010
    Location:
    Chicago
    #3
    I'm pretty sure I double checked that. Wouldn't it have needed the ID and password at setup anyway?

    I'll check again when I get home.
     
  4. UneElle macrumors member

    Joined:
    Jun 14, 2010
    #4
    I've posted this elsewhere in this forum. Suffice it to say that I tried almost everything to get Apple ID to recognize my ID/password without success. Here's a cut and paste summary of how I finally resolved the problem.

    "I don't know if this will help you or not, but I had the same problem when I first purchased my ATV2. Somewhere on this forum is the thread I started detailing my efforts to solve the problem. In brief, and following the advice of Apple Support as well as the Genius Bar, I: Purchased a new router / Opened the Ports Apple uses / Opened ALL ports entirely / Disabled firewalls / Reset router and reset ATV2 numerous times / Established a NEW Apple ID / Changed from wireless to wired connection / Rerouted ports, etc. There were other "fixes", all of which failed.

    What FINALLY resolved the problem for me was working closely with my ISP. Fortunately, they are very customer service oriented and sent out technicians 3 times to determine why I couldn't connect. Once they brought out a *business* cable modem, which uses different software and doesn't block ports on their end, it became apparent that the problem was on THEIR end. The ISP was blocking access to one of the ports that Apple uses (sorry, I've forgotten which one, but I think it was 123). They made a software modification to the cable modem and opened the port(s) Apple uses, and VOILA(!) I could log in immediately.

    Perhaps you might try contacting your ISP to see if they might be blocking one (or more) of the ports on their end.

    Good luck!
    __________
     
  5. Technohead macrumors newbie

    Joined:
    Jan 12, 2011
    #5
    I have the exact same problem. All of the sudden Apple TV2 won't recognize my address or ID. I'm also suddenly having the same problem on my Ipad and Itouch-even when using it outside of the house on different Wifi systems. Suddenly I cannot purchase any apps from any of these devices (when just a day or so ago I could). I've changed nothing on any of my devices nor do I have a new router or wifi (i have an Apple airport express). My Apple TV is up to date as are my other devices (including my IMAC). Something just "clicked" and disabled my devices from being able to successfully log into the Apple stores/apps. When trying to purchase an app or Itune, I get prompted to enter my security code from my visa card (which I do) then to click "done". After I do this, it kicks me out of the app store. WHen i relaunch it, I have to do the same thing over and over without success.

    HELP!!
     
  6. Technohead, May 16, 2011
    Last edited: May 16, 2011

    Technohead macrumors newbie

    Joined:
    Jan 12, 2011
    #6
    Got the fix: Apparently ITunes rec'd an update that made it mandatory that your billing address contain the street, avenue, lane, etc. after your address, i.e. my billing address simply read "Elm" I had to enter Elm St (note do NOT use a period after St) I also had to enter the 4 digit postal service zip code after my 7 digit zip, i.e. 48170-1234 (USE the dash). Once I did these 2 things, I was back in business. Wish apple would notify people of these things when they come up rather than have us waste time trying to troubleshoot oursevles, waste time on hold forever on the apple help line. This would avoid a lot of anger and frustration for something that would be so simple for us to fix if we only knew what to do!
     
  7. Merk macrumors newbie

    Merk

    Joined:
    Dec 5, 2016
    #7
    --- Post Merged, Dec 5, 2016 ---
    Make sure Rd, St, etc... are correct and not RD, ST, or rd, st,. This caused an issue with my account. Had them in all caps and wouldn't accept or verify account until I read above post and figured out they wanted the correct format on address abbreviations! Changed them on both address locations and all is good now... Feel like I'm back in school!!! SMH!
     

Share This Page