Apple TV not showing in iTunes 7.6.1

Discussion in 'Apple TV and Home Theater' started by jonthegeologist, Mar 3, 2008.

  1. jonthegeologist macrumors member

    Joined:
    Feb 8, 2008
    #1
    Hi all,

    I know that this subject has been posted before and countless suggestions for fixes and fudges have also been suggested. I raise this once again as I think there might be a serious error with the latest iTunes update (7.6.1).

    In essence, the error is that Apple TV does not show in the devices list. You've heard that error before I know. Fixes suggested elsewhere and tried without luck include:

    1. Ensuring network visibility for both devices
    2. Turning off/on (my helpdesk colleagues call this one power cycling, works temporarily for some)
    3. Reinstalling 7.6.1 - I shouldn't have to, but it didn't work anyway
    4. Ensuring all devices are on the same network
    5. Ensuring only 'n' network devices are present
    6. Checking "Search for Apple TV" in iTunes preferences
    7. Pinging the Apple TV
    8. Resetting the network on the Apple TV
    9. Reconfiguring the iTunes library on the Apple TV
    10. Restore factory defaults on Apple TV and reinstalling 2.0
    11. Rewind to iTunes 7.6/7.5 - works temporarily.
    12. Connecting via ethernet (this works, but I don't wish my laptop to be connected in this way)
    13. Change Firewall settings (System Pref, Security Panel, Firewall tab) to allow incoming for iTunes - works only with ethernet

    I've drawn a blank with all of these.

    I'm writing this thread so that others can try all of the above. Other people swear these will solve the problem (in fact, so does Apple on their website), but they haven't for me.

    I'm drawing to a sad conclusion. Either my Apple TV has a problem or iTunes 7.6.1 is the rogue element. Given that all of these issues appeared post my updating iTunes, I think 7.6.1 is the issue.

    Anyone else care to add to my list of solutions? Anyone else as frustrated as I am with this situation? What pressure (if any) can be applied to Apple to solve this?

    J
     
  2. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #2
    Have you tried to go back to 7.6 and see if it works?

    Have you tried to connect the apple tv with a network cable instead of going wireless?
     
  3. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #3
    I have become convinced that these problems are a combination of both Take 2 and 7.6.1.

    There is an unhealthy interaction that causes these as well as other problems.

    Let's face it. I didn't any problems with v 1.1 -- the problems started with Take 2, its incompatibilities with 7.6, and now the fixes in 7.6.1 have created more problems.
     
  4. jonthegeologist thread starter macrumors member

    Joined:
    Feb 8, 2008
    #4
    Good suggestions (I've edited and added to the list)

    Rewinding to iTunes 7.6 does work as does connecting via ethernet. Neither, of course, are desireable and both suggest an error in 7.6.1.
     
  5. swhit macrumors newbie

    Joined:
    Mar 3, 2008
    #5
    Rewind to 7.6 a temporary fix.

    I reverted iTunes back to version 7.6.0 last Thursday (Feb 28). This fixed everything for me for a couple of days. It stopped playing nice yesterday (Sunday, Mar 2). Now the apple tv is not seen by iTunes, even though the apple tv is on the network since it can download youtube videos. Not sure what to do next, other than just wait for an update to iTunes/Take 2.

    FYI, everything worked perfectly for me with apple tv version 1.1 software and iTunes 7.5. Both the iMac (which is the library source) and the apple tv are on a wireless n network (dlink, not apple extreme base station).

    I called apple care, they blamed my problems on network interference (which is bull since changing channels on the wireless router fixes nothing, yet reverting back to apple tv version 1.1 and iTunes version 7.5 fixes everything (except no rentals and no split sync/stream libraries)).
     
  6. jonthegeologist thread starter macrumors member

    Joined:
    Feb 8, 2008
    #6
    I'll keep this post up to date so that we have a comprehensive list of suggestions for fixes, but like other correspondents, I'm quickly coming to the conclusion that there is an error with 7.6.1 (or in combination with ATV 2.0).

    If you have other suggestions that I can try then please, jot them down here and I'll update the list.

    Now, if there is an error in 7.6.1 or in combination with 2.0, how does Apple get to hear about it and act to change? Does Steve read macrumors? :)
     
  7. Dingo Dave 69 macrumors regular

    Joined:
    Oct 23, 2007
    #7
    I have had this problem too but it made no difference if my :apple:tv was connected by ethernet or wireless, either way it did not show up under my devices.

    I fixed it by unplugging the :apple:tv and plugging it back in but I have heard from others this is a temp fix. It seems more to do with the latest itunes update.

    If you go to the official apple help forums you will see quite a lot of people are having this problem, I also posted a thread about it here. :(
     
  8. SamMiller0 macrumors member

    SamMiller0

    Joined:
    Aug 17, 2004
    Location:
    San Jose, CA
    #8
    what wireless router are you using? I've had no problems seeing my Apple TV in iTunes, using both a D-Link 802.11g router and more recently a 802.11n Time Capsule. In both cases my Mac Mini was connected with ethernet.
     
  9. jonthegeologist thread starter macrumors member

    Joined:
    Feb 8, 2008
    #9
    Hi

    I'm using Apple Extreme base station - so, Apple's own hardware. In truth though, it really shouldn't matter what router I use. It was, after all, working just fine not that long ago...
     
  10. TommyD macrumors member

    Joined:
    Jan 7, 2008
    Location:
    Stirlingshire, Scotland.
    #10
    I have my :apple:tv connected via ethernet cable and get this issue too.

    At first, turning internet sharing (sharing my ethernet connection)off, then back on again seemed to cure it, or at least cause :apple:tv to showup in itunes. Now that doesn't seem to work very well either.

    The last time it wouldn't appear in itunes, i had to pull the plug on the :apple:tv, then when i restarted it, it was fine.
     
  11. PTGoldmember macrumors newbie

    Joined:
    Mar 3, 2008
    #11
    Yes I also found this to be a BIG problem, I found the problem seems to relating to the Wireless Network card. Sitting 2 feet from an 802.11N router it didn't show up, It grabbed up the 802.11b routers first both of my 802.11G and 802.11n routers did not show up. The second issue I ran into was trying to use DHCP instead I setup a static IP within my networks range.

    Here is what I did so far in my test environment in the past few days
    Solution 1
    PC XP Home Edition in a work group added an entry in the HOST file located C:\Windows\System32\Drivers\etc\hosts for AppleTV with the static IP

    Solution 2.
    Active Directory 2003 Server Environment added an entry for AppleTv with the IP on the DNS server.

    Both of these solutions seemed to help, also try turning off any firewall software it is probably blocking the ports that AppleTV uses. I also discovered that Norton Antivirus software detects iTunes 7.61 as a threat and blocks it. Nod32 also blocks ports and you may need to allow ports to be opened up from the appleTV's IP

    Hope this helps
     
  12. jbellanca macrumors 6502

    Joined:
    Jul 2, 2007
    #12
  13. swhit macrumors newbie

    Joined:
    Mar 3, 2008
    #13
    Wii interference?

    After the downgrade to iTunes 7.6.0 didn't help, although the downgrade did work for 3 days, I upgraded back to iTunes 7.6.1. Then, just to try, I turned off the wireless connection of my Wii (which sits next to the apple tv). Strangely enough, the apple tv has been working perfectly since Monday (Mar 3). Maybe there was wireless interference caused by the Wii?

    I was actually debating with myself in regards to whether I should post this bit of info or not. I don't want to jinx my apple tv now that it's working! It seems to have a bit of personal karma mixed in (i.e., works for some, doesn't for others).

     
  14. gauchers macrumors newbie

    Joined:
    Jul 17, 2007
    #14
    same problem - my solution

    Followed jbellanca's post - deleted itunes app and mobiledevice files, reinstalled itunes 7.6.1, and re-synced apple tv - so far so good.
     
  15. PTGoldmember macrumors newbie

    Joined:
    Mar 3, 2008
    #15
    I run into a number of issues on XP, Firstly Norton treats the iTunes761.msi as a virus. I got around this turning off Norton, My other Laptop has ESET/Nod32 the firewall must be turned off in order to see the AppleTV.
    I have mixed luck after I had coded the IP address to static with a Static DNS on my router and one in my DNS Server, This still didn't always work on my Laptop so I hard coded the AppleTV's IP into a Hosts file on the Laptop.
    I never uninstalled the iTunes 7.61. I am issues with the sync screwing up now but at least I can see the AppleTV. I got mad at this whole AppleTV thing and bought myself a Mediagate, it has a 1TB drive, 802.11n and will allow composite as well HDMI connections. The part that I like best your not limited to iTunes. Apple needs to add functionality to iTunes for me. I stuck with my AppleTV and learning to live with it. Its too bad I like the looks of it and the idea too bad Apple dropped the ball with the software
     
  16. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #16
    What version ATV software are you running? V1.0 & V1.1 are "rock solid" in comparison. If you don't need the rentals, you might consider doing a factory restore.
     

Share This Page