Apple TV not updating?

Discussion in 'Apple TV and Home Theater' started by dh1210, Jun 25, 2011.

  1. dh1210 macrumors newbie

    Jun 22, 2011
    My new apple tv keeps telling me i have an update so i go to update it and when i do it tells me the update is unsuccessful. Does anyone know why that is? Is anyone else having this problem? Is there anything i can do to fix this?
  2. Payton3485 macrumors member

    May 1, 2010
    I have the same issue. I have two ATV2s and the one I just bought yesterday will not update from version 4.2(2060) to 4.2.2 The good thing is the version on it now does have all the latest features including AirPlay. Apparently there is an issue with Apple's server. There are a few other posts on the board about it. Hopefully, the server will be corrected soon!!!
  3. Ratatapa macrumors 6502a

    Apr 3, 2011
    As for now to update it, find the .Ipsw on the net and install it threw iTunes

    Sent from my iPad2 using Tapatalk
  4. skullnbones macrumors newbie

    Jul 11, 2010
    Please excuse my naïveté, but I only bought my first ATV the other week. I am having the same issues updating from the ATV connected to the television. May I therefor ask where to find the latest .ipsw on the net and how do I update it through iTunes? Can I not connect a USB and press an update button in iTunes, or is it more complicated than that?

    Tanks in advance for any more basic instructions than the above.
  5. Irishman macrumors 68030

    Nov 2, 2006
    It's actually much easier than that.

    Turn on your Apple TV2, go to the "settings" menu, then down to "general", then click on "update software".

    Let us know if that doesn't work, and specifically what error message you receive.
  6. MattG macrumors 68040


    May 27, 2003
    Asheville, NC
    I tried it like this yesterday and it wouldn't work. Just kept getting a message about the file download being corrupted. I ended up finding the IPSW on a web site, putting it in the "Apple TV Software Updates" folder and then it did its thing correctly.
  7. Irishman macrumors 68030

    Nov 2, 2006
    Glad it worked out.
  8. gj02 macrumors newbie

    Jun 22, 2011
    Update is working now
    I'm now seeing a step 1 of 2 update
    Something I've not seen before

    Yeah update via the box has worked
  9. Payton3485 macrumors member

    May 1, 2010
    I was able to run the update install this morning without any issues. It looks like Apple has fixed the issue :D

Share This Page