Apple TV - Plugin folder "Permission Denied"

Discussion in 'Apple TV and Home Theater' started by goroboto, Oct 5, 2008.

  1. goroboto macrumors newbie

    Joined:
    Dec 11, 2007
    #1
    I'm trying to copy some files over and I keep getting "Permission Denied" errors - anyone have any advice?
     
  2. staka69 macrumors member

    Joined:
    May 21, 2005
    #2
    Fugu

    If trying to copy files from your mac to your atv, try using fugu but you must copy them to your frontrow directory first.

    Once that is done, ssh into your atv and copy the files/directory to the plugin folder.
     
  3. brembo76 macrumors newbie

    Joined:
    Oct 8, 2008
    #3
    You should also try and chmod the files to set the correct permission on the folder / files.
     
  4. brembo76 macrumors newbie

    Joined:
    Oct 8, 2008
    #5
    OK so I've already ssh enabled my appletv.

    Here is what I had to do to copy XBMC and Boxee plugins.

    Enable ReadWrite on Disk
    http://wiki.awkwardtv.org/wiki/Mount_ReadWrite
    sudo mount -uw /

    Copy the plugins into the /Users/frontrow folder

    then use
    sudo mv BoxeeLauncher.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    sudo mv XBMCLauncher.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    then
    cd /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    ls -al to check permissions

    sudo chown -R root:wheel XBMCLauncher.frappliance/
    sudo chown -R root:wheel BoxeeLauncher.frappliance/
     
  5. Cave Man macrumors 604

    Cave Man

    #6
    Where do you get XBMCLauncher.frappliance? Do you also need to install XBMC Atlantis beta 2?
     
  6. brembo76 macrumors newbie

    Joined:
    Oct 8, 2008
    #7
  7. Cave Man macrumors 604

    Cave Man

    #8
    Yeah, I got it sorted out. I pulled the frappliances from atvusb-creator and put them into the ATV finder in OSBoot of an eSATA drive I have for testing purposes and both showed up on the menu. Then I had to install XMBC Atlantis beta 2 and Boxee on my Mac, then copy those two apps over to the Applications folder. Works just fine with DVD rips, but as expected 1080p is way too much for the ATV to handle. If anyone is hoping for a Blu-Ray option for the current Apple TV it ain't gonna happen. The ATV just doesn't have the muscle for it.

    The two movies I tried were copied over to the ATV's Media partition for playback. I wasn't able to figure out how to do networking to other volumes on my computers, so any tips there would be great. I tried the browsing like what can be done with Plex, but none of the volumes showed up on XBMC on the ATV. Obviously I'm not setting the network sharing properly - I just can't figure it out.
     

Share This Page