Apple TV problem with not responding

Discussion in 'Apple TV and Home Theater' started by jbellanca, Feb 26, 2008.

  1. jbellanca macrumors 6502

    Joined:
    Jul 2, 2007
    #1
    OK, so I have three Apple TV's, got them about a month ago. They've been working great. Tonight, all of a sudden, the all exhibit the same odd behavior. I turn on my iMac, load iTunes, and they all 3 show up. Then within 1 minute, they all disappear. If I try to sync one of them before they disappear, I get the message: "The Apple TV <name> is not responding. Check that any firewall software running on this computer has been set to allow communication on port 3689." None of my setting have changed at all, I checked my firewall in Leopard and it's set to allow incoming connections (even tried resetting those settings). I've tried rebooting both the iMac, all the Apple TVs, and the Airport Extreme Base Station multiple times, and nothing works. If I try to play a movie on one of them before they disconnect from iTunes, it will play for about 60 seconds before it disconnects from iTunes. I can play YouTube on it after it disconnects from iTunes so I know it's still connected to the network. One is hardwired to the AEBS, two are wireless. I'm running iTunes 7.6.1. I also tried reverting one of them back to 1.1 and the same thing happens. Also tried repairing permissions on my iMac, but still get the problem.

    EDIT: OK, I figured out that the problem is my iMac. All the Apple TV's sync and stream just perfectly with my MacBook iTunes library (iTunes 7.6 - NOT 7.6.1). So, something in my iMac changed by itself in the last 24 hours, or there's a problem with 7.6.1. Also tried reinstalling iTunes 7.6.1. I tried repairing permissions and tried setting up a new iTunes library. Tried copying iTunes 7.6 from the MacBook to the iMac. FrontRow works on the MacBook reading the iMac library.

    Nothing has worked...

    Anyone have ANY idea what's causing this or how to fix it??? Is there any way to revert back to 7.6? I'll call Apple tomorrow to see what they say.
     
  2. omni macrumors 6502

    Joined:
    Jan 20, 2008
    #2
    I have no answer for you but just some (hopefully) helpful debugging advice:

    Turn off 2 of them so you are only dealing with 1 at a time.

    From there try running it both wireless and wired and see if you get different results?

    Try to eliminate as many variables as possible and just work on one problem at a time.

    Good luck and post if you get it working
     
  3. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #3
    Tried this, doesn't help.

    No difference, same results.

    Thanks, but I've eliminated every variable I can think of... hoping someone here has some more ideas.
     
  4. gavd macrumors 6502a

    Joined:
    Jan 30, 2006
    #4
    From looking around on the Web, it seems like a problem a few people are having, but there doesn't seem to be a definitive fix. From reading your post, you've tried what seemed to work for most people in rebooting and repairing permissions and that's not worked.

    The only other thing I did see was that someone had more than one account on their Mac logged into iTunes so they logged out of all other accounts and back into theirs and all was OK.

    Clutching at straws, but I thought I'd mention it just in case.
     
  5. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #5
    Thanks, I saw that one too. I only have one account, so I know that's not it. I also just tried disabling and re-enabling sharing in iTunes, even though FrontRow connects from the MacBook to the iMac just fine, just the AppleTV's won't. This is so weird and frustrating!!! I'm just about to wipe my HD clean and re-install Leopard from a blank disk, I just don't know what else to do!
     
  6. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #6
    I had trouble early on getting a good sync with my :apple:TV, after initial success. Turned out the problem was wireless interference. A neighbor had installed FiOS and it was somping on my wireless. I solved it by extending my network with the Airport Express to have a sturdier signal at the :apple:TV.

    There was also a time around that time when I lost contact with many of my devices and it tuned out I somehow managed to get on a neighbor's open wireless, instead of my own. So the 'net was working but none of MY devices were available. I couldn't see mt iTunes library, etc...

    Make sure the underlying network is sound.

    B
     
  7. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #7
    So when I went to bed last night, I had all those issues, spent hours trying to get it to no disconnect from iTunes after 60 seconds. I went to my iMac this morning, and... everything is working perfectly. All 3 AppleTV's are streaming and syncing, just as if nothing was wrong at all last night.

    I just don't get it. Did I have a ghost over here? Were there solar flares? Was I giving off some weird radiation after my airplane flight? :) Just weird, but I'll just pretend it didn't happen I guess.

    Thanks everyone for the tips, maybe this will all help someone else some day.
     
  8. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #8
    Well, it all worked reliably for about 3 days. Then the wireless ones started dropping off intermittantly, but the wired one was OK. Now, the wired on keep dropping off, too. I'm so frustrated at this... I wonder if there's a problem with my AEBS?
     
  9. Edandlindz28 macrumors regular

    Joined:
    Apr 26, 2007
    Location:
    Colorado
    #9
    Same Issue

    I have had the same problem with my Macbook. I could not figure it out. I am on vacation and hoping it just works when I get home. Hopefully someone smarter than me can figure it out.
     
  10. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #10
    I THINK I have this figured out now... I hesitate to say any of this because of Murphy's Law -- as soon as I tell you all here, it will magically break again... but for all you having problems with AppleTV frequently disconnecting from the device list in iTunes, try this.

    1. Delete iTunes. (Not your iTunes library, just your iTunes app in your Applications folder.)

    2. Remove both Apple Mobile Device services. You can find directions on how to do this on Apple's support site. The link is:

    http://docs.info.apple.com/article.html?artnum=306637

    3. Reinstall iTunes. I actually reinstalled iTunes 7.5 and upgraded to 7.6.1. You can try just installing 7.6.1.

    Since I did this, they haven't disconnected even once... I'm keeping my fingers crossed. I'd like to hear if it works for anyone else...
     
  11. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #11
    Well they worked for a solid 3 days perfectly. Now they've fallen off the iTunes device list again and won't come back. So I guess it only partially worked. iTunes is definitely buggy - there seems to be a whole lot of people with this issue.

    EDIT: I also did a factory restore on my AEBS, and that seems to have fixed the issue... for now. If you're having these problems, I'd recommend two things: (1) do the delete/reinstall steps in my previous response with applemobiledevice, and (2) do a factory restore on your AEBS.
     
  12. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #12
    I feel oddly compelled to commiserate with you.

    I wish I had something constructive to contribute.

    All I can think is to recommend you restore to Take 1, which was solid and reliable.
     
  13. WolfsMac macrumors newbie

    Joined:
    Jul 15, 2008
    #13
    Port 3689

    I am also having this issue and haven't been able to find a solution anywhere online. :mad:

    For what it is worth it didn't start happening to me until I added my husbands iTunes library to the Apple TV.

    If anyone has found a solution please post!
     
  14. macaco74 macrumors regular

    Joined:
    Jan 11, 2008
    #14
    everytime I reboot my imac, the apple tv does not show up on my device list. This has been happening for a couple of months now.

    I will put it up on ebay soon. I have had enough of the POS.
     
  15. jbellanca thread starter macrumors 6502

    Joined:
    Jul 2, 2007
    #15
    Somehow my 3 AppleTV's worked reliably for quite a few months. But now, it's happening again. All of a sudden, today, all 3 have dropped off and won't come back. One wireless one and one wired one connected long enough to sync, but then dropped off. The other wired one won't show up at all unless you go through the whole reconnect process, but then it oddly stays in the Device list but you get the "cannot connect" "port 3639" error.

    Now, I love Apple products in general, but the iTunes/AppleTV connectivity issues are MAJOR and I just don't understand why Apple won't FIX THEM. Very frustrating.
     
  16. Macaday macrumors newbie

    Joined:
    Sep 13, 2007
    #16
    I'm having similar frustrating problems with Apple TV...

    I'm having problems syncing or streaming to Apple TV from my new iMac. Once the setup number has been entered into iTunes to start streaming, nothing happens. Every time you press sync, the button goes gray for a second and then goes back to normal.

    I have just tried syncing the Apple TV to my MacBook Pro to see if the problem was with my Airport Extreme but that worked fine.

    Both Macs have the same firewall settings: 'Allow All Incoming Connections', but one works, one doesn't.

    Does anybody know how to fix this? Is there a setting on the iMac that I have overlooked that might be the cause of this?

    It is strange how Apple TV shows up fine in iTunes but it cannot sync!

    I have tried the usual things like restoring Apple TV, repairing permissions etc.. and the iMac networks wirelessly with the MacBook Pro fine.

    Any help much appreciated! Thanks
     
  17. mattwolfmatt macrumors 65816

    mattwolfmatt

    Joined:
    Jun 7, 2008
    #17
    Also having the same 3689 communication failure message when trying to sync appletv.

    I haven't heard anyone else with this problem, but on the AppleTV all the movies I handbraked all show up, but the ones I actually bought from itunes/apple tv aren't on the AppleTV. All of the movies are on itunes and the appropriate boxes are checked.

    This is frustrating. Any tips? Thanks.
     
  18. Duffinator macrumors 6502

    Duffinator

    Joined:
    Sep 3, 2007
    Location:
    130 miles NE of Cupertino
    #18
    I'm experiencing a similar problem. I've had my ATV for over 18 months and always used an Ethernet connection and never had an issue. I've moved my ATV into a dedicated stereo system using WiFi connection and it usually connects for streaming audio and shows up in iTunes and on my D-Link software. I'm using a D-Link DIR-655 Extreme N Gigabit router with a PC using XP Pro. After a period of time it loses the connection and can't find my iTunes library. It will still show in iTunes and my D-Link software and has a 4-5 bar signal strength on the ATV. A few times an error message comes up and asks to restart the ATV. From a couple of other wireless devices I see several of my neighbors networks and I'm wondering if I'm having some interference problem.

    BTW, my ATV, iTunes, and Touch were all updated this week with the latest software updates. Any ideas what's going on?
     
  19. Mr Dominator macrumors newbie

    Joined:
    Dec 6, 2008
    #19
    Port 3689 Problem

    Wow - I have about the same exact issue as jbellanca, and have tried the same fixes to no avail (even down to 3 Apple TVs). Has anyone resolved this issue?:(
     
  20. tb1712 macrumors newbie

    Joined:
    Nov 26, 2008
    #20
    Vista

    Wow, same issue here. Vista 64-bit, iTunes 8.0.2, ATV 2.3

    The ATV has been working flawlessly for over a year, until I changed it to Manual Sync. As soon as I clicked "sync" I got the Port 3689 issue and haven't been able to resolve it.

    If I restart iTunes, I can see my entire library on the ATV and play a movie. If I stop the movie though, it seems to lose the connection.

    I've tried about everything. It's REALLY frustrating.
     
  21. moniquetx macrumors member

    Joined:
    Sep 25, 2008
    Location:
    Dallas, TX
    #21

    I just tried this, see my other post here

    http://forums.macrumors.com/showthread.php?p=6817426&posted=1#post6817426

    Apple TV now works great (well syncs as supposed to) under XP.
     
  22. MagnusVonMagnum macrumors 601

    MagnusVonMagnum

    Joined:
    Jun 18, 2007
    #22
    I've got two AppleTV units and one is for audio only at the moment on my high-end audio rig (will get a flat screen to put above my digital piano in the near future). I've run into various issues over the past year with them, but the audio only one seems to act up far more than the one connected to my home theater. Just today, I opened iTunes (both of them and my PowerMac that serves them are up 24/7) and the 2nd unit was missing from the device list. I rebooted the PowerMac but it didn't show up. I had to pull the power plug from the AppleTV unit (why they couldn't include a simple reset button is beyond me; clearly they think their software is perfect and never needs rebooted...hahahaha). It then reappeared in iTunes and works as usual.

    But I've had times where both units disappeared and a reboot of the PowerMac fixed it. Other times, all I needed to do was quit iTunes and restart it. And one time I had to move the audio only unit downstairs to connect it to a video source and found that it wouldn't connect to my NetGear router for reasons unknown (reported an 'error' when connecting) yet it would connect to my 2nd Network OK (Apple Airport Express "N") that I keep around so my primary NetGear "N" network doesn't get slowed down by devices like my iPod Touch that I use as a remote. After several attempts, it suddenly DID connect to my Netgear router OK and I took it back upstairs (which reboots of course) and it was working fine again (for awhile until today when I had to reboot it again to get it to show in iTunes).

    The weird thing is that when it does disappear from iTunes and reappears after an AppleTV reboot, if you do operate the unit with a monitor connected, the unit appears to be working just fine, except it's lost the streamed material to it. Why it needs a reboot is beyond me but that seems to fix it for iTunes most of the time (if that doesn't work then a reboot of the PowerMac running iTunes will fix it). I've never run into a situation where the units couldn't be made to connect period for more than a few minutes as above.

    Tests I've done transferring a long song such as "Dogs" by Pink Floyd (18+ minutes) in Apple Lossless have revealed even with recent updates to the Airport Express, etc., the Netgear router is usually 20-50% faster than the Airport Express N for transferring large files (usually 400k/sec on Airport and 650k/sec on the Netgear). I can't help but wonder if Apple purposely cripples their Airport Express units compared to a regular Airport Extreme. Both are running one channel and are on different frequences (and both set on different frequencies compared to other nearby wireless networks). I've also tried changing channels to compare and the Airport Express is always significantly slower and hence I tend to use it with B/G devices like the iPod Touch.

    For reference, my MBP can get over 800k/sec on the same NetGear network (but it gets over 50MB/sec (that would be maxing out its internal hard drive) using wired Gigabit so when it's docked in my den, I go wired). My PowerMac gets over 70MB/sec over Gigabit using a high speed 7200RPM Sata drive and Sonnet PCI card as does my PC with its Gigabit card and 7200RPM drives when talking to each other.

    One other annoying thing I've noticed about AppleTV after renting dozens of movies is that about 1/8 movies, I will get an "error" during the movie that says the movie couldn't finish downloading. I then have to stop the movie and go to the settings/computers/downloads menu and click on the download to 'retry/restart' the movie and then go back to watching it. It is utterly BEYOND ME why I should have to go to that menu to retry. Why can't the darn thing retry automatically and then I wouldn't even NOTICE that it had an issue downloading while watching it! No one likes to pause a movie for something like that. I'd report the bug/issue to Apple, but I've already reported many other ones and they haven't fixed a single one I've sent them in two years so I don't think they read and/or care about user bug reports. Once again, Apple has proven to me that their customer service just plain sucks.
     
  23. DaddySam macrumors newbie

    Joined:
    May 11, 2011
    #23
    apple tv is not responding itunes

    All of a sudden my iTunes showed: "Apple TV is not responding... Make sure your Firewall is not blocking Port 8068...".

    After a comprehensive research and many trials I discovered the problem was due to the installation of a "Network Range Extender".

    As soon as the Extender was disconnected, the problem disappeared.
    There might be a solution by re-configuring the extender, but at least for now the problem is solved

    Hoping this helps
     

Share This Page