Apple TV problems on TVOS 11

Discussion in 'Apple TV and Home Theater' started by imahawki, Nov 2, 2017.

  1. imahawki, Nov 2, 2017
    Last edited: Nov 2, 2017

    imahawki macrumors 6502a

    Joined:
    Apr 26, 2011
    #1
    A little background, I'm a big movie guy and have three 3rd gen ATVs and two 4th gen and have ripped all of my sizeable DVD and Blu-Ray collection to my Synology NAS.

    I've had some issues over the years where Apple TVs would say they couldn't see my library and closing iTunes and re-opening it would usually fix the problem. Since TVOS 11 though it has been a freaking nightmare. Often times I'll go into the movies area and the movies on screen (i.e. the top of my alphabetical list) will play fine but if I scroll down to the Ms or Ts nothing will play and the movie icons will be generic gray boxes instead of cover art. Sometimes restarting iTunes will fix this but sometimes it won't. Sometimes if I click on the movie any way it will eventually play, most of the time it won't.

    It has been such a nightmare problem that I actually deleted my library file and re-added all my media. This was a HUGE pain in the ass (just as one example I had to go back and manually set 232 movies as unwatched and lost all of my date added and last watched data which was actually useful to me) and it didn't fix the problem. I'm at my wits end.

    I'm a pretty ace troubleshooter based on past experience and I can't figure out why it is behaving so badly. I ALMOST wish nothing worked but why will the first 20 movies play and then some random block of movies in the R section play but nothing above or below that? It is maddening.

    Other than the TVOS upgrade, the only other thing that has changed is I actually swapped out my iTunes server. I was running it off my daily use iMac but I got rid of that for a 2017 MacBook pro so I'm running my old MacBook Air as the server. It is sitting right in my equipment rack and is configured to never sleep and even has a widget installed to keep it awake when the screen is shut. Obviously it works some time so I don't know if it is a network issue, server issue, TVOS issue or what.

    Any ideas?

    Specs/Relevant Info
    "Server" is a 2011 MacBook Air 13" with 4GB of RAM
    Media is stored on Synology DS1515+
    Library files are stored on Synology DS1515+ with alias placed in the standard location on the server's local drive
    Library file is only about 7MB
    Media includes ~1500 movies and is about 6TB total size
     
  2. Danger_Man macrumors newbie

    Joined:
    Jul 8, 2017
    #2
    To try and rule out the old MacBook Air, what happens if you use the 2017 MacBook Pro as the server?
    For these types of connectivity issues please send feedback or a bug report if you have a developer account.

    https://www.apple.com/feedback/appletv.html
    https://developer.apple.com/bug-reporting/

    Also include a sysdiagnose as this will help track down the issue.

    https://download.developer.apple.com/iOS/tvOS_Logs/sysdiagnose_Logging_Instructions.pdf
     
  3. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #3
    It doesn't work any better when running the library off of my brand new MacBook pro. I feel like I've narrowed the problem down to just EXTREME slowness. My kids are trying to watch a movie in the living room. I scroll down to it and of course its the gray box logo like 90% of the movies past the top few and I press enter. It doesn't work so I walk back to the den to start replying to your post and literally like 2-3 minutes later my daughter yells "its working". I can do more troubleshooting and see if it consistently works if you just wait forever but that shouldn't be the case IMO. It's all local so my internet speed is not at play. I have a 2nd generation EERO with 3 total access points, and if I do a speedtest everything is blazing fast.
     
  4. Hermes Monster macrumors 65816

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #4
    Have you tried using something like Infuse to see if performance is any better? Try pointing Infuse at your NAS, and if it’s still slow, I think it’s safe to say it’s a network issue rather than iTunes issues.
     
  5. Danger_Man macrumors newbie

    Joined:
    Jul 8, 2017
    #5
    You could try connecting your Apple TV and MacBook directly into the same router to see if that helps to narrow down the issue.
     
  6. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #6
    The solution was ridiculous and still baffling. I took a video but haven't uploaded it anywhere. Basically any gray box movie (missing cover art) wouldn't play. If I went into Computers -> Movies the top movies always had cover art. If I scrolled down, line by line, the cover art would fill in for each movie, line by line. If I jumped way ahead say from C to M, then the cover art would never fill in. I had to go line by line and wait for cover art to appear.

    Not this never impacted my Gen 3 Apple TVs and I had no problems with TVOS 10.x. Whatever this was was clearly an 11.x issue.
     

Share This Page